Subject: (ngtrans) NUD over configured tunnels

From: Sowmini Varadhan <[email-masked]>
Date: Tue, 16 Nov 1999 16:52:56 -0500 (EST)

For the purpose of  Neighbor-Discovery (specifically, NUD),
do bidirectional configured tunnels have a link-layer address?

If possible, it would be nice to see something approximating one of 
the following two statements added to Section 3.8 ("Neighbor Discovery 
over Tunnels") of draft-ietf-ngtrans-mech-04.txt:

        For purposes of Neighbor Discovery, a tunnel is
        considered to have link-layer addresses, the
        link-layer addresses being those in the encapsulating
        header.  Therefore, link-layer address options
        SHOULD be included in ND messages sent over
        configured bidirectional tunnels.

or:

        For purposes of Neighbor Discovery, a tunnel is
        considered to not have link-layer addresses.
        Therefore, link-layer address options MUST NOT
        be included in ND messages sent over configured
        bidirectional tunnels.

--Sowmini

---

From: Erik Nordmark <[email-masked]>
Date: Tue, 16 Nov 1999 22:30:04 -0800 (PST)

> do bidirectional configured tunnels have a link-layer address?

Good question.
Since it is a pt-pt link there is no use sending around link-layer addresses
in ND messages.

What do implementations do today?

Have you observed interoperability problems relating to this issue?

>         be included in ND messages sent over configured

I suspect the MUST NOT will be too strong.
Unless we can show that no implementation sends link-layer address options
options over bidirectional configured tunnels I suspect we need to say
	An implementation MUST be able to handle link-layer address options
	in received ND messages sent over configured
	bidirectional tunnels.
	An implementation SHOULD (or SHOULD NOT?) send such link-layer address 
	options.

  Erik

---

From: Francis Dupont <[email-masked]>
Date: Wed, 17 Nov 1999 11:15:10 +0100

=> I believe this is the good argument.

=> ignore link-layer at receiving side, don't add link-layer at the
sending side.

=> all junk things, for instance redirects with strange link-layer
addresses are filtered out by sanity checks: no problem.

=> I agree, there is no interoperability problem then MUST is too strong.

=> SHOULD NOT!

Thanks

[email-masked]