Subject: (ngtrans) Fwd: BIND 8.2.2-P3 release announcement

From: Marc Blanchet <[email-masked]>
Date: Mon, 08 Nov 1999 21:47:19 -0500

Well, this has been discussed in this morning ngtrans. So issue is closed: 
not only patches exists for bind from kame, but the official bind source is 
now IPv6-enabled on *BSD.

Regards, Marc.

>To: [email-masked]
>Subject: BIND 8.2.2-P3 release announcement
>Date: Mon, 08 Nov 1999 16:13:01 -0800
>From: Paul A Vixie <[email-masked]>
>X-Approved-By: [email-masked]
>Sender: [email-masked]
>X-original-sender: [email-masked]
>List-unsubscribe: <mailto:[email-masked]?Subject=unsubscribe>
>
>-----BEGIN PGP SIGNED MESSAGE-----
>
>Some highlights vs. BIND 8.2.2:
>
>         Portability to IPv6 versions of FreeBSD, OpenBSD, NetBSD.
>         Portability improvements (A/UX, AIX, IRIX, NetBSD, SCO, MPE/IX).
>         "also-notify" option could cause memory allocation errors.
>         IXFR improvements (though client-side is still disabled).
>         Contributed software upgraded (including TIS's "dns_signer").
>         Several latent denial-of-service bugs fixed (from audits, not abuse).
>         New "make noesw" top-level target for removing encumbered components.
>
>Distribution files are:
>
>ftp://ftp.isc.org/isc/bind/src/8.2.2-P3/bind-src.tar.gz
>ftp://ftp.isc.org/isc/bind/src/8.2.2-P3/bind-doc.tar.gz
>ftp://ftp.isc.org/isc/bind/src/8.2.2-P3/bind-contrib.tar.gz
>
>PGP signature files are:
>
>ftp://ftp.isc.org/isc/bind/src/8.2.2-P3/bind-src.tar.gz.asc
>ftp://ftp.isc.org/isc/bind/src/8.2.2-P3/bind-doc.tar.gz.asc
>ftp://ftp.isc.org/isc/bind/src/8.2.2-P3/bind-contrib.tar.gz.asc
>
>MD5 checksums are:
>
>93e7de4b50db1c87f645747017eb4e1c bind-contrib.tar.gz
>bf22215d79cee700f24841e466a825b5 bind-contrib.tar.gz.asc
>42025ab4bed0f13ab612ec5984abe2f0 bind-doc.tar.gz
>ef77a4fe54f4f7babd013f511f67ba87 bind-doc.tar.gz.asc
>c782af1a8058d6d2d3c95c1385a5c8c0 bind-src.tar.gz
>5ae5d5dfc716d62393f0d6ff201a4285 bind-src.tar.gz.asc
>
>top of CHANGES says:
>
>         --- 8.2.2-P3 released ---
>
>  891.   [bug]           options { also-notify { ... }; }; resulted in wrong
>                         pointer being memput with the wrong size on reload.
>
>  890.   [port]          A/UX portability improved.
>
>  889.   [port]          added IPv6 portability for OpenBSD, NetBSD, FreeBSD.
>
>         --- 8.2.2-P2 released (internal release) ---
>
>  888.   [support]       add default: all tag to top src/Makefile so that 
> "make"
>                         will work properly in some OS'.
>
>  887.   [bug]           "dig ... axfr" was printing spurious "TSIG ok" msgs.
>
>  886.   [support]       top-level Makefile now included in all tarballs.
>
>  885.   [support]       IXFR improvements.
>
>  884.   [bug]           some deprecated NXT RR forms weren't ignored 
> properly.
>
>  883.   [support]       "host" command can now try to verify dnssec 
> signatures.
>
>  882.   [contrib]       dns_signer/ had some last minute problems (by 
> author).
>
>  881.   [bug]           possible sprintf() overflow prevented.
>
>  880.   [support]       minor tweak to bin/dig/dig.c TSIG code to clarify
>                         whether res_nsend or res_nsendsigned is being used.
>
>  879.   [support]       add "noesw" target to top-level Makefile (for PL1).
>
>  878.   [port]          aix4 HAS_INET6_STRUCTS was not being set based on the
>                         existance of _IN6_ADDR_STRUCT.
>
>  877.   [port]          freebsd + KAME need a different Makefile.set
>                         see INSTALL notes.
>
>  876.   [port]          IPv6 probe for MPE/IX, NetBSD.
>
>  875.   [bug]           bad NAPTR RRs could be loaded from zone files.
>
>  874.   [port]          update irix_patch in irix port.
>
>  873.   [port]          add SRC/tools to sco's make [std]links.
>
>         --- 8.2.2-REL released ---
>...
>
>-----BEGIN PGP SIGNATURE-----
>Version: 2.6.2
>Comment: Processed by Mailcrypt 3.4, an Emacs/PGP interface
>
>iQCVAwUBOCdnAm2DN4pRurLtAQHK2AP+PglM2wSggv5TMRdWNFGD7LIJdnkiJfC8
>/PEArt5+3ghbeCWxi78ap9XsuaaCdwg3p6Kw3nlr3gma4v9V4eChxoI3lzUXnQcC
>3pTvqB2ujionOhJddO1jem9r+yVl9xbYmALeQkTI4h6acxwUi91NkxbB2XAUO+af
>U8opAalijvs=
>=5lRd
>-----END PGP SIGNATURE-----

-----------------------------------------------------------
Marc Blanchet			| [email-masked]
Viagénie inc.			| http://www.viagenie.qc.ca
2875 boul. Laurier, suite 300	| tél.: 418-656-9254
Ste-Foy, Québec		| fax.: 418-266-5539
Canada, G1V 2M2		| radio: VA2-JAZ
------------------------------------------------------------
Internet Engineering Standards/Normes d'ingénierie Internet
                http://www.normos.org
------------------------------------------------------------

---

From: [email-masked]
Date: Tue, 09 Nov 1999 14:12:43 +0900

>now IPv6-enabled on *BSD.

	This version of BIND does not do IPv6 transport ready AFAIK.
	It just compiles fine even if  *BSD/KAME is installed, that's all.

itojun