Subject: (ngtrans) Re: Question about NAT-PT

From: Pyda Srisuresh <[email-masked]>
Date: Sun, 28 Nov 1999 08:06:17 -0800 (PST)

NAT-PT modifies the IP and UDP headers of an IP packet with RTP stream, 
as the packet traverses between V6 and V4 realms. Clearly, NAT-PT is 
compute intensive, as each packet is subject to lookup and modifications.  
This could result in increased latency and reduceded router throughput.
However, if the processing capacity of NAT-PT exceeds line processing 
rate, this should not be a problem.

cheers,
suresh

--- "Jonas Malmkvist (ETX)" <[email-masked]> wrote:
> Hi,
> 
> I have a question about the performance of the NAT-PT protocol.
> 
> Do you think that the use of NAT-PT would add a significant delay to the
> end-to-end communication?
> I'm thinking of a scenario where a v6-host and a v4-host are communicating
> using a real-time application like Voice over IP.
> Of course this question is hard to answer since it is dependent of the
> specific implementation.
> 
> I would appreciate any information and guidance.
> Please reply to my e-mail address, since I'm not on the ngtrans mailing list.
> 
> Regards,
> Jonas Malmkvist, Ericsson
> 
> [email-masked]
> 
> 

__________________________________________________
Do You Yahoo!?
Thousands of Stores.  Millions of Products.  All in one place.
Yahoo! Shopping: http://shopping.yahoo.com

---

From: Peter Tattam <[email-masked]>
Date: Mon, 29 Nov 1999 12:25:37 +1100 (EST)

> rate, this should not be a problem.

Except that the checksum has commutative properties which would result in
only incremental modifications to the packets...  typically not an issue to
recalculate though given typical traffic patterns.  My NAT does two passes, the
first to verify that packet is ok before translation, the second to
recalculate.  The second pass could be incremental, but the cost is relatively
low for the bandwidth typically used with the product.

Peter

--
Peter R. Tattam                            [email-masked]
Managing Director,    Trumpet Software International Pty Ltd
Hobart, Australia,  Ph. +61-3-6245-0220,  Fax +61-3-62450210