Subject: (ngtrans) Bump-in-the-stack

From: Kornel Szegedi <[email-masked]>
Date: Wed, 09 Feb 2000 10:28:11 +0100

Hi,

 I have a question about BIS.
 BIS is useful for IPv4 applications to communicate with both IPv4 and
IPv6 hosts. Is it possible for IPv6 applications to work with BIS? I
mean that if az IPv6 packet arrives, it will be translated to IPv4 by
the tranlator module without examining that it is addressed to an IPv6
or an IPv4 application.

Thanks,

        Kornel Szegedi

---

From: Fabrizio Invernizzi <[email-masked]>
Date: Wed, 09 Feb 2000 10:43:50 +0100 (MET)

Hi.

I think that, in theory, a BIS would translate only IPv4->IPv6 and
IPv6->IPv4 traffic.

I installed an hitachi BIS (the only one i know to exist) on a windows NT
machine and it works great for IPv4 application (I use winamp IPv4, for
example), but if i try to use IPv6 applications (for example sdr whith
MSR6 stack) these don't work.

Fabrizio

---

From: Kazuaki Tsuchiya <[email-masked]>
Date: Wed, 09 Feb 2000 23:27:41 +0900

Hi Ngtrans folks,

At 10:43 00/02/09 +0100, Fabrizio Invernizzi wrote:
> I think that, in theory, a BIS would translate only
> IPv4->IPv6 and IPv6->IPv4 traffic.
> 
> I installed an hitachi BIS (the only one i know to exist)
> on a windows NT machine and it works great for IPv4 appli-
> cation (I use winamp IPv4, for example), but if i try to
> use IPv6 applications (for example sdr whith MSR6 stack)
> these don't work.
> 

Yes, that's right. But it is a Hitachi Toolnet6's
implementation issue, not a BIS technical issue.
If we implement an "Extension Name Resolver" as
follows, Toolnet6 would be able to communicate with
other IPv6 hosts using pure IPv6 applications/stack.

"Extension Name Resolver":

  When an "Extension Name Resolver" gets an IPv6
  address, as an answer to a query which tries to
  resolve 'AAAA' records for a target host name, the
  resolver returns the IPv6 address to IPv6 applica-
  tions as is. 
    * Note that in the case there is no need for
      the IP conversion by a translator.

Thanks.

-- Kazuaki Tsuchiya, Hitachi.

------------------------------------------------------------
Kazuaki Tsuchiya (mailto:[email-masked])
  Hitachi,Ltd. Enterprise Server Division
    Phone: +81-46-235-8268(Dial-in) Fax: +81-46-235-8324

---

From: Lajos Szabo <[email-masked]>
Date: Thu, 10 Feb 2000 11:21:29 +0100

Kazuaki Tsuchiya wrote:

 >    the IP conversion by a translator

Ok, that's clear. We speak about the communication which is triggered by
the IPv6 only host. In this case the packet reaches the dual host and
the mapper tries to find a mapping entry for the source and destination
address. The destination address will be the dual host's IPv4 address
and the mapper will assign one to the source address. Then the
translation will be done automatically (whether it's needed or not).
So I don't see how the IPv6 application on the IPv6 only host can
communicate with the IPv6 application on the dual host.
Is that possible?

          Lajos Szabo

---

From: Kazuaki Tsuchiya <[email-masked]>
Date: Mon, 14 Feb 2000 10:57:40 +0900

Lajos,

Terribly sorry for my misunderstanding what you asked.

Yes, you are right. When communication is triggered by
the IPv6 only host and the IPv6 packets arrive at BIS,
it doesn't know whether it should toss them to IPv4
applications after translating them into IPv4 packets
or it should toss them to IPv6 applications as is. In
the case BIS cannot but translate them into IPv4 auto-
matically. So BIS cannot communicate with the IPv6 only
host using the IPv6 application. That is BIS technical
issue.