Subject: RE: (ngtrans) Re: draft-ietf-ngtrans-6to4-06.txt

From: "Dave Thaler" <[email-masked]>
Date: Tue, 15 Aug 2000 12:39:15 -0700

Brian Carpenter writes:
> Scott Bradner wrote:
> >   This mechanism has significant scaling issues 
> particularly in regards to
> >   the growth of the routing table.  
> 
> But this is not really the case. Basic 6to4 adds one entry, 
> 2002::/16, to the 
> native IPv6 routing table. There are scaling issues for 
> massive numbers of tiny 
> sites- covered by Tony's draft - and I do need to add a 
> statement that the base
> document does not cover that situation. (Tony's draft wasn't out when
> this -06 draft was done.) So I agree that scaling should be 
> mentioned but the
> words will be a bit different.

Right, even with Tony's draft, no additional prefixes are injected
into the v6 infrastructure.  The v6 infrastructure has exactly
one additional prefix (2002::/16).

With Tony's draft (if I understand it correctly), the 6to4 
*site* adds additional prefixes to the internal tables on 
the 6to4 site gateway router (and doesn't advertise them).
In the worst case, the number of prefixes on a site router 
will be the number of prefixes in the v6 infrastructure 
that are known to relays.

Tony's draft can say this, but I don't see any scaling
problems with the base 6to4 draft.

-Dave

---

From: "Tony Hain" <[email-masked]>
Date: Thu, 24 Aug 2000 15:49:35 -0700

Dave's understanding is correct, in this version of the draft the only
place that routing tables grow is the site gateway that is keeping track
of the prefix/relay mappings. My guess about the IESG concern is that
there will always be those that want to optimize their entry point onto
the link (existing IPv4 infrastructure) based on some policy. While the
native IPv6 network is relatively flat, the nearest 2002::/16 prefix
announcement is likely to fill most policy concerns. When there is
hierarchy in the native IPv6 space, it will be less clear which path to
2002::/16 fits the policy in both the IPv6 space and across the IPv4
based link, or if it will even be possible to align those policies.
Neither document deals with this problem, but since it is a scale issue
(native space growth), it would make more sense to add it to mine with
notes in the base doc that these are concerns. We really do need to get
the base doc out the door. 
 
Tony
 
-----Original Message-----
From: Dave Thaler 
Sent: Tuesday, August 15, 2000 12:39 PM
To: Brian E Carpenter; Scott Bradner
Cc: [email-masked]
Subject: RE: (ngtrans) Re: draft-ietf-ngtrans-6to4-06.txt

-Dave