Subject: (ngtrans) Dual Stack Mobility + Use of MIPv6 CCoA

From: [email-masked]
Date: Tue, 22 Aug 2000 13:52:43 +0100

All,

As promised, this draft shows how IPv4 based communications can be
supported by a dual stack mobile node that only supports Mobile IPv6
(MIPv6). The aim is to use MIPv6 for mobility services while the
Mobile can still use its dual stack capabilities for IPv4
communications without the need for translation.

This draft is also relevant to recent discussions on the IPng list regarding
use of CCoA as source address in Mobile IPv6 Spec. In the draft we use the
MIPv6 CCoA to request an IPv4 address from the local DHCPv6 server (ala
DSTM).

Regards
George

> -----Original Message-----
> From:	[email-masked] [SMTP:[email-masked]]
> Sent:	Tuesday, August 22, 2000 12:08 PM
> To:	IETF-Announce
> Subject:	I-D ACTION:draft-tsirtsis-v4-over-mipv6-00.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> 
> 
> 	Title		: IPv4 over Mobile IPv6 for Dual Stack nodes
> 	Author(s)	: G. Tsirtsis, A. O'Neill, S. Corson
> 	Filename	: draft-tsirtsis-v4-over-mipv6-00.txt
> 	Pages		: 4
> 	Date		: 21-Aug-00
> 	
> In this document we show how IPv4 based communications can be
> supported by a dual stack mobile node that only supports Mobile IPv6
> (MIPv6). The aim is to use MIPv6 for mobility services while the
> Mobile can still use its dual stack capabilities for IPv4
> communications without the need for translation.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-tsirtsis-v4-over-mipv6-00.txt
> 
> Internet-Drafts are also available by anonymous FTP. Login with the
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-tsirtsis-v4-over-mipv6-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-tsirtsis-v4-over-mipv6-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.

---

From: "Shiao-Li Charles Tsao" <[email-masked]>
Date: Thu, 24 Aug 2000 09:35:55 +0800

Dear All, 

Sorry for interrupting you.
The IPv4/IPv6 interworking problems seems to involve both Mobile IP and IPv4/IPv6 transition issues. We also have a draft which is relevant to this topic. The document specifies mechanisms to solve mobility problems in IPv4 and IPv6 interconnected networks for IPv4 or IPv6 mobile nodes. The solution adopts dual stack model that implements a new address mapper on mobile nodes. The dual stack model with the address mapper can facilicate the mobility services for IPv4 or IPv6 mobile nodes in between IPv4 and IPv6 networks. You can get it from the following URL, if you are interested in it
http://www.ietf.org/internet-drafts/draft-tsao-mobileip-duelstack-model-00.txt

I appreciate your suggestions and comments. Thank you.

Best Regards,

Shiao-Li Tsao

---

From: Francis Dupont <[email-masked]>
Date: Thu, 24 Aug 2000 11:10:34 +0200

In your previous mail you wrote:

   The IPv4/IPv6 interworking problems seems to involve both Mobile IP and
   IPv4/IPv6 transition issues. We also have a draft which is relevant to
   this topic.

=> George's draft (draft-tsirtsis-v4-over-mipv6-00.txt) is very different,
he doesn't propose an integrated IPv4/IPv6 mobility but something very
simple (ie. trivial :-) based on two remarks:
 - new mobile phone infrastructures will be based on IPv6 (mainly because
   the lack of addresses in IPv4)
 - mobile phones will be dual stack hosts (because this is the safe way
   and this is not too expensive)
then a transition mechanism like DSTM which uses IPv4 over IPv6 tunnels
will be able to use freely/transparently all IPv6 devices like mobile IPv6
(I think George has EMA in mind but this applies too).

Regards

[email-masked]

---

From: "Shiao-Li Charles Tsao" <[email-masked]>
Date: Thu, 24 Aug 2000 18:01:58 +0800

Thanks for your comments. 

Yes, George's draft is different from the Mobile IPv4/v6 Interworking proposal(draft-tsao-mobileip-duelstack-model-00.txt). However, these two drafts can be used to solve some of the mobility problems in IPv6/IPv4 interworking. That is why I pose the related draft on the mailing list. 

Regards,
Shiao-Li