Subject: (ngtrans) DSTM addressing

From: "Hesham Soliman (EPA)" <[email-masked]>
Date: Fri, 15 Sep 2000 00:12:45 +1100

Hello George and DSTM authors, 

Thanks for the comments on the draft and sorry for the very
late reply. 

I do believe it is important to come up with a solution / 
recommendation for handling the IPv4 address assignment
based on IPv4 hosts' DNS lookups. Jim mentioned that there
will be a draft ready for San Diego, would it be possible
to have something there to address this problem ?

Erik and myself discussed it briefly and we thought that 
one way to do it may be to allocate IPv4 addresses for a 
"short" time, and let the IPv6 host request the time extension 
if it sees that it still needs it (ie. if it is actually 
a legidimate communication with an IPv4 host). 

Of course the length of time for the initial allocation 
would depend on how many IPv4 addresses are in the pool
amongst other factors, and perhaps it should be configurable
in the AIIH server. 

I don't know how feasible this is but it would be good to 
hear people's opinions. 

Cheers,
Hesham

---

From: Francis Dupont <[email-masked]>
Date: Thu, 14 Sep 2000 15:36:03 +0200

In your previous mail you wrote:

   I do believe it is important to come up with a solution / 
   recommendation for handling the IPv4 address assignment
   based on IPv4 hosts' DNS lookups.

=> I believe this is about the removed scenario 2 aka AIIH.

   Jim mentioned that there
   
=> it was in previous DSTM drafts (then it is still available,
if you can't get previous drafts, I can send them to you).

   a legitimate communication with an IPv4 host). 
   
=> there are many possible policies but the only real problem is
that there is a bit easy to consume the whole IPv4 address pool,
even with a short time, ie. there is a possible denial of service attack.

=> if this can't avoid the DOS, it has a little interest.

   I don't know how feasible this is

=> just need a processor which can handle basic arithmetic operations (:-).

   but it would be good to hear people's opinions. 
   
=> now you know mine... This is a problem shared by any scheme where
allocations can be triggered by an action "from the outside".

Regards

[email-masked]

PS: the scenario 1 without DHCPv6 is already implemented and works well.