Subject: RE: (ngtrans) An IPv4 anycast address for 6to4<->6bone gateways

From: "Dave Thaler" <[email-masked]>
Date: Fri, 27 Oct 2000 16:00:32 -0700

This was mentioned in the NGtrans meeting in Pittsburgh, 
and no such an anycast address doesn't currently exist.

What would be needed would be to get a prefix short 
enough to pass the prefix length filters in the Internet,
and then just use 1 of the addresses in that large prefix.

(Some would argue that having packets take the scenic
route as you describe is desirable, however.)

-Dave

> -----Original Message-----
> From: Brad Huntting [mailto:[email-masked]]
> Sent: Friday, October 27, 2000 2:46 PM
> To: f.johan.beisser
> Cc: [email-masked]; [email-masked]; 
> [email-masked]
> Subject: (ngtrans) An IPv4 anycast address for 6to4<->6bone gateways
> 
> 
> 
> > http://www.kfu.com/~nsayer/6to4/
> 
> Actually this web page brings up another issue that a freind and
> I were discussing just yesterday.  Anyone who's actually tried to
> use 6to4 (2002::/16) has probably noticed that they need a default
> route to reach the 6bone.  But even assuming you actually find such
> a router it is almost always on the far side of the Internet; which
> means that your packets get to take the scenic route on their way
> to the 6bone.
> 
> One simple solution to this would seem to be to use a well known
> IPv4 "anycast" address (call it "a.b.c.d" for now) for all 6to4
> gateways.
> 
> In this way, anyone using 6to4 could reliably use 2002:(a.b.c.d)::1
> (actual IPv6 address syntax will vary) as a default route to the
> 6bone.
> 
> 6to4 gateways would advertise to the their IPv4 peers that they
> have a route for "a.b.c.d".  And for their IPv6 peers (the 6bone)
> they can advertise a route for 2002::/16.
> 
> Does anyone see a problem with this?  I dont suppose there's already
> a block of IPv4 address space set aside for anycast?
> 
> 
> brad

---

From: "Dave Thaler" <[email-masked]>
Date: Mon, 30 Oct 2000 10:20:45 -0800

Dan Lanciani <[email-masked]> writes:
> |(Some would argue that having packets take the scenic
> |route as you describe is desirable, however.)
> 
> What is the argument for this?

I've heard two arguments so far:

1) The business motivation for an ISP to deploy a 6to4 relay
   is probably more likely to be that an IPv6-native ISP wants
   to provide good connectivity to its IPv6-native customers 
   from 6to4 sites.  A relay close to the 6to4 site would
   probably not be the site's ISP or the native destination's
   ISP... it would probably be some third party ISP's relay
   which would be used for transit and may have lousy 
   connectivity.  Using the relay closest to the native 
   destination would more closely match the v4 route,
   and quite possibly provide a higher degree of reliability.
   So the "scenic" route can actually be less scenic.

2) For the immediate future where IPv6 packets aren't
   forwarded in hardware by the majority of IPv6 routers,
   it can be faster to forward IPv6-in-IPv4 encapsulated 
   packets than to forward IPv4 native packets
   (i.e. if the bottleneck is the pps forwarding rate
   and not the BW overhead of encapsulation).  As a result,
   the "scenic" route can actually have higher performance.

-Dave

---

From: Dan Lanciani <[email-masked]>
Date: Fri, 27 Oct 2000 21:42:44 -0400 (EDT)

|What would be needed would be to get a prefix short
|enough to pass the prefix length filters in the Internet,
|and then just use 1 of the addresses in that large prefix.

Or for less waste, somebody could just donate a pre-CIDR class-C.  Are
there any ISPs of any significance that don't exempt them from the prefix
length constraints?

				Dan Lanciani
				[email-masked]