Subject: (ngtrans) RE: rfc 2765 corrections!

From: [email-masked]
Date: Wed, 14 Mar 2001 18:42:14 +0200

> The problem in the SIIT case is that the SIIT translator might not see
> the ICMPv6 packet too big message (there can be multiple 
> independent SIIT
> boxes for a site) due to assymetric routing.
> Thus the box that does IPv4->IPv6 might not be able to track
> the current MTU.
> The box that does IPv6->IPv4 translation would deliver an 
> ICMPv4 packet too big
> but when the IPv4 sender doesn't implement pmtu discovery 
> this is of no help.

But we are doing ipv6-side path mtu discovery from the siit box itself. Thus
pmtu discovery is an end-to-end affair between the siit box's ipv6 interface
and destination ipv6 interface. So there is no question of another siit box
coming in between. I guess it should work.

-------------       v6 side
siit box # 1 | ---------------- dest v6 host 
-------------

regards,
imran

---

From: Erik Nordmark <[email-masked]>
Date: Wed, 14 Mar 2001 18:18:06 +0100 (CET)

> coming in between. I guess it should work.

The issue is that the source address of the IPv6 packets is assigned
to the IPv4 host and not assigned to the SIIT box itself.
Thus any ICMPv6 packet too big messages, as well as any other packets
destined to the IPv4 endpoint, will be routed towards the IPv4 endpoint.
Along this path there must be one SIIT box, but it might not be the same SIIT
box as the one sitting on the other path. Thus you can have

IPv4 host --- Cloud -- SIIT A ---- Cloud --- IPv6 host
                |                    |
                ------ SIIT B --------

In this case packets from 4 to 6 might go through SIIT A but the reverse path
might go through SIIT B.

Does that make things more clear.

  Erik