Subject: RE: (ngtrans) Sites with multiple 6to4 border routers

From: George Tsirtsis <[email-masked]>
Date: Fri, 23 Mar 2001 12:09:36 -0500

-----Original Message-----
From: Christian Huitema [mailto:[email-masked]]
Sent: Friday, March 23, 2001 10:50 AM
To: [email-masked]
Cc: Vladislav Yasevich; George Tsirtsis; NGTRANS List
Subject: RE: (ngtrans) Sites with multiple 6to4 border routers

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> >> I believe that's what Brian Carpenter, Tony Hain, and Dave Thaler
were
> >> saying the meeting.   You have to use a globaly IPv4 address to
> >> create a 6to4 prefix.  I don't beleave you can assign the same IPv4
> >> address to 2 independent devices...
> >Uh? There is nothing impossible there. Suppose that we have a
> >multi-homed site that connects to the Internet through multiple
routers,
> >both of which advertise the same IPv4 prefix, say 123.123.1/23.
> 
> 	i guess you are talking about different thing from Vladislav
said:
> 
> >        /-------\                   /------
> >        |       | +-+               |
> >        |       +-+A+---------------+
> >        |       | +-+               |
> >        | Site  |                   | Internet
> >        |       | +-+               |
> >        |       +-+B+---------------+
> >        |       | +-+               |
> >        \-------/                   \-----
> 
> 	George: A and B both uses nd 2002:xxxx:xxxx::/48.  A uses
x.x.x.x,
> 		B uses y.y.y.y.
> 	itojun: it is problematical when B uses y.y.y.y and
> 2002:xxxx:xxxx::/48,
> 		due to filtering rule on the other side.
> 	Vladislav: George's way is hard.  also, A and B both using
x.x.x.x
> 		and 2002:xxxx:xxxx::/48 is hard.
> 	Christian: A uses x.x.x.x and 2002:xxxx:xxxx::/48, B uses
y.y.y.y
> 		and 2002:yyyy:yyyy::/48.

No. When I say that "It is quite natural to reserve a single IPv4
address for the 6to4 routing service", I mean that A and B both use
2002:xxxx:xxxx::/48; both A and B use x.x.x.x. They advertise different
addresses in the IPv6 cloud; they advertise the same IPv4 prefix (say
x.x.x/24) to the Internet; the routing of outward bound packets is
determined by IPv6 routing inside the site, e.g. RIPng; the routing of
packets from the Internet is determined by Internet routing protocols
(e.g. BGP).

GT> Indeed! The requirement for 2 or more 6to4 gates to be able to use the
same 6to4 prefix is that they advertise the same ipv4 prefix in the IPv4
Internet. Up to now it has been assumed that they only advertise a single
IPv4 address but this is clearly not necessary.

GT> In this case, mechanisms that require outgoing and incoming paths to be
using the same 6to4 gate could make use of Alain's 6to4 designated address.

George

---

From: Vladislav Yasevich <[email-masked]>
Date: Fri, 23 Mar 2001 11:38:31 -0600

Well, that just shows how much I know... :)

However, I still don't see a need for a special address for
6to4 routers.  The DSTM mechanism can provide the TEP and
it might as well provide the 6to4 address of the router (not
any speciall address).

May be DSTM might be extended to privide multiple TEPs and
let the implementation choose one (or cycle through them)?
Just a thought.  This way we don't have to reserve a speciall
address.

-vlad