Subject: (ngtrans) Re: suggestion on draft-ietf-ngtrans-bgp-tunnel-01.txt

From: Dirk Ooms <[email-masked]>
Date: Thu, 26 Apr 2001 08:49:06 +0200

Francois,

The draft was intended to be tunnel type agnostic, but as you correctly
pointed out there are still some references to IP tunnels.  I will make
sure that this will be corrected in the next version (your point (a)). 
If there is anything specific for IP tunnels I will move it to a
separate section (your point (b)), if you have any specific text for
another type of tunnel I will be happy to include it in the draft.

Thanks for your comment,
dirk

Francois Le Faucheur wrote:
> 
> Dirk,Jeremy,Gerard,Tri,Stuart,
> 
> As per my conversation with some of you, I would like to make a suggestion
> on the draft :
> 
> My perception is that:
>         - the technique described in bgp-tunnel draft can work with other tunnels
> than IPv4 tunnels (eg IPv4 tunnel, MPLS LSPs,..)
>         - it is indeed useful/beneficial for implementors to also apply this
> technique to other tunnels than IPv4 (eg MPLS LSPs)
>         - the current draft recognises this, but as currently written, the draft
> is not quite completely independent of tunneling technology, because it
> sort of implies IPv4 tunneling in a few places
> 
> So my suggestion would be to update the draft so that it is written in a
> generic way and does not unnecessarily restrict tunneling techniques. To do
> so, I would propose to:
>         - (a) adjust "tunneling technique independent" text to remove
> IP-v4-tunneling specifics
>         - (b) where some tunneling techniques require some specific details, cover
> those details in a "tunneling technique specific" section (b)
> 
> For instance, (a) would involve (probably not exhaustive list):
>         -  in section 5: do not restrict SAFI to 1/2/3 only. eg. it would be 1/2/3
> if tunneling is IPv4 but could be another value if tunneling is MPLS.
>         - in section 6:  2nd paragraph. rather than "normal IPv4 do the job", we
> could have something like "non-secured tunnels (IPv4, MPLS LSPs) can do the
> job..."
>         - in section 8: clean up text to avoid statement like "The method in this
> draft could be extended to using LSPs instead of IP tunnels,..."
> 
> For instance, (b) would involve a few MPLS-specifics for the case of
> tunneling over MPLS LSPs (eg. possibility to use two levels of label with
> labels advertised in MP-BGP, SAFI=4 [TBC] in that case). This could go in a
> new section or could be bundled with existing section 8.
> 
> What do you guys think about the principle of making the draft generic?
> What do you think something like (a) and (b) are a good way to achieve this?
> 
> Thanks for your views
> 
> Francois
> 
> PS: If you agree on this, I can propose specific draft text.

-- 
Dirk Ooms                       mailto:[email-masked]
                                tel:+32 3 2404732
Network Strategy Group (NSG)    http://aww.alcatel.com/nsg
Alcatel                         http://www.alcatel.com

---

From: Francois Le Faucheur <[email-masked]>
Date: Thu, 26 Apr 2001 13:46:43 +0200

Dirk,

>another type of tunnel I will be happy to include it in the draft.

Great.
I will provide you with some draft text for the MPLS specifics.
Francois

>>         - (b) where some tunneling techniques require some specific
details,
cover
>>         -  in section 5: do not restrict SAFI to 1/2/3 only. eg. it
would be
1/2/3
>>         - in section 8: clean up text to avoid statement like "The
method in
this
>> PS: If you agree on this, I can propose specific draft text.
PLEASE NOTE NEW CONTACT DETAILS - See below

_________________________________________________________________
Francois Le Faucheur   
Development Engineer, IOS Layer 3 Services 
Cisco Systems 
Office Phone:          +33 4 97 23 26 19
Mobile :               +33 6 89 108 159
Fax:                   +33 4 97 23 26 26
Email:                  [email-masked]
_________________________________________________________________
Cisco Systems Europe
Domaine Green Side
400, Avenue de Roumanille
Bâtiment T3
06 410   BIOT 
SOPHIA ANTIPOLIS
FRANCE
_________________________________________________________________

---

From: Francois Le Faucheur <[email-masked]>
Date: Wed, 25 Apr 2001 17:10:42 +0200

My perception is that:

Thanks for your views

Francois