Subject: (ngtrans) SIIT question? RFC2765

From: "Daniel G Waddington" <[email-masked]>
Date: Mon, 9 Apr 2001 10:08:44 -0400

Hi,

Can someone explain to me why the SIIT proposal does not seem to infer a
need to recalculate UDP and TCP checksums at the translator.  Surely by
translating the IP header the respective UDP/TCP pseudo header has changed
and therefore needs recalculating?  I think I'm missing something.

DAN

=======================================
 Dr. Daniel G. Waddington
 Bell-labs, Lucent Technologies
 Room 4F-615, 101 Crawfords Corner Rd
 Holmdel, NJ
 [email-masked] [732 949-3959]
=======================================

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 9 Apr 2001 16:58:59 +0200

> and therefore needs recalculating?  I think I'm missing something.
	=> You don't need to recalculate the pseudo headers. The 
	checksum is the same as it is for the IPv4 addresses
	due to the format of the IPv4-mapped and IPv4-translated 
	IPv6 addresses. 

	Hesham

---

From: [email-masked]
Date: Mon, 9 Apr 2001 18:03:02 +0300

> and therefore needs recalculating?  I think I'm missing something.

That is because SIIT uses special addresses called IPv4 mapped &
translatable addresses which are such that the higher order 96 bits always
have zero checksum..

But note that for nat-pt you need to recalculate the checksums.

imran