Subject: (ngtrans) problem ping6-ipv4 in nat-pt-linux

From: Ravikanth Samprathi <[email-masked]>
Date: Thu, 10 May 2001 10:13:01 -0700

Hi
I have the following problem with nat-pt in linux.

SETUP:-
-------------
I have 2 hosts h1 and h2 both linux-2.4.0.
h1 is ipv6.
h2 is ipv4 and ipv6 dual stack.
in h1, eth0 is ipv6 (fec0::2/96).
in h2, eth1 is ipv6 (fec0::1/96) and eth2 is ipv4 (10.0.0.1/16).

SOFTWARE:-
---------------------
i am running nat-pt in h2.
(http://www.ipv6.or.kr/english/linux-usermode-natpt-install.txt)
The prefix i am using is fec0:0:0:0:0:ffff.
I added a static route in routing table of h1
route -A inet6 add fec0:0:0:0:0:ffff:10.0.0.1/96 dev eth0

PROBLEM:-
------------------
I am not able to talk (ping6) with eth2-of-h2 from eth0-of-h1.
Ping6 from h1:-
ping6 fec0:0:0:0:0:ffff:10.0.0.1

OUTPUT:-
---------------
This is the output of ping6 at h1:-
PING fec0:0:0:0:0:ffff:10.0.0.1(fec0:0:0:0:0:ffff:a00:1) 56 bytes
 From ::1: Destination unreachable: Address unreachable
 From ::1: Destination unreachable: Address unreachable
 From ::1: Destination unreachable: Address unreachable
 From ::1: 
Destination unreachable: Address unreachable
 From ::1: Destination 
unreachable: Address unreachable

This is the output of tcpdump from eth1 of h2:-
08:43:35:273492 fec0::2 > ff02::1:ff00:1: icmp6: neighbor sol:
who has fec0::ffff:a00:1
08:43:35:273492 fec0::2 > ff02::1:ff00:1: icmp6: neighbor sol:
who has fec0::ffff:a00:1
08:43:35:273492 fec0::2 > ff02::1:ff00:1: icmp6: neighbor sol:
who has fec0::ffff:a00:1
08:43:35:273492 fec0::2 > ff02::1:ff00:1: icmp6: neighbor sol:
who has fec0::ffff:a00:1
08:43:35:273492 fec0::2 > ff02::1:ff00:1: icmp6: neighbor sol:
who has fec0::ffff:a00:1

QUESTIONS:-
--------------------
Can somebody help me with configuration
of nat-pt please???
Is the prefix i am using wrong?? Is the way i ping6 wrong?
Is the way i am adding static route in h1 wrong?
What is going wrong?

I would greatly appreciate the help.
Thanx,
ravi
--------------------------------------------------->
Ravi Samprathi   work:(408)853-8038
Cisco Systems   res  :(408)988-2268
Empowering the  Internet Generation
<---------------------------------------------------

---

From: Pekka Savola <[email-masked]>
Date: Thu, 10 May 2001 21:39:44 +0300 (EEST)

> I have the following problem with nat-pt in linux.

[snip]

Could you please stop spamming this on different lists?  You've posted
without proper Cc: independently on [email-masked] and
[email-masked] already, and received a reply there too.

I think is is a routing problem; you shouldn't define dec0::ffff to be
on-link because it is not; you should add the route so that the traffic
to these addresses go to the dual stack host.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords