Subject: Re: (ngtrans) NAT-PT: DNS ALG question

From: Remco van de Meent <[email-masked]>
Date: Mon, 2 Jul 2001 11:24:25 +0200

Suresh Satapati wrote:
> I wanted to know what would be the correct behavior for the following
> scenario.
> 
> An IPv6 client host sends a AAAA query, thru NAT-PT, to a DNS server
> in IPv4 cloud. NAT-PT RFC says that a AAAA need to be sent
> untranslated, along with a translated 'A' query. If the DNS server
> has AAAA records to reply, the additional records may end up having
> 'A' records (or IPv4 addresses). These would make no sense to the
> IPv6 client.  Should NAT-PT also translate such records, to convert A
> to AAAA ? The RFC really doesnt say anything like that.

The DNS_ALG should convert the A response in a quad-A reponse,
embedding the IPv4 address in a pre-configured prefix (see
draft-ietf-ngtrans-translator-03.txt).

cheers,
Remco.

---

From: George Tsirtsis <[email-masked]>
Date: Tue, 10 Jul 2001 05:12:09 -0400

-----Original Message-----
From: Suresh Satapati [mailto:[email-masked]]
Sent: Wednesday, June 27, 2001 3:26 AM
To: [email-masked]
Subject: (ngtrans) NAT-PT: DNS ALG question

Hi,

An IPv6 client host sends a AAAA query, thru NAT-PT, to a DNS server in IPv4

cloud. NAT-PT RFC says that a AAAA need to be sent untranslated, along with 
a translated 'A' query. If the DNS server has
AAAA records to reply, the additional records may end up having 'A'
records (or IPv4 addresses). These would make no sense to the IPv6 client. 
Should NAT-PT also translate such records, to convert A to AAAA ? The RFC 
really doesnt say anything like that.

GT> It actually does! I had to go back and check...it has been a while...
See top of page 12 of RFC2766:
"  If there is an A record for Node-C the reply also returns to the
   NAT-PT. The DNS-ALG then, translates the reply adding the appropriate
   PREFIX and forwards it to the originating device with any IPv6
   addresses that might have learned. So, if the reply is

      NodeC    A     132.146.243.30, it is translated to
      NodeC   AAAA   PREFIX::132.146.243.30 or to
      NodeC    A6    PREFIX::132.146.243.30"

George