Subject: (ngtrans) Re: Question about draft-ietf-ngtrans-introduction...

From: Alain Durand <[email-masked]>
Date: Mon, 17 Sep 2001 14:54:37 -0700

This diuscussion is the topic of NGtrans, not IPng,
so I've redirect the thread here.

Chae-yong Chong wrote:

> Hi
>
> When I read a draft "An overview of the introduction of IPv6 in the internet"
> I got some ambigous statement in 4.1.3
>
> 4.1.3 Tunnel Broker
> ...
>
> IPv4 address requirements : 1
> ...
>
> What does that "1" means? Does that mean Tunnel Broker's IPv4 address?
> In other section, there always some more description like "1 per host" or ">=1 per site"
>
> In my understanding that should be corrected like "1 per host".

Some tunnel brokers may offer you a complete prefix and not just one address.
In this particular case, the IPv4 address requirement will be: 1 per site
If the tunnel broker offer you only one IPv6 address, then the requirement becomes
1 per host.

Thanks for catching this, I will update the draft.

    - Alain.

---

From: Pekka Savola <[email-masked]>
Date: Tue, 18 Sep 2001 08:58:51 +0300 (EEST)

> Thanks for catching this, I will update the draft.

Looking at the draft, there might be room for additional clarifications
wrt. the term "IPv4 address requirements".

It seems implicit that we're talking about _global_ IPv4 addresses here.
Under some circumstances, tunnel broker could be used in a certain
topology so that you can use private IPv4 addresses too, which will
usually make the IPv4 address requirement moot.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

---

From: "Chae-yong Chong" <[email-masked]>
Date: Thu, 20 Sep 2001 14:28:13 +0900

Hi..

I'm not sure the same question was posted already. If so, sorry for my duplicated question.

In BIS, when non-IPv6 application want to send a packet to IPv6 host, the Extension Name Resolver
translate IPv4 DNS query message(Type 'A') to IPV6 DNS query message(type "A6" or "AAAA").
Does the Extension Name resolver need to know the target node's hostname is IPv6' node?
If so, how does the Extension Name Resolver know the translation(type "A" to "A6" or "AAAA" is required?

And the draft-ietf-ngtrans-introduction-to-ipv6-transition-07.txt said that

   IPv6 requirements:          none 
   IPv6 address requirements:  none 

But RFC2767 said that

2.3 Address Mapper

...

   NOTE: There is only one exception. When initializing the table, it
   registers a pair of its own IPv4 address and IPv6 address into the
   table statically.

I think this means that IPv4 host which implement must has native IPv6 address.
So the "IPv6 address requirement" in draft must be changed to "1 per host".

Chae-yong

--------------------------------------------
Chae-yong Chong

Samsung Electronics Co. Ltd
E-mail : [email-masked]
--------------------------------------------

---

From: Kazuaki Tsuchiya <[email-masked]>
Date: Thu, 20 Sep 2001 18:05:06 +0900

Hi,

>If so, how does the Extension Name Resolver know the translation(type "A" to "A6" or "AAAA" is required?

When BIS wants to send packets to a host(IPv4 or IPv6)
using IPv4 applications, the Extension Name Resolver
makes an IPv6 DNS query message from an IPV4 DNS query
message, and sends both messages to a DNS server.

o When the target node is an IPv4 host, the server returns
   an "A" record to BIS.

o When the target node is an IPv6 host, the server returns
   an "AAAA" record to BIS.

So BIS can know whether the target node is IPv4 or IPv6
automatically. There is no need to know whether the target
node is IPv4 or IPv6 in advance.

>    registers a pair of its own IPv4 address and IPv6 address into the

This just means that BIS needs an IPv6 address for
speaking in IPv6.

Thanks.

-- Kazuaki Tsuchiya, Hitachi.

------------------------------------------------------------
Kazuaki Tsuchiya, Hitachi.
   http://www.v6.hitachi.co.jp
   mailto:[email-masked] (NEW!)
   mailto:[email-masked]

---

From: "Chae-yong Chong" <[email-masked]>
Date: Fri, 21 Sep 2001 08:47:59 +0900

I add some comment for your reply.

----- Original Message ----- 
From: "Kazuaki Tsuchiya" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, September 20, 2001 6:05 PM
Subject: Re: (ngtrans) Another question about RFC2767 and draft-ietf-ngtrans-introduction-...

> message, and sends both messages to a DNS server.

Does that mean the Extension Name Resolver always translate the DNS query
whether it is for an IPv4 node or IPv6 node? If not, how does Extension Name Resolver
know the target is IPv4 or IPv6?
Is there any difference in DomainName for IPv4 or IPv6?

> This just means that BIS needs an IPv6 address for

In my understanding the purpose of BIS is using the non-IPv6 application
in IPv4 node when that node want to communicate the other IPv6 only node.
The BIS implemented IPv4 node should got an IPv6 address. If not, why use
the BIS?