Subject: Re: (ngtrans) Another question about RFC2767 and draft-ietf-ngtrans-introductio

From: Kazuaki Tsuchiya <[email-masked]>
Date: Fri, 21 Sep 2001 09:52:35 +0900

Firstly, thanks for feeling interest in BIS.

At 18:23 01/09/20 +0900, [email-masked] wrote:
> > When BIS wants to send packets to a host(IPv4 or IPv6)
> > using IPv4 applications, the Extension Name Resolver
> > makes an IPv6 DNS query message from an IPV4 DNS query
> > message, and sends both messages to a DNS server.
>
>Does that mean the Extension Name Resolver always translate the DNS query
>whether it is for an IPv4 node or IPv6 node? If not, how does Extension Name Resolver
>know the target is IPv4 or IPv6?
>Is there any difference in DomainName for IPv4 or IPv6?

At first, BIS does not know whether the target node is IPv4
or IPv6. So the Extension Name Resolver always translates
the DNS query, and sends queries for both 'A' and 'AAAA.'
                                      ~~~~~~~~~~~~~~~~~~~~
And as a result of the reply, BIS gets to know whether the
target node is IPv4 or IPv6.

> > >    NOTE: There is only one exception. When initializing the table, it
> > >    registers a pair of its own IPv4 address and IPv6 address into the
> > >    table statically.
> > 
> > This just means that BIS needs an IPv6 address for
> > speaking in IPv6.
> > 
>
>In my understanding the purpose of BIS is using the non-IPv6 application
>in IPv4 node when that node want to communicate the other IPv6 only node.
>The BIS implemented IPv4 node should got an IPv6 address. If not, why use
>the BIS?

Exactly right. BIS can communicate with other IPv6 hosts using
existing IPv4 applications. So BIS needs only one IPv6 address
for self when speaking in IPv6.
~~~~~~~~
Best regards.

-- Kazuaki Tsuchiya, Hitachi.

------------------------------------------------------------
Kazuaki Tsuchiya, Hitachi.
   http://www.v6.hitachi.co.jp
   mailto:[email-masked] (NEW!)
   mailto:[email-masked]

---

From: "Chae-yong Chong" <[email-masked]>
Date: Fri, 21 Sep 2001 10:12:53 +0900

Thanks..
I got an clear answer for my question. :-)
Extension Name Resolver's action which translate type "A" to
type "A" AND type"AAA" is clearly described in RFC. I missed it. Sorry.

Chae-yong