Subject: (ngtrans) Re: [mobile-ip] IPv4 and MIPv6 Transition

From: "Shiao-Li Charles Tsao" <[email-masked]>
Date: Fri, 26 Oct 2001 08:30:24 +0800

Hello, 

This approach was also addressed in "Moving in a Dual Stack Internet" <http://www.ietf.org/internet-drafts/draft-ietf-ngtrans-moving-00.txt>. 
It is a WG draft in NGTRANS. However, this approach can be only applied to a MN with a co-located IPv4 address in the visited IPv4 network. To work with NAT and DHCP in the visited IPv4 network, it seems a pratical scenario and should be further investigated. 

Charles Tsao

----- Original Message ----- 
From: "KASSI-LAHLOU Mohammed FTRD/DMI/CAE" <[email-masked]>
To: <[email-masked]>
Sent: Thursday, October 25, 2001 7:41 PM
Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

Hello,

If the MN and the HA are dual-stack, the solution could be the following:
On the home network, the MN receives an Ipv6 RA with the H bit set and an
Ipv4 RA with the H bit set.
When the MN arrives on the visited Ipv4 network, it acquires an Ipv4 CoA
(co-located CoA) and tunnels Ipv6 BU in Ipv4 packets to its HA.
The HA intercepts Ipv6 packets intended for the MN and tunnels them to the
MN in Ipv4 packets.
The MN tunnels Ipv6 packets intended for the CN in Ipv4 packets to the HA.
The HA decapsulates the packets and sends them directly to the CN.

The same solution can be used when the CN is Ipv4 and the visited network is
Ipv6.

I do not know any developments about this but it could be a new work item.

Kassi

-----Message d'origine-----
De : Eng Soo Guan [mailto:[email-masked]]
Envoyé : mercredi 24 octobre 2001 11:07
À : [email-masked]
Objet : Re: [mobile-ip] IPv4 and MIPv6 Transition

Thanx for your reply.

I read the SITT and DSTM draft. My question is that MN is using DSTM. But
there are possible cases where MN cannot obtain a "IPv4 Global Addresses".
As such, the SITT and DSTM solution is not what I am looking for.

If a MN visits a foreign IPv4 network running NAT and DHCP (and no 6to4,
Tunnel Broker or 6over4 stuff), how can the MN sends a Binding Update to its
Home Agent in IPv6? Can the MN uses some configuration information it has
when it was previously at home to access the 6Bone?

The best candidate I see it Shipworm. I'm wondering if anyone has come
across other proposals.

SG
Soo Guan, Eng
R&D Engineer (Software Lab)
Centre for Wireless Communications, NUS
http://www.cwc.nus.edu.sg
Tel (65) 8709330
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
----- Original Message -----
From: Hesham Soliman (EPA)
To: [email-masked]'
Sent: Wednesday, October 24, 2001 3:12 PM
Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

Hello Eng,
There is another draft you can find at:
http://standards.ericsson.net/hesham/draft-ietf-ngtrans-siit-dstm-00.txt
It's a WG draft in NGTRANS but it expired and I'll
resubmit it after adding some of the comments received.
Cheers,
Hesham

-----Original Message-----
From:   Eng Soo Guan [SMTP:[email-masked]]
Sent:   Wednesday, 24 October 2001 12:04
To:     [email-masked]
Subject:        [mobile-ip] IPv4 and MIPv6 Transition
Dear All,
I would like to know if any work has being done with regard to 'transiting'
to Mobile IPv6 with IPv4 Internet, especially with Mobile Node behing a NAT.
The closet drafts I find are "Mobile IPv4 Traversal Across NAT and VPN
Gateways" and "Mobility Support for IPv4 and IPv6 Interconnected Networks
based on Dual-Stack Model".
I read found the NGTRANS Shipworm draft attractive to be modified for MIPv6
in a IPv4 only network behind a NAT.
Warmest regards.
SG
Soo Guan, Eng
Centre for Wireless Communications, NUS
http://www.cwc.nus.edu.sg
~~~~~~~~~~~~~~~~~~~~~~~~~~~~

---

From: "???" <[email-masked]>
Date: Mon, 29 Oct 2001 16:26:32 +0900

Also, we are working on this now. 
You can find our paper, which will be sent to IETF as a darft soon.
The tile is "requirements for 4to6 mobility transition using hierarchical mobility."

Up to date, since the effects of considering mobile node roaming in IPv4/IPv6 transition networks have not been investigated fully, we propose the requirements and analysis of diferent routing architecture of <IPv4/MIPv6 transition network.

We are working on the problem solving mechanism according to the requirements.

Please refer to:
http://hard.korea.ac.kr/~ccl/research/draft_kahng_ngtrans_hdsma-00.txt

  -----Original Message-----
  From: [email-masked] [mailto:[email-masked]]On Behalf Of Shiao-Li Charles Tsao
  Sent: Friday, October 26, 2001 9:30 AM
  To: [email-masked]
  Cc: [email-masked]
  Subject: (ngtrans) Re: [mobile-ip] IPv4 and MIPv6 Transition

  Hello, 

  Charles Tsao

  ----- Original Message ----- 
  From: "KASSI-LAHLOU Mohammed FTRD/DMI/CAE" <[email-masked]>
  To: <[email-masked]>
  Sent: Thursday, October 25, 2001 7:41 PM
  Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

  Hello,

  Kassi

  -----Message d'origine-----
  De : Eng Soo Guan [mailto:[email-masked]]
  Envoyé : mercredi 24 octobre 2001 11:07
  À : [email-masked]
  Objet : Re: [mobile-ip] IPv4 and MIPv6 Transition

  Thanx for your reply.

  SG
  Soo Guan, Eng
  ----- Original Message -----
  From: Hesham Soliman (EPA)
  To: [email-masked]'
  Sent: Wednesday, October 24, 2001 3:12 PM
  Subject: RE: [mobile-ip] IPv4 and MIPv6 Transition

  Hello Eng,

  -----Original Message-----
  From:   Eng Soo Guan [SMTP:[email-masked]]
  Sent:   Wednesday, 24 October 2001 12:04
  To:     [email-masked]
  Subject:        [mobile-ip] IPv4 and MIPv6 Transition
  Dear All,
  I would like to know if any work has being done with regard to 'transiting'
  to Mobile IPv6 with IPv4 Internet, especially with Mobile Node behing a NAT.
  The closet drafts I find are "Mobile IPv4 Traversal Across NAT and VPN
  Gateways" and "Mobility Support for IPv4 and IPv6 Interconnected Networks
  based on Dual-Stack Model".
  I read found the NGTRANS Shipworm draft attractive to be modified for MIPv6
  in a IPv4 only network behind a NAT.
  Warmest regards.
  SG
  Soo Guan, Eng