Subject: Re: (ngtrans) Re: I-D ACTION:draft-kahng-ngtrans-hdsma-00.txt

From: Pekka Savola <[email-masked]>
Date: Fri, 2 Nov 2001 08:43:35 +0200 (EET)

On Thu, 1 Nov 2001, Shiao-Li Charles Tsao wrote:
> > - if MN is IPv6-only, Home Agent is reachable without translation via IPv6
> > (tunneling ok)
> > - if MN is IPv4-only, Home Agent is reachable without translation via
> > IPv4 (also, tunneling ok)

What about these?

The draft mentions NAT-PT, SIIT etc. and I don't see why if these 
assumptions would hold.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

---

From: "Shiao-Li Charles Tsao" <[email-masked]>
Date: Fri, 2 Nov 2001 17:39:14 +0800

----- Original Message -----
From: "Pekka Savola" <[email-masked]>
To: "Shiao-Li Charles Tsao" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, November 02, 2001 2:43 PM
Subject: Re: (ngtrans) Re: I-D ACTION:draft-kahng-ngtrans-hdsma-00.txt

> > > IPv4 (also, tunneling ok)

I don't quite understand the above two scenarios. If MN is IPv6-only for
example, its home network and home agent should be also IPv6. If MN moves to
IPv6 or dual stack visited networks, HA is basically reachable via IPv6 (or
through tunneling, if home network and visited network are connected by IPv4
cloud). If MN moves to IPv4-only network, it loses its connectivity.  Could
you please explain them more ?  Thanks.

Charles Tsao

---

From: "???" <[email-masked]>
Date: Tue, 13 Nov 2001 15:37:20 +0900

Please see below;

Charles Tsao
=============================================================

For the above question....

As you know, there are 24 cases(see below table).
Under the assumptions that the mobile node is either IPv4-only or IPv6-only, but not both, 
there are 8 cases that the connections are lost.
For example, in case of [case 21] below, connection is lost.
However,  under the situation that the wired or wireless IPv6 networks co-exist with  the wired or wireless IPv4 networks for a while, the cases like 5,6,7,9,13,14,21 and 23 should be considered, too.

we are now considering the possibility that the above problems can be solved with minor modifications. 
I hope that soon we will present it by the end of this year.

+----+-------------+----------------------+------------------------+-------------+--------------+
|     |     MN     |  Home Network  Visited Network | IPv4 CN  | IPv6 CN   |
+----+-------------+----------------------+------------------------+-------------+--------------+
|  1  | IPv4-only |  IPv4-only        |  IPv4-only          |  IPv4       | TM          |
|  2  |               |  IPv4-only        |  IPv4-dual          |  IPv4       | TM          |
|  3  |               |  IPv4-dual        |  IPv4-only          |  IPv4       | TM          |
|  4  |               |  IPv4-dual        |  IPv4-dual          |  IPv4       | TM          |
|  5  |               |  IPv6-dual        |  IPv6-only          |   n/s       | n/s           |
|  6  |               |  IPv6-dual        |  IPv6-dual          |   n/s       |  n/s          |
|  7  |               |  IPv4-only        |  IPv6-only          |   n/s       |  n/s          |
|  8  |               |  IPv4-only        |  IPv6-dual          |  IPv4       | TM          |
|  9  |               |  IPv4-dual        |  IPv6-only          |   n/s        | n/s          |
| 10 |               |  IPv4-dual        |  IPv6-dual          |  IPv4       | TM          |
| 11 |               |  IPv6-dual        |  IPv4-only          |  IPv4       | TM          |
| 12 |               |  IPv6-dual        |  IPv4-dual          |  IPv4       | TM          |
+-------------+----------------------+------------------------+-------------+--------------+
| 13 | IPv6-only |  IPv4-dual        | IPv4-only           |   n/s       |  n/s         |
| 14 |               |  IPv4-dual        |  IPv4-dual          |   n/s       |  n/s         |
| 15 |               |  IPv6-only        |  IPv6-only          |    TM      |  IPv6       |
| 16 |               |  IPv6-only        |  IPv6-dual          |    TM      |  IPv6       |
| 17 |               |  IPv6-dual        |  IPv6-only          |    TM      |  IPv6       |
| 18 |               |  IPv6-dual        |  IPv6-dual          |    TM      |  IPv6       |
| 19 |               |  IPv4-dual        |  IPv6-only          |    TM      |  IPv6       |
| 20 |               |  IPv4-dual        |  IPv6-dual          |    TM      |  IPv6       |
| 21 |               |  IPv6-only        |  IPv4-only          |   n/s       |  n/s         |
| 22 |               |  IPv6-only        |  IPv4-dual          |    TM      |  IPv6       |
| 23 |               |  IPv6-dual        |  IPv4-only          |   n/s       |  n/s         |
| 24 |               |  IPv6-dual        |  IPv4-dual          |    TM      |  IPv6       |
+--- +\\\----------+----------------------+------------------------+-------------+--------------+
n/s: not supported
TM: Transition Mechanism (e.g. tunneling, Sock-base IPv4/IPv6 Gateway, etc. except Translator)

---

From: Pekka Savola <[email-masked]>
Date: Tue, 13 Nov 2001 09:41:43 +0200 (EET)

> I hope that soon we will present it by the end of this year.

My point in the above two cases was that IMO, we should not care about the 
combinations that require _translation_.