Subject: (ngtrans) Looking for NAT-PT Implementation.

From: S P <[email-masked]>
Date: Thu, 13 Dec 2001 14:41:47 -0800 (PST)

Hi,

I'm looking for a NAT-PT implementation. I believe BT
has one as described in the following, but could not
access it. I would appreciate if you could point me to
an open implementation.

Regards,
ps

NAT-PT announcement.

--------------------------------------------------------------------------------

To: [email-masked] 
Subject: NAT-PT announcement. 
From: [email-masked] 
Date: Thu, 13 May 1999 11:54:17 +0100 
Sender: [email-masked] 

--------------------------------------------------------------------------------

Dear 6BONE community,

I'm forwarding this announcement on behalf of the
NAT-PT development team
because I think the previous announcement did not get
through this important
list, sorry if you are receiving this twice.

NAT-PT is a v4/v6 translator developed in BT Labs
which allows transparent
bidirectional communication between IPv4 and IPv6
networks, the translator
includes a DNS ALG which ensures true transparency and
makes the major
difference between this and other translators. Please
see below for more
detailed information on NAT-PT.

We have tested the NAT-PT and we are very proud of how
it works, we firmly
believe and hope that the NAT-PT development will help
boost IPv6 deployment
and proves useful for the transition to IPv6. For this
purpose we make
available the software including the source code.

We encourage you to download NAT-PT (see below) and
try it, we welcome any
feedback, comments, bug report, etc, and you can
obtain support mailing the
NAT-PT development team at:

[email-masked]

Thanks,

Antonio Herrera
BT Laboratories
Martlesham Heath, UK.

************** NAT-PT ***************
BT have developed an implementation of NAT-PT (Network
Address Translation -
Protocol Translation) which is based on the IETF draft
specification
<draft-ietf-ngtrans-natpt-05.txt> 
http://search.ietf.org/internet-drafts/draft-ietf-ngtrans-natpt-05.txt.
NAT-PT provides a seamless 
bi-directional translation capability between IPv4 and
IPv6 networks. NAT-PT
is located on the 
boundary router between IPv4 and IPv6 and translates
all packets crossing
the boundary and where
necessary assigns a global IPv4 address to represent
an IPv6 host. DNS is a
vital
component of NAT-PT as it allows hosts to communicate
across the boundary by
knowledge 
of DNS addresses and negates the need for end hosts to
be concerned about
the 
destination host network type of IP address.

The implementation developed in BT resides on a
FreeBSD host using the Kame
IPv6 stack
for connection to the IPv6 network. We are making the
implementation
available to
promote the draft specification, which was jointly
written by BT and Lucent,
and also
the concept of NAT-PT as an IPv4/IPv6 translation
mechanism.

We have two sites from which the NAT-PT implementation
may be downloaded
from.
http://nat-pt.ipv6.bt.net is a 6bone web site.
Alternatively
http://www.labs.bt.com/technical/nat_pt/
provides the same access via the Internet. We do ask
that you identify
yourself
prior to downloading the code so that we can gauge the
level of interest and
for the
notification of code updates. If you would like to
send us comments or
report bugs
please reply to this email address

[email-masked]

__________________________________________________
Do You Yahoo!?
Check out Yahoo! Shopping and Yahoo! Auctions for all of
your unique holiday gifts! Buy at http://shopping.yahoo.com
or bid at http://auctions.yahoo.com

---

From: "Sean Lin" <[email-masked]>
Date: Wed, 19 Dec 2001 13:21:11 +1300 (NZDST)

Hi,
	Well, the following are implementations that i know of
 -the  microsoft implementation has one. www.research.microsoft.com/msripv6
- xBSDs has the faithd transport relay translator, don't have an exact 
link but u can try www.kame.net
- there's the TTB IPv6/IPv4 Translator . http://www.ydc.co.jp/IT/ip/TTB/index.html.

Hope that helps.

Regards,
Sean

Date sent:      	Thu, 13 Dec 2001 14:41:47 -0800 (PST)
From:           	S P <[email-masked]>
Subject:        	(ngtrans) Looking for NAT-PT Implementation.
To:             	[email-masked]
Copies to:      	[email-masked], [email-masked]
Send reply to:  	S P <[email-masked]>

> access it. I would appreciate if you could point me to

-------------------------------------------------------------
Sean Lin                 27 Nazareth Avenue
Software Engineer        PO Box 8011
Allied Telesyn Research  Christchurch
phone +64 3 339 3000     New Zealand
fax   +64 3 339 3002     email: [email-masked]
                         web: http://www.alliedtelesyn.co.nz/
-------------------------------------------------------------

---

From: Feico Dillema <[email-masked]>
Date: Wed, 19 Dec 2001 01:58:38 +0100

> link but u can try www.kame.net
xBSDs also has NAT-PT by Kame project. If you're looking for
sourcecode, you can browse kame source code for example here:

http://cvsweb.no.netbsd.org/bsdweb.cgi/?cvsroot=Kame

Feico.

---

From: Nathan Lutchansky <[email-masked]>
Date: Thu, 20 Dec 2001 00:03:01 -0500

> - there's the TTB IPv6/IPv4 Translator . http://www.ydc.co.jp/IT/ip/TTB/index.html.

I would like to add to this list pTRTd, which is a portable TRT I've been 
working on.  For the moment, it only runs on Linux 2.4.x, but it should be 
easy to port to other Unix-like systems since it doesn't depend on kernel 
support for TRT functions.  The site is here:

http://v6web.litech.org/ptrtd/

-Nathan

-- 
+-------------------+---------------------+------------------------+
| Nathan Lutchansky | [email-masked] |  Lithium Technologies  |
+------------------------------------------------------------------+
|  I dread success.  To have succeeded is to have finished one's   |
|  business on earth...  I like a state of continual becoming,     |
|  with a goal in front and not behind. - George Bernard Shaw      |
+------------------------------------------------------------------+