Subject: RE: (ngtrans) Review of draft-ietf-ngtrans-shipworm-03.txt

From: "Christian Huitema" <[email-masked]>
Date: Mon, 28 Jan 2002 15:08:19 -0800

One of the reviewers' comments was a "doubt whether MS is serious about
others being able to implement the protocol." Allow me to put that one
to rest. The intent is indeed to produce a specification that anyone can
use. You may have observed that the document was submitted in full
compliance with IETF rules, and that we have not mention any particular
intellectual property claim.

-- Christian Huitema

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Tue, 29 Jan 2002 01:34:11 +0100

I know that this is probably more a policy than a technical discussion, but I can't stop myself this time ;-)

I'm not on the side of any vendor, but I fully support any initiative, as is the case for Teredo, that will push for the IPv6
deployment.

NAT's are the evil that stop IPv6 deployment, and provide a false "security" to users.

We all must push, as NGTRANS WG, any protocol that help the Internet to recover the end-2-end perspective, broken by NAT.

We have thousands of reasons (no need to comment, I guess) to work on this or similar protocols that allow the users work with IPv6
and thus push their providers for a faster transition.

If other vendors do not support our WG work, they aren't serious with IPv6. Indeed, I'm sure we will see soon a lot of
implementations.

Sorry if this is uncomforting anybody.

Regards,

Jordi Palet

----- Original Message -----
From: "Christian Huitema" <[email-masked]>
To: "Randy Bush" <[email-masked]>
Cc: "NGtrans List" <[email-masked]>
Sent: Tuesday, January 29, 2002 12:08 AM
Subject: RE: (ngtrans) Review of draft-ietf-ngtrans-shipworm-03.txt

> intellectual property claim.

---------------------------------------------------------------------------------------
Europe Drives IPv6 Deployment
www.ipv6-es.com
Madrid 2002 Global IPv6 Summit

---

From: Randy Bush <[email-masked]>
Date: Mon, 28 Jan 2002 16:11:28 -0800

> NAT's are the evil that stop IPv6 deployment

i always wondered what was inhibiting v6 deployment.  it's a relief to
finally find a simple devil to hate.  </sarcasm>

i suspect that concentrating on more real and less religious issues may be
more productive.

> We all must push, as NGTRANS WG, any protocol that help the Internet to
> recover the end-2-end perspective, broken by NAT.

i suggest ngtrans limit its crusade to its charter, which does not include
an all out war on nats.

i suggest pushing the positive attributes of 6to4 is a far more productive
path.  and it's actually in the wg's charter.

randy

---

From: "JORDI PALET MARTINEZ" <[email-masked]>
Date: Tue, 29 Jan 2002 01:55:14 +0100

The Teredo draft clearly states, and I fully agree, that 6to4 is not valid in most of the NAT cases, at least here in Europe (worst
if we talk about countries with several levels of NAT).

The transition must be transparent, and Teredo is a way to do it, where 6to4 fails.

Regards,

Jordi

---

From: Pekka Savola <[email-masked]>
Date: Tue, 29 Jan 2002 10:02:13 +0200 (EET)

> intellectual property claim.

This could be interpreted as either:

 1) "we may or may not have IPR claims but we haven't mentioned them yet"
 2) "we don't have IPR claims so we have nothing to mention"

:-)

Assuming you meant 2) ?

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 29 Jan 2002 16:10:18 +0100

I've always tried to insist that 6to4 was designed for reasonably large
sites who are condemned to NAT but at least buy up to date boxes
that can suupport 6to4 and NAT in the same box. I've never been a big
fan of pushing 6to4 out to mass market clients likely to be hidden
behind atrocious low-end NATs. Shipworm aka Teredo does offer a solution
in that case. And in my opinion, it meets the criteria in
draft-iab-unsaf-considerations-00.txt . 

   Brian