Subject: Re: (ngtrans) ngtrans status report

From: [email-masked]
Date: Mon, 21 Jan 2002 12:58:04 +0100

Pekka,

You are right, we didn't answer Alain's question on the mailing list. 
One should not consider bgp-tunnel as a mechanism opposed to the couple
(6to4, isatap):

- When "MP-BGP over IPv4" is used the sites themselves can use isatap
- In "MP-BGP over IPv6" 6to4 can be the underlying inter-site ngtrans
mechanism, while isatap is used within the site

dirk

Pekka Savola wrote:
> 
> On Wed, 16 Jan 2002, Bob Fink wrote:
> [snip]
> > BGP-TUNNEL has been changed from Informational to Standards Track due to
> > the recent addition of an approach that requires standardization.
> > BGP-TUNNEL will be passed thru the IDR working group for comment as it is
> > last called for forwarding
> 
> I recall Alain asking the authors of BGP tunneling mechanisms to justify
> their solutions:
> 
> --8<--
> Date: Wed, 05 Sep 2001 10:53:39 -0700
> From: Alain Durand <[email-masked]>
> To: ngtrans <[email-masked]>
> Subject: (ngtrans) BGP-tunnels and connect-ipv6-igp
> 
> Stepping back a little, we now have 2 set of proposals to address the
> issue of scaling tunnel set-up during transition.
> 
> a) 6to4 + isatap
> b) BGP-tunnel + connect-ipv6-igp
> 
> As work in the general direction of a) has started long time ago and is well
> on its way, I would like to suggest the authors of b) to come up with some
> rationale/applicability statements that would help the working group
> to understand better how to position b) in regards to a)
> --8<--
> 
> There were no follow-ups.
> 
> Has this been discussed in the last meeting, off-list, or when the
> decision to stardardize (would experimental be better, anyway?) BGP
> tunneling was made?
> 
> --
> Pekka Savola                 "Tell me of difficulties surmounted,
> Netcore Oy                   not those you stumble over and fall"
> Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords

-- 
Dirk Ooms                       mailto:[email-masked]
                                tel:+32 3 2404732
Network Strategy Group (NSG)    http://aww.alcatel.com/nsg
Alcatel                         http://www.alcatel.com

---

From: Pekka Savola <[email-masked]>
Date: Mon, 21 Jan 2002 14:07:52 +0200 (EET)

> mechanism, while isatap is used within the site

Was the justification hidden in this message in some subtle way?

Pekka