Subject: RE: (ngtrans) isatap-03

From: Alain Durand <[email-masked]>
Date: Mon, 18 Feb 2002 17:50:44 -0800

At 5:01 PM -0800 2/18/02, Christian Huitema wrote:
>  > Implementing a DNS stub resolver to do DNS resolution over IPv4 one
>>  particular
>>  application and over IPv6 for the others is difficult, so clearly an
>>  ISATAP
>>  node will very probably always perform DNS resolution over IPv4
>>  and if ISATAP is deployed widely, it could become an obstacle to
>>  the deployment of DNS resolution over IPv6.
>
>Alain,
>
>Isn't this is a generic issue with all "parallel stack" transition
>schemes? As long as you have IPv4 deployed, the resolver is going to
>have access to DNS over IPv4. The key is to enable this resolver to also
>use IPv6 when available. The test would then be based on the
>availability of a AAAA record for a name server: if available, use IPv6,
>else, use IPv4.

I agree, the key is to be able to simply specify which transport to use.

Isatap is unique in the sense it periodically tries to fetch a list of routers
from the DNS. All the other dual stack mechanisms do not have this dynamic
property and can be simply configured to use either DNS over v4 transport
OR DNS over v6 transport once in place.

	- Alain.

--

---

From: Vladislav Yasevich <[email-masked]>
Date: Tue, 19 Feb 2002 09:39:46 -0500

Alain

> OR DNS over v6 transport once in place.

Why the "OR" restriction above?  I do not see this restriction
in current implementations of stub resolvers.  At least in 
UNIX flavors, multiple nameserver entries are allowed and 
both address types are supported simultaneously.

I don't see any requirements on the ISATAP node to NOT use IPv6
for DNS resolution.  It can use IPv6 "almost" as easily as
IPv4.

-vlad 
++++++++++++++++++++++++++++++++++++++++++++++++++++
Vladislav Yasevich		Tel: (603) 884-1079
Compaq Computer Corp.		Fax: (435) 514-6884
110 Spit Brook Rd ZK03-3/T07
Nashua, NH 03062

---

From: Alain Durand <[email-masked]>
Date: Tue, 19 Feb 2002 10:31:01 -0800

(reversing the order of your points)

> for DNS resolution.  It can use IPv6 "almost" as easily as

=> Not in the bootstrap phase where you're trying to discover the
      router IP address. My understanding  is you do Isatap
      only if there is no native IPv6 connectivity available.

> both address types are supported simultaneously.

You have a point, but what about the induced delays if
the 1st nameserver entry is a v6 address and v6 is not up yet?

    - Alain.

---

From: Vladislav Yasevich <[email-masked]>
Date: Tue, 19 Feb 2002 13:43:14 -0500

Alain

>       only if there is no native IPv6 connectivity available.

I admit this this is kind of hackish, but consider the flollowing:
 - The ISATAP router is also a DNS server at IP 1.2.3.4
 - taking unix as an example for resolve.conf entries we can
   do:
	nameserver fe80::0:5EFE:0102:0304

We can now do name resolution using IPv6 as a transport.
This is an example off the top of my head, but I am sure
I can come up with some more based on different implementations
I am considering...

> the 1st nameserver entry is a v6 address and v6 is not up yet?

I think some implementations have the ability to probe nameservers
in parallel.  This would reduce the delay.

-vlad

---

From: Pekka Savola <[email-masked]>
Date: Tue, 19 Feb 2002 22:16:53 +0200 (EET)

> I can come up with some more based on different implementations

The address might also be glueable in /etc/hosts, then there would be no 
need for v4 DNS -- here, I'm assuming DNS lookup is not done directly, but 
rather through the resolver.

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords