Subject: Re: (ngtrans) isatap-03

From: "Fred L. Templin" <[email-masked]>
Date: Thu, 14 Feb 2002 17:22:29 -0800 (PST)

Alain,

> I have two questions/comments for the ISATAP authors
> 
> 1. WKS. Isatap proposes to use WKS records in DNS.
>     What is the current status of support for WKS in the
>      various DNS servers/resolver in use today?

I believe you may be referring to text in section 5.2.1 that talks
about the proposed Well-Known Service name "ISATAP". Others have asked
about this, and we recognize that our terminology is a bit loose here.
We are seeking to add the name "ISATAP" to the "Protocol and Service
Names" assigned numbers document found at:

  http://www.iana.org/assignments/service-names

This is to provide a well-known name for name service lookups. We are
NOT asking that DNS WKS RR's be used for encoding IP addresses associated
with the name "ISATAP", however; when DNS is used, we expect that ordinary
"A" records will be used for this purpose. We will work on better text
for this in the next version of the draft.

> 2. Phasing out ISATAP.
>      Section 6.1
>      "the host MAY discontinue the 'Route Polling Process'
>       I'm worried that this is not strong enough and we may end up
>       with many hosts still using ISATAP when native IPv6 is available.
>       I'm curious to see why stronger wording like SHOULD or MUST
>       was not used.

We originally specified this as "SHOULD" but it was relaxed to "MAY"
based on peer review input. I believe one of the other authors could
speak better to this particular issue.

Thanks for the comments,

Fred Templin
[email-masked]

---

From: Vladislav Yasevich <[email-masked]>
Date: Fri, 15 Feb 2002 10:37:04 -0500

Fred

> for this in the next version of the draft.

Reading the URL you provide, one makes the same assumption as in
the draft, i.e. WKS records are to be used.  The recored is well implemented,
but I don't know how widely it's used.

Here is my proposal after some digging.  Use SRV records... here is how.
Since the draft reserves ISATAP in "Protocol and Service Names" documents,
a SRV record can be created with the followin fileds:
	Service  = _ISATAP
	Protocol = _IP
	Name     = <zone name>
	TTL	 = appropriate TTL
	Class	 = IN
	Priority = depends on the configuration (def = 0)
	Weight	 = depends on the configuration (def = 0)
	Port	 = 0
	Target   = name of the Isatap server (essentially pointer to A record).

Ex:

	_ISATAP._IP.example.com.  1H  IN SRV 0 0 0 isatap-rtr1.example.com.
				  1H  IN SRV 0 0 0 isatap-rtr2.example.com.

	isatap-rtr1.example.com.  12H IN A  1.2.3.4
	isatap-rtr1.example.com.  12H IN A  1.2.3.6

This way, the host names are not reserved and there is no potential conflict.

Hope to hear your thoughts...
-vlad

++++++++++++++++++++++++++++++++++++++++++++++++++++
Vladislav Yasevich		Tel: (603) 884-1079
Compaq Computer Corp.		Fax: (435) 514-6884
110 Spit Brook Rd ZK03-3/T07
Nashua, NH 03062