Subject: RE: DSTM-ports Considered Harmful [Re: (ngtrans) final ngtransagendaforIETF-53 in Minneapolis]

From: "Bound, Jim" <[email-masked]>
Date: Tue, 19 Mar 2002 02:07:47 -0500

exactly.  Thats what DSTM is all about.  DSTM will be deployed and updated and updated.  It is golden to reduce the NAT proliferation of IPv6 to use IPv4.

I will be writing a white paper on DSTM over the next few months and its deployment scenario to support those that will use DSTM in the market.  Will send it here when its done.

The question now is what extensions to DSTM are useful?  I think we should not drop the extensions for 6to4 either.

/jim

> -----Original Message-----
> From: Myung-Ki Shin [mailto:[email-masked]]
> Sent: Monday, March 18, 2002 11:46 PM
> To: Pekka Savola
> Cc: Francis Dupont; Alain Durand; Yasevich, Vladislav; NGtrans List
> Subject: Re: DSTM-ports Considered Harmful [Re: (ngtrans) 
> final ngtransagendaforIETF-53 in Minneapolis]
> 
> 
> 
> Pekka Savola wrote:
> 
> > I'm not sure if that's a goal of DSTM: the goal of DSTM is 
> to be able to
> > run IPv6-only network infrastructure with dual-stack nodes.
> >
> > Sure, getting end-2-end IPv4 is always a plus, but nothing 
> specific to
> > DSTM. And there should be some use for IPv6 too ;-)
> 
>    No, see the section 3. DSTM Overview and Assumptions in DSTM spec.
>    http://www.ietf.org/internet-drafts/draft-ietf-ngtrans-dstm-07.txt
> 
>    ====
>    The core assumption within this mechanism is that it is totally
>    transparent to applications, which can continue to work with IPv4
>    addresses. It is also transparent to the network, where only IPv6
>    packets are carried. It is the authors' viewpoint that the user, in
>    this case, has deployed IPv6 to support end to end 
> computing without
>    translation.  This aspect is fundamental during a 
> transition process
>    to guarantee that every existing application will continue to work
>    (e.g. IPsec, H.323), despite the presence of IPv4 addresses in the
>    payload of a packet.
> 
> 
>    Myung-Ki.
> 
>

---

From: "Bound, Jim" <[email-masked]>
Date: Tue, 19 Mar 2002 10:42:28 -0500

I tend to agree with you.  Also makes sense to focus this on servers
too.
good logical come back.....................
thanks
/jim

> From: Pekka Savola [mailto:[email-masked]]
> Sent: Tuesday, March 19, 2002 10:26 AM
> To: Bound, Jim
> Cc: Myung-Ki Shin; Francis Dupont; Alain Durand; Yasevich, Vladislav;
> NGtrans List
> Subject: RE: DSTM-ports Considered Harmful [Re: (ngtrans) final
> ngtransagendaforIETF-53 in Minneapolis]
> 
> 
> tOn Tue, 19 Mar 2002, Bound, Jim wrote:
> > True that this extends the life of IPv4 as you say.  
> > 
> > The assumption and I why I support it as extension to DSTM 
> is that in a
> > predominant IPv6 network or one that is virtually predominant (this
> > means user is trying reduce reliance on IPv4) the DSTM port 
> option may
> > help a department or office or home environment use the 
> limited global
> > address space it has with a port option.
> 
> This is no different compared to IPv4: the office could 
> perform NAT for
> some employees but give a public IP to others.  DSTM does not 
> change that.
> 
> (The only really workable case of ports option IMO seems to 
> be assigning a 
> few port numbers for IPv4 _servers_ that need to be globally 
> reachable.. 
> but not for ephemeral ports numbers or clients..)
>  
> > Would NAT-PT work better?  I don't think so.  DSTM permits the e2e
> > security and application model to run over the network.  
> Clearly on the
> > Internet its a bigger bite of faith to believe all the 
> deployment parts
> > can be done and implemented.  But if we can get Shipworm 
> done we can get
> > this done too.
> 
> Note that me I, at least, didn't suggest NAT-PT as the 
> alternative for 
> DSTM ports: rather NATv4.
> 
> My main concern (as some brought up similar with Teredo) is that we 
> specify IPv6 mechanisms that may not be robust, reliable etc. 
>  I think we 
> should try to leave IPv4 mess alone if possible.
> 
> > > From: Pekka Savola [mailto:[email-masked]]
> > > Sent: Monday, March 18, 2002 11:22 PM
> > > To: Myung-Ki Shin
> > > Subject: Re: DSTM-ports Considered Harmful [Re: (ngtrans) final
> > > ngtransagendafor IETF-53 in Minneapolis]
> > > 
> > > 
> > > On Tue, 19 Mar 2002, Myung-Ki Shin wrote:
> > > 
> > > > Pekka Savola wrote:
> > > > 
> > > > > > => IMHO the port option is like adding a NAT in DSTM. 
> > > It saves addresses
> > > > > > but remains an abomination.
> > > > >
> > > > > IMHO if you really have to save addresses, why don't you 
> > > just give out
> > > > > private IPv4 addresses to the DSTM nodes and do NAT.  
> Much cleaner
> > > > > solution, and nothing to do with IPv6 then!
> > > > 
> > > >   In my opinion,  at least, DSTM+NAT is bad approach.
> > > >   As I said, one of DSTM benefits is to provide end-2-end 
> > > computing for IPv4
> > > > without
> > > >   translation.
> > > 
> > > I'm not sure if that's a goal of DSTM: the goal of DSTM is to 
> > > be able to 
> > > -- 
> > > Pekka Savola                 "Tell me of difficulties surmounted,
> > > Netcore Oy                   not those you stumble over and fall"
> > > Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords
> > > 
> > > 
> > 
> 
> -- 
> Pekka Savola                 "Tell me of difficulties surmounted,
> Netcore Oy                   not those you stumble over and fall"
> Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords
> 
>