Subject: (ngtrans) soininen-ngtrans-3gpp-cases

From: Erik Nordmark <[email-masked]>
Date: Tue, 28 May 2002 22:39:19 +0200 (CEST)

>   2) IPv6 UE connecting to an IPv6 node through an IPv4 network   

The title for this section, and to some extent the content of the
section, doesn't make it clear whether the only issue is
 - that the network between the UE and GGSN is IPv4
or that is also considers the case when the target destination is
only reachable over IPv4 (i.e. there isn't an IPv6 path between the GGSN and
the target).
Part of the problem is the use of "connecting" - makes me think of
an e2e TCP connection.
If the intent is just "IPv6 UE, IPv6 GGSN, with IPv4 path between"
it would make sense to state that explicitly.

If the issue is both the UE-GGSN path and past the GGSN, then I think
that should be viewed as two orthogonal aspects of the transition
scnarios.

>   3) IPv4 UE connecting to an IPv4 node through an IPv6 network   

At some level this section has the same issue as #2 above.

  Erik

---

From: [email-masked]
Date: Wed, 29 May 2002 16:22:09 +0300

Hi, Erik!

Thanks for your comments! Some comments from me:

-----Original Message-----
From: ext Erik Nordmark [mailto:[email-masked]]
Sent: 28 May, 2002 23:39

JW: yep, the intention is to describe a scenario that there is IPv4 network (somewhere) between the GGSN and the peer host the UE is communicating with, so the target destination is only reachable over IPv4. We are not focusing on "3GPP network internal" transition scenarios, e.g. the network between the UE and the GGSN. In 3GPP architecture (user IP layer), UE-GGSN is seen as one link; GGSN is the default router for the UE. Adding some more textual explanation (or even ASCII pictures?) could be beneficial.

Typically in this scenario, an IPv6 PDP context is activated between the UE and the GGSN Access Point and the "IPv6 in IPv4" tunneling is carried out by a network element, such as the GGSN or the edge router in the operator's network.

JW: Agreed. This is the reverse case.

Best Regards,
	          -Juha W.-