Subject: RE: (ngtrans) draft-wiljakka-3gpp-ipv6-transition-00.txt

From: "Karim El-Malki (EAB)" <[email-masked]>
Date: Mon, 22 Jul 2002 14:47:33 +0200

> >  > I mean :
 > >  > A node sends "I want to contact [email-masked]" query 
 > using IPv6.
 > >  > Same node receives "[email-masked] is 192.168.168.192" reply
 > >  > using IPv6.
 > >  > Same node use then its IPv4 stack to contact [email-masked]...
 > > 
 > > This is not possible since all 3GPP IMS communication (signalling
 > > and traffic) runs over IPv6 (see below). Node A would get 
 > back an IPv6
 > > address (e.g. PREFIX::192.168.168.192) which can be translated
 > > to IPv4 by a translator box.
 > 
 > But is there any reason that IP packet translation is 
 > needed, rather than
 > an application level proxy running on a dual stack? 
 > 

In the answer above I was talking about translation for the traffic part as opposed
to the SIP Signalling (for which a dual stack SIP ALG makes sense). For example,
the 3GPP host would be sending RTP/UDP/IPv6 packets and these need to be
translated to RTP/UDP/IPv4. A Translator would do this. Note that the 3GPP host
can only send and receive IPv6 packets for IMS. A dual-stack RTP/UDP proxy would
work but I can't see the advantages with respect to a more generic translator.

/Karim

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 22 Jul 2002 15:23:37 +0200

> work but I can't see the advantages with respect to a more generic translator.

The advantage is that it avoids any flavour of NAT, which we want to avoid unless
we are absolutely forced into it. 

  Brian