Subject: RE: (ngtrans) draft-wiljakka-3gpp-ipv6-transition-00.txt

From: "Karim El-Malki (EAB)" <[email-masked]>
Date: Mon, 22 Jul 2002 18:00:15 +0200

If you're talking about IMS, then it's only SIP so a SIP ALG
would suffice. If instead you mean the general case, 3GPP
terminals will be dual-stack so they should talk IPv4
to IPv4 peers and the same for IPv6. We are recommending
in the doc that in general this is preferred, although
we need to clarify some wording (see Erik's email). IMS is a
special IPv6-only case which is why a SIP ALG would be needed.
/Karim

 > -----Original Message-----
 > From: Brian E Carpenter [mailto:[email-masked]]
 > Sent: den 19 juli 2002 09:48
 > To: NGTRANS List
 > Subject: Re: (ngtrans) draft-wiljakka-3gpp-ipv6-transition-00.txt
 > 
 > 
 > And how will this work for apps with no ALG available?
 > 
 >    Brian
 > 
 > "Karim El-Malki (EAB)" wrote:
 > > 
 > > Hi Luc,
 > > 
 > > IMS only allows IPv6 connectivity (PDP Contexts).
 > > It's not possible to activate an IMS IPv4 PDP Context,
 > > therefore we need translation for the case where an
 > > IMS (SIP-based) IPv6 host communicates with an IPv4 host.
 > > 
 > > /Karim
 > > 
 > > -----Original Message-----
 > > From: BELOEIL Luc FTRD/DMI/CAE
 > > To: [email-masked]; [email-masked]; 
 > [email-masked]
 > > Cc: [email-masked]; MARTIQUET Nicolas FTRD/DMR/ISS
 > > Sent: 2002-07-19 01:58
 > > Subject: RE: (ngtrans) draft-wiljakka-3gpp-ipv6-transition-00.txt
 > > 
 > > Hi all,
 > > 
 > > I'm happy to see a draft that proposes the use of native 
 > connection each
 > > time needed.
 > > 
 > > Moreover I totally agree that UE must be dual-stack (in 
 > first phases)
 > > and that IPv4 connectivity (IPv4 PDP context) should not 
 > be always-on.
 > > 
 > > But, I do not feel at ease with section 4.1 (dual-stack 
 > UE) in addition
 > > with section 5.2. (UE connecting to a node in an IPv4 
 > network through
 > > IMS). I see a case which seems not to be addressed in the draft.
 > > 
 > > Consider a dual-stack UE with IPv6-only connectivity 
 > (because of IPv4
 > > addresses scarcity) that initiates a communication through 
 > IMS (with
 > > SIP) towards another node named C. Consider C is IPv4-only 
 > and outside
 > > the operator network. Don't you think that an IPv4 PDP 
 > context should be
 > > initiated (by UE or network) so as to allow a native end-to-end
 > > connection ?
 > > 
 > > Could you help me ?
 > > 
 > > Luc
 > > 
 > > -----Message d'origine-----
 > > De : [email-masked] [mailto:[email-masked]]
 > > Envoyé : mercredi 17 juillet 2002 07:13
 > > À : [email-masked]; [email-masked]
 > > Cc : [email-masked]
 > > Objet : RE: (ngtrans) draft-wiljakka-3gpp-ipv6-transition-00.txt
 > > 
 > > Hi all!
 > > 
 > > I also think that the issue is in wording and we are happy 
 > to clarify
 > > that in the next revision. :-)
 > > 
 > > We are no way prefering NAT over tunneling. Just because tunneling
 > > remains the end-to-end nature of the communication. 
 > However, translation
 > > may be needed in some cases, like in IMS scenario 1.
 > > 
 > > And about tunneling: what I meant was that if you consider 
 > GPRS scenario
 > > 2 (or actually scenario 1, where the UE has dual stack 
 > capability), I
 > > prefer doing "IPv6 in IPv4" tunneling in the network (the 
 > encapsulating
 > > node could be e.g. GGSN or edge router), not in the UE. If you make
 > > tunneling in the network, you can just activate IPv6 PDP context.
 > > 
 > > What Karim commented about the case that if a dual stack UE is
 > > connecting to a network in which the GGSN does not support 
 > IPv6, it is a
 > > relevant thing to make "IPv6 in IPv4" tunneling in the UE and just
 > > activate IPv4 PDP context. That scenario is also very 
 > shortly documented
 > > in GPRS scenario 1.
 > > 
 > > Best Regards,
 > >                 -Juha W.-
 > > 
 > > -----Original Message-----
 > > From: ext Erik Nordmark [mailto:[email-masked]]
 > > Sent: 17 July, 2002 12:32
 > > To: Karim El-Malki (EAB)
 > > Cc: 'Erik Nordmark '; [email-masked] '
 > > Subject: RE: (ngtrans) draft-wiljakka-3gpp-ipv6-transition-00.txt
 > > 
 > > > Maybe we need to look at the doc again to clarify this
 > > > but we do have cases where tunnelling from the UE is preferred
 > > > e.g. accessing IPv6-only services (i.e. IMS) when you're roaming
 > > > into a network which only supports IPv4 connections (PDP 
 > Contexts).
 > > > There are also cases where translation looks like the way to go
 > > > e.g. Communicating with an IPv4 node when using an IPv6-only
 > > > service (IMS) which mandates IPv6-only connections.
 > > > The recommendations probably need clarifying if they give
 > > > that impression, but regarding the tunnelling I think it was
 > > > meant to prefer the native connection (without tunnelling or
 > > > translation) rather than always recommending against tunnelling
 > > > and for translation.
 > > 
 > > Thanks. In that case I think the issue is with the wording in the
 > > document.
 > > 
 > >   Erik
 >

---

From: Keith Moore <[email-masked]>
Date: Mon, 22 Jul 2002 14:56:34 -0400

> to IPv4 peers and the same for IPv6. 

I'm confused...  how are you going to be able to get enough IPv4 
addresses for 3GPP terminals to let them use IPv4 when talking 
to IPv4 peers?