Subject: Re: 6to4 default MTU [was Re: (ngtrans) 6to4 MRU - need WG consensus]

From: "Fred L. Templin" <[email-masked]>
Date: Tue, 17 Sep 2002 14:24:25 -0700

Erik Nordmark wrote:
 >>Interesting document - thanks for pointing it out. Have you had a chance
 >>to read it? If so, what is your assessment of the "How to detect" and
 >>"How to fix" suggestions given in section 2.1 from the standpoint of
 >>robustness and efficiency?
 >
 >
 > I think it is a bit tricky because there are multiple things you'd might
 > want to trigger when the transport protocol is retransmitting.
 > For instance in IPv4 you want to trigger dead gateway detection.
 > And in an SCTP case you might want to try an alternate path for
 > the retransmitted packets.
 > Thus transport retransmissions might be due to at least
 >  - loss due to congestion
 >  - loss due to lossy (e.g. wireless) links
 >  - loss due to the path having failures (1st hop router or some other part
 >    of the path)
 >  - loss due to sending large packets and the ICMP too big not being returned
 >
 > The TCP specification handles the first two.
 > The SCTP specification handles the first three even though the heuristics
 > for path failures are really basic.
 >
 > I haven seen an easy way to combine all four.

Does your easy way handle both TCP and SCTP? What about persistent UDP
sessions? How about multicast? Finally, do you plan to enlighten us all
during the v6ops meeting tomorrow?

Fred
[email-masked]

---

From: Erik Nordmark <[email-masked]>
Date: Fri, 20 Sep 2002 11:16:00 +0200 (CEST)

>  > I haven seen an easy way to combine all four.

Missing "'t" above.
"have not".

  Erik