Subject: Re: (ngtrans) more comments on draft-ietf-ngtrans-mech-v2-00.txt

From: "Robert Elz" <[email-masked]>
Date: Mon, 23 Sep 2002 16:32:01 +0700

Date:        Fri, 20 Sep 2002 12:04:48 +0200 (CEST)
    From:        Erik Nordmark <[email-masked]>
    Message-ID:  <[email-masked]>

Erik, could you elaborate on what this one means?

  | 3. State that when the dynamic PMTU is not implemented the sender MUST NOT
  |    by default send IPv6 packets larger than "max MTU" into the tunnel.
  |    We can debate this number.

I'm failing to understand the intent.

All the rest of your message is good, except that I'm not certain that
we need a specified MTU that anyone is expected to use.

kre

---

From: Erik Nordmark <[email-masked]>
Date: Wed, 25 Sep 2002 21:52:18 +0200 (CEST)

> I'm failing to understand the intent.

The first paragraph in Section 3.2 in the spec can be interpreted
as it being ok to threat the tunnel interface as having a MTU (from IPv6's
perspective) of 65535-20 bytes. Thus IPv4 fragmentation could be freely used
up to 65535 bytes of IPv4 packets.
Given than receivers might not want to dedicate that much reassembly buffer
it would make sense to pick a smaller number. That is the intent
of the above point.

Note that implementations which use the optional dynamic MTU stuff
would only use IPv4 fragmentation for IPv6 packets that are 1279 bytes
and smaller. 

   Erik