Subject: Re: (ngtrans) Re: comments on draft-itojun-v6ops-v4mapped-harmful-00.txt

From: Jun-ichiro itojun Hagino <[email-masked]>
Date: Wed, 18 Sep 2002 02:59:54 +0900

>>This packet will only go out as an IPv4 packet if there was an IPv4 address
>>available.  If the node implements SIIT and there is not IPv4 address, the
>>packet will go out as a SIIT formatted IPv6 packet (i.e with a translatable 
>>source.
>>
>>A node that does not implement SIIT that happens to receive a SIIT formatted
>>packet will simply drop the packet because ::ffff:a.b.c.d IPv6 address is
>>not configured on any IPv6 interfaces of the node.
>
>	i have never seen such sender rule written down anywhere, and such rule
>	complicates sender's behavior.  do you have any reference?

	for instance, if you have 127.0.0.1 assigned to your node you will send
	the packet out as IPv4 packet.  such sender rule (and AI_ADDRCONFIG)
	does not work in reality.

itojun

---

From: Caitlin Bestler <[email-masked]>
Date: Tue, 17 Sep 2002 13:26:05 -0500

I've scanned the archive, and could not find a discussion on
this issue. My apologies is this has already been discussed
and I just failed to search on the correct keywords.

RFC2821 and 2142 both establish standard email addresses
that a domain offering email service must support:
postmaster and abuse.

The spirit of this requirement is that anyone participating
in the email system must be reachable in a standard way.

Given that intention, would it be appropriate to add a
requirement that a domain offering email MUST specify an
IPv4 MX record?

Allowing a domain to hide behind an IPv6-only MX record
could easily become a method of making it difficult to
complain about email abuse.

Indeed, I can think of no valid reason to offer a public
IPv6-only email server before IPv4 has been reducted to a
historic footnote forgotten by most network administrators.

Caitlin Bestler
http://asomi.com/CaitlinBestler/

---

From: Vladislav Yasevich <[email-masked]>
Date: Tue, 17 Sep 2002 14:29:26 -0400

Well...

> 	does not work in reality.

As far as references, our implementation does something similar to what I 
described (it's a lot more thorough then the simple case I stated).

As far as AI_ADDRCONFIG, it does not considere loopback addresses when
determining what's configured.

I am sure that nodes that implement and enable SIIT know that it's enabled
and they will attempt to use it before attempting loopback depending on
what their routing table shows.

Now, I am not really defending SIIT, as it has other problems then the
use of mapped addresses on the wire.

-vlad

-- 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Vladislav Yasevich		Tru64 UNIX - IPv6 Project Lead
Hewlett Packard 		Tel: (603) 884-1079
Nashua, NH 03062		ZKO3-3/T07