Subject: (ngtrans) IPv6 only devices in home network

From: Soohong Danniel Park <[email-masked]>
Date: Fri, 11 Oct 2002 12:18:50 +0900

at unmanaged network environments, 
if IPv6 is applied to home networks, probably IPv6 only devices  within
home network is trying to connect IPv4 ISP and any kind of system.
at this time, IMOP natpt or siit will be suitable for comminications.
because it translates each IP headers.
so just a kind of router or IPv4 provided equipment should be upgrade
transition supporting. 
is it correct ?
 
-Daniel
             
==================================
Soohong Daniel Park
 
Mobile Platform Group
Digital Media R&D Center
Samsung Electronics Co.,LTD
416, Maetan-dong, Paldal-gu
Suwon-city, Kyungki-do, Korea
TEL:+82-31-200-3728
FAX:+82-31-200-3147
H.P:+82-11-9950-4655
mailto:[email-masked]
==================================

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 11 Oct 2002 08:44:36 +0200

I believe much better advice to service providers of all kinds is to
push as hard as possible towards dual stack servers. Then tunnels or
6to4 can be used.

Unfortunately some cases may remain where NAT/PT is the only solution,
but we really should make it clear that this is a 2nd-class solution.

   Brian

> Soohong Danniel Park wrote:
> 
> if IPv6 is applied to home networks, probably IPv6 only devices  within home network is trying to connect IPv4 ISP and any
> kind of system.
> at this time, IMOP natpt or siit will be suitable for comminications. because it translates each IP headers.
> so just a kind of router or IPv4 provided equipment should be upgrade transition supporting.
> is it correct ?
> 
> -Daniel
>

---

From: Keith Moore <[email-masked]>
Date: Fri, 11 Oct 2002 10:24:01 -0400

> at this time, IMOP natpt or siit will be suitable for comminications. 

No.  NAT (including NAT-PT) breaks applications.  a big reason to use 
IPv6 is to avoid having your applications broken by NAT.

Keith