Subject: Re: (ngtrans) Re: IPv6 only devices in home network

From: "Michael Cole" <[email-masked]>
Date: Sun, 20 Oct 2002 0:16:37 -0400

If General Motors and MIT were to lease out their millions of 
unused global addresses, then Ipv4 shortages would not be so critical. How the 
hell is MIT going to use 24 million mumble something addresses anyways.

----- Original Message ----- 

From: Keith Moore  

To: Caitlin Bestler 
Cc: Keith Moore ; [email-masked] 

Sent: 10/17/2002 11:16:31 AM 

Subject: Re: (ngtrans) Re: IPv6 only 
devices in home network

  So you would advocate that any ISP without sufficient

  public IPv4 addresses simply refuse to provide IPv4

  connectivity to their customers?

If the RIRs are doling out address blocks in such a way that some 
ISPs

can assign static IPs to each customer that has a full-time 
connection,

while others cannot do so, that's a serious problem that needs to be 

fixed ASAP.

But NAT does not provide "IPv4 connectivity" any more than tin cans

and string provide a reliable data link.

 

--- Michael Cole

--- [email-masked] 

--- EarthLink: It's your Internet.

---

From: "Zhang haofeng" <[email-masked]>
Date: Sun, 20 Oct 2002 14:04:02 +0800

Hi,
        Do you mean that,  if MIT were to lease out there unused IP address IPv6 is not so urgent to deploy?
        I come from China, where IPv4 shortage problem is very serious for ISPs and also each Internet user. But when I have discussiones with some engineers about IPv6, they often ask me what the motivity to develop or deploy IPv6,  since even no some common IPv6 applications are not available to public.  Then I can not find some powerful words to answer them. 
        Mainly, they have these questions:
        1. what's the exact time that IPv4 addresses will be run out? Nobody cares about IPv6 until the IPv4 addresses are run out.
        2. Can ISPs benefit from IPv6? It needs much money to upgrade the IPv4 network to IPv6 network!
        3. Application for IPv6? Is IPv6 similar with 3G, which both lack of Killer applications?
        Any suggestions? 
  ----- Original Message ----- 
  From: Michael Cole 
  To: Keith Moore 
  Cc: ngtrans 
  Sent: Sunday, October 20, 2002 12:16 PM
  Subject: Re: (ngtrans) Re: IPv6 only devices in home network

  If General Motors and MIT were to lease out their millions of unused global addresses, then Ipv4 shortages would not be so critical. How the hell is MIT going to use 24 million mumble something addresses anyways.
    ----- Original Message ----- 
    From: Keith Moore 
    To: Caitlin Bestler 
    Cc: Keith Moore; [email-masked]
    Sent: 10/17/2002 11:16:31 AM 
    Subject: Re: (ngtrans) Re: IPv6 only devices in home network

    > connectivity to their customers?

    If the RIRs are doling out address blocks in such a way that some ISPs
    can assign static IPs to each customer that has a full-time connection,
    while others cannot do so, that's a serious problem that needs to be 
    fixed ASAP.

  --- Michael Cole
  --- [email-masked]

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 21 Oct 2002 17:10:59 +0200

>         1. what's the exact time that IPv4 addresses will be run out? Nobody cares about IPv6 until the IPv4 addresses are run out.

They ran out some time ago, since you can't get enough today.

Actually, there were never enough IPv4 addresses. The world population
was more than 4 billion even when the IPv4 standard was published. 

>         2. Can ISPs benefit from IPv6? It needs much money to upgrade the IPv4 network to IPv6 network!

It costs much money to solve the problems caused by NAT. Every time I travel, without
exception, I hit a connectivity problem caused by NAT. This costs a lot to both
ISPs, users, and employers. Moving to IPv6 will save money.

>         3. Application for IPv6? Is IPv6 similar with 3G, which both lack of Killer applications?

We don't need a killer application. We just need enough addresses for
normal applications.  For one list of IPv6-enabled applications,
see http://6net.iif.hu/ipv6_apps/

    Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 21 Oct 2002 17:10:59 +0200

Brian

---

From: Randy Bush <[email-masked]>
Date: Mon, 21 Oct 2002 08:53:04 -0700

>> 1. what's the exact time that IPv4 addresses will be run out? Nobody
>> 1. cares about IPv6 until the IPv4 addresses are run out.

actually, one can, except in the asia/pacific region, where protectionist
national registries, controlled by the incumbents, are not acting in an
open fashion.

randy

---

From: Ronald van der Pol <[email-masked]>
Date: Mon, 21 Oct 2002 19:31:17 +0200

> national registries, controlled by the incumbents, are not acting in an

I can get only one IPv4 address at home. And it is even not garanteed
that it won't change. That's in Europe.

	rvdp

---

From: Randy Bush <[email-masked]>
Date: Mon, 21 Oct 2002 10:34:12 -0700

> that it won't change. That's in Europe.

that is not due to a shortage of v4 ip space.

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 21 Oct 2002 22:31:43 +0200

> that is not due to a shortage of v4 ip space.

Well, as far as the user is concerned, the effect is the same,
which is what I meant originally. ISPs that act in restraint of
trade are indeed making the shortage worse than it needs to be.

   Brian

---

From: Randy Bush <[email-masked]>
Date: Mon, 21 Oct 2002 13:55:54 -0700

> trade are indeed making the shortage worse than it needs to be.

"restraint of trade" seems to be a legal term, which means you could
be indulging in libel unless you can substantiate that indeed some
law is being broken.

and i was not aware that consumer end sites indulged in trade.

perhaps the hyperbole surrounding this passed the stage of utility
and relevance some years ago.

personally, i think the vicious shipmakers that won't let me have
a 42' J-Boat are even more vicious and anti-consumer.  oh, you mean
i should *pay* for it?  what a concept.

randy

---

From: Brian E Carpenter <[email-masked]>
Date: Mon, 21 Oct 2002 23:25:30 +0200

If I'd mentioned any specific ISPs I would indeed not have used
such words. But my point is not hyperbolic I think: if a customer
can't get enough addresses for their purpose, then there is a de facto
shortage of addresses. (I didn't say that one shouldn't have to pay
for resources. Now that would have been hyperbolic.)

  Brian

---

From: Pekka Savola <[email-masked]>
Date: Tue, 22 Oct 2002 00:27:20 +0300 (EEST)

> that is not due to a shortage of v4 ip space.

Do RIR's agree?

One of our (AS1741) hostmasters wanted to go on sick leave right then when
I suggested he should apply for some 6 (or so) /24 blocks so we could give
one public address for a university's DSL users.. instead NAT is done now
:-(

Some definitely seem to be thinking there isn't enough v4 ip space.. or
perhaps they are just lazy bums who don't want to deal with paperwork with
RIPE 24 x 7 :-(.

(Oh yes, on another thread about paying: weren't addresses supposed to be
free :-)

-- 
Pekka Savola                 "Tell me of difficulties surmounted,
Netcore Oy                   not those you stumble over and fall"
Systems. Networks. Security.  -- Robert Jordan: A Crown of Swords