Subject: Re: (ngtrans) Re: IPv6 only devices in home network

From: Steve Pollock <[email-masked]>
Date: Fri, 01 Nov 2002 17:15:53 -0700

At 12:16 AM 10/20/2002 -0400, Michael Cole wrote:
>If General Motors and MIT were to lease out their millions of unused global addresses, then Ipv4 shortages would not be so critical. How the hell is MIT going to use 24 million mumble something addresses anyways.

But...   why should -anyone- have to "pay" to use an IP address.

---

From: Randy Bush <[email-masked]>
Date: Tue, 05 Nov 2002 23:36:15 -0800

> India, Africa, and other less fortunate places do not have enough v4
> address space and this we know from the v6 forum.

ahhh.  i understand.  it's the climate that makes integers melt there.

[ btw, i know some about v6 in africa, and your assertion is bogus ]

randy

---

From: Randy Bush <[email-masked]>
Date: Wed, 06 Nov 2002 04:58:21 -0800

> Well I do to and my assertion is not bogus.  There is not enough
> address space in AP if africa wants to deploy 20 million ip
> devices for education that are globally routable, secure, and
> without NAT.

sorry.  i did not realize we were talking about theories of what
would happen if.  i thought the words being used were in the
present tense, and what little i know of english would seem to
support that conclusion.

if i did not think it was prudent engineering to plan for a need
for more address space, i would not spend my time reading this
stuff.  but that does not lead me to make assertions about the
present world which i can not substantiate and which might lead me
to make incorrect assumptions in my thinking about the future.

randy

---

From: "Michael Cole"<[email-masked]>
Date: Tue, 12 Nov 2002 21:05:51 -0800

Actually, There are 4 reasons why we have to pay more for addresses:

1. The original allocation scheme allocated 16 million plus addresses to each
of the original IPv4 participants at essentially zero cost. In the early days,
charging 10 cents or even 1 cent per month per address would have been a
hardship. That is not true today.

2. Routing had to be simple because early routers were built using the PDP-11.
That is no longer an issue.

3. In a lot of cases it takes both a carrot AND a stick to get these people to
realize that they can make money hand over fist leasing out their unused
addresses. So far, AT&T is one of the few companies that has realized this.

4. If IANA charged a nominal price such as 10 cents per address per month,
then those people who do not need 16 million addresses could make $!#%loads of
money by leasing out 500,000 of them at $5 per month each. Those companies
that really do need a /8 block can easily pay $1.6 million per month. Even if
the IANA price were 2 cents per month each we would still have much more
equitable distribution.

However, we will still need IPv6; when we need it will depend a lot on whether
the big guys will lease out their unused addresses.

Mike Cole, [email-masked] 

On Tue, 5 Nov 2002 15:51:56 +0000 Tim Chown <[email-masked]> wrote:

> On Tue, Nov 05, 2002 at 07:32:38AM -0800, Randy
> Bush wrote:
> > > The reason why we have shortages of Ipv4
> addresses
> > 
> > do we have a shortage of v4 ip addresses?
> 
> Perhaps "shortages of globally routable IPv4
> addresses available to end
> users in a number of environments", like public
> WLANs, home networks,
> networks in hotels, or in public events (like
> IST2002 where I am now),
> etc etc.
> 
> The choice of the operator to ask for and use
> global addresses is not
> something the end user can control :(   I can
> vote with my wallet for
> my home network (though it's frustrating that
> money is required to get more
> IPv4 addresses, for whatever reason), but not
> so usually when attached to 
> a public or other network.
> 
> Tim
>