Subject: RES: RES: RES: ReN: (ngtrans) IPv6 tranisition issues

From: "Marcelo Barbosa Lima" <[email-masked]>
Date: Tue, 7 Jan 2003 08:51:20 -0200

Hi Keith,

>you are completely mistaken.  the NAT does not have sufficient information to perform the >>>conversion even if it is aware of the protocol that the application is using.

   I think that I can to implement a stateful NAT module able to see the several connections in ongoing applications and get these informations. I implemented one Linux Kernel Module to filtering RPC-based services. It was abble to look in communication between portmapper and client RPC and get RPC servers´s port numbers. In this way, the filter creates rules on-the-fly to these services. I believe that be possible make the same to NAT modules.

>almost any distributed application fails in the presence of NAT unless there is a central server >via which communications are routed.  the ones I'm most familiar with are used in distributed >computation: netsolve, globus, pvm.  but SIP has this problem also.

  I think that you are correct to current NAT implementations. But I think that it is possible implement applications-specific NAT. I dont know SIP protocol, but if it is similar to H323, it is possible to implement a special NA module abble to see sinnaling UDP sessions end get port numbers to be used in the call and to do address/port translation. 

  Marcelo.

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 09 Jan 2003 15:08:18 +0100

Marcelo Barbosa Lima wrote:
...
> 
>   I think that you are correct to current NAT implementations. But I think that it is possible implement applications-specific NAT. 

That's not a NAT. That's an application level gateway (ALG) including 
NAT functionality.

This requires every NAT-ALG vendor to develop new software kludges for
every new application. Or to put it another way, it prevents innovative
applications since they cannot penetrate existing NATs. There is no
doubt that NAT is the single biggest barrier to innovation today.

This is of course why we started developing IPv6 in 1994, so can we
please get back to that, instead of continuing to waste resources
discussing NAT?

   Brian

---

From: "Michael R. Cole" <[email-masked]>
Date: Fri, 10 Jan 2003 04:34:15 -0500

----- Original Message -----
From: "Brian E Carpenter" <[email-masked]>
To: "Marcelo Barbosa Lima" <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, January 09, 2003 9:08 AM
Subject: Re: (ngtrans) IPv6 tranisition issues

> >   I think that you are correct to current NAT implementations. But I
think that it is possible implement applications-specific NAT.
> please get back to that, instead of continuing to waste resources

Thanks. I was starting to suspect that there was another kind of box that
performs some NAT functions but without creating as many headaches. That
would explain why one of the packages that I tried worked so well.

MIke Cole