Subject: RES: RES: ReN: (ngtrans) IPv6 tranisition issues

From: "Marcelo Barbosa Lima" <[email-masked]>
Date: Tue, 7 Jan 2003 08:21:09 -0200

Folks,

   I think that Keith´s answer did not offend to me. I want only a good debate about IPv6´s subjects. I really believe that is possible to write code STATEFUL to NAT where whatever application can be supported. I believe that all connections/sessions related to one application can be inpesctioned (in application layer)and port numbers and IP address translated like in simple FTP.  Of this way, NAT can provide support to many applications more complex. AGAIN, stateful NAT with application sense can be implemented to support this application. I really dont see reasons to that one NAT applications-specific module can not be implemented. In Linux, for example, exists IRC, Netmeeting and ICQ modules to masquerading. I also believe that few implementation do it. My apologies for my "irresponsible comments about NAT". I only thougth that it was a free debate between civilized people.
Best Regards,

			Marcelo.

-----Mensagem original-----
De: Bound, Jim [mailto:[email-masked]]
Enviada em: segunda-feira, 6 de janeiro de 2003 17:47
Para: Fred L. Templin
Cc: Keith Moore; Marcelo Barbosa Lima; [email-masked];
[email-masked]
Assunto: RE: RES: ReN: (ngtrans) IPv6 tranisition issues

Hi Fred,

Missed the light part.  My apologies.  It is just some are so rude in
email I cannot help but wish them the worst from that view.  And I do.

/jim

> -----Original Message-----
> From: Fred L. Templin [mailto:[email-masked]] 
> Sent: Monday, January 06, 2003 2:35 PM
> To: Bound, Jim
> Cc: Keith Moore; Marcelo Barbosa Lima; [email-masked]; 
> [email-masked]
> Subject: Re: RES: ReN: (ngtrans) IPv6 tranisition issues
> 
> 
> Hi Jim,
> 
> Bound, Jim wrote:
> > Fred,
> > 
> > I did not think Keiths mail was insulting.
> 
> Exactly why I prefaced my note with "No offense intended";
> just trying to make light of an ongoing discussion that has
> (to me) become almost humerous by its cyclical nature. (Ever 
> see the movie "Groundhog Day"?)
> 
> Perhaps this was inappropriate, and hopefully has come at no 
> expense to Keith (apologies if it has). I certainly didn't 
> intend to single Keith out as being solely responsible for 
> perpetuating the thread.
> 
> Thanks,
> 
> Fred
> [email-masked]
> 
>

---

From: Keith Moore <[email-masked]>
Date: Tue, 7 Jan 2003 07:25:19 -0500

On Tue, 7 Jan 2003 08:21:09 -0200
"Marcelo Barbosa Lima" <[email-masked]> wrote:

> 
>   Folks,
> 
>    I think that Keith´s answer did not offend to me. I want only a good
> debate about IPv6´s subjects. I really believe that is possible to write code
> STATEFUL to NAT where whatever application can be supported. I believe that 
> all connections/sessions related to one application can be inpesctioned (in 
> application layer) and port numbers and IP address translated like in 
> simple FTP.  

you are still incorrect.  I am sorry if this sounds impolite or offensive, but 
facts are facts.  Even 3-party FTP fails in the presence of NAT.

think of it this way - if there are more than two hosts involved in an 
application, then it's not necessarily the case that a single NAT can see all 
of the addresses that get passed around between hosts.  if a NAT is between
host A and host B, there may be ways that host A and host B can learn 
addresses for each other without the traffic passing through that NAT.

if you want to discuss this further, please do so in private mail.  it's not
relevant to IPv6, since NATs have no place interfering with communication 
between IPv6 hosts.

Keith