Subject: RES: RES: ReN: (ngtrans) IPv6 tranisition issues

From: "Marcelo Barbosa Lima" <[email-masked]>
Date: Mon, 6 Jan 2003 16:01:34 -0200

Hi Keith,

   I dont know one application what NAT (or reverse NAT) are not abble to support or what one NAT implementation can be extended to provide support it. If NAT implemantation is smart and application sense, I think that I can do translation of IP addresses and ports in application data (without cryptography), if necessary, like I do in FTP and other tricky protocols. Can you tell me applications where NAT can not be used? Regards,

			Marcelo.

-----Mensagem original-----
De: Keith Moore [mailto:[email-masked]]
Enviada em: segunda-feira, 6 de janeiro de 2003 15:51
Para: Marcelo Barbosa Lima
Cc: [email-masked]; [email-masked]
Assunto: Re: RES: ReN: (ngtrans) IPv6 tranisition issues

On Mon, 6 Jan 2003 08:56:20 -0200
"Marcelo Barbosa Lima" <[email-masked]> wrote:

> 
>   I think that NAT is a good workaround and it can be done to support all aplications

you are mistaken.  your statement is completely and utterly incorrect.

Keith

---

From: Keith Moore <[email-masked]>
Date: Mon, 6 Jan 2003 14:09:58 -0500

On Mon, 6 Jan 2003 16:01:34 -0200
"Marcelo Barbosa Lima" <[email-masked]> wrote:

> 
>  Hi Keith,
> 
>    I dont know one application what NAT (or reverse NAT) are not abble > to support or what one NAT implementation can be extended to provide > support it. If NAT implemantation is smart and application sense, I > think that I can do translation of IP addresses and ports in > application data (without cryptography), if necessary, like I do in > FTP and other tricky protocols. 

you are completely mistaken.  the NAT does not have sufficient information to perform the conversion even if it is aware of the protocol that the application is using.

> Can you tell me applications where NAT can not be used? Regards,

almost any distributed application fails in the presence of NAT unless there is a central server via which communications are routed.  the ones I'm most familiar with are used in distributed computation: netsolve, globus, pvm.  but SIP has this problem also.

Keith