Subject: RE: RES: ReN: (ngtrans) IPv6 tranisition issues

From: "Bound, Jim" <[email-masked]>
Date: Tue, 7 Jan 2003 10:14:09 -0500

Folks,

Lets just listen to Christians mail.  Me included.

No comment from me at this point.   I would not advocate the development of state machines in code to support NAT at this point with IPv6 so close though.

Regards,
/jim

> -----Original Message-----
> From: Marcelo Barbosa Lima [mailto:[email-masked]] 
> Sent: Tuesday, January 07, 2003 5:21 AM
> To: Bound, Jim; Fred L. Templin
> Cc: Keith Moore; [email-masked]; [email-masked]
> Subject: RES: RES: ReN: (ngtrans) IPv6 tranisition issues
> 
> 
> 
>   Folks,
> 
>    I think that Keith´s answer did not offend to me. I want 
> only a good debate about IPv6´s subjects. I really believe 
> that is possible to write code STATEFUL to NAT where whatever 
> application can be supported. I believe that all 
> connections/sessions related to one application can be 
> inpesctioned (in application layer)and port numbers and IP 
> address translated like in simple FTP.  Of this way, NAT can 
> provide support to many applications more complex. AGAIN, 
> stateful NAT with application sense can be implemented to 
> support this application. I really dont see reasons to that 
> one NAT applications-specific module can not be implemented. 
> In Linux, for example, exists IRC, Netmeeting and ICQ modules 
> to masquerading. I also believe that few implementation do 
> it. My apologies for my "irresponsible comments about NAT". I 
> only thougth that it was a free debate between civilized 
> people. Best Regards,
> 
> 			Marcelo.
> 
> -----Mensagem original-----
> De: Bound, Jim [mailto:[email-masked]]
> Enviada em: segunda-feira, 6 de janeiro de 2003 17:47
> Para: Fred L. Templin
> Cc: Keith Moore; Marcelo Barbosa Lima; [email-masked]; 
> [email-masked]
> Assunto: RE: RES: ReN: (ngtrans) IPv6 tranisition issues
> 
> 
> Hi Fred,
> 
> Missed the light part.  My apologies.  It is just some are so 
> rude in email I cannot help but wish them the worst from that 
> view.  And I do.
> 
> /jim
> 
>  
> 
> 
> > -----Original Message-----
> > From: Fred L. Templin [mailto:[email-masked]]
> > Sent: Monday, January 06, 2003 2:35 PM
> > To: Bound, Jim
> > Cc: Keith Moore; Marcelo Barbosa Lima; [email-masked]; 
> > [email-masked]
> > Subject: Re: RES: ReN: (ngtrans) IPv6 tranisition issues
> > 
> > 
> > Hi Jim,
> > 
> > Bound, Jim wrote:
> > > Fred,
> > > 
> > > I did not think Keiths mail was insulting.
> > 
> > Exactly why I prefaced my note with "No offense intended"; 
> just trying 
> > to make light of an ongoing discussion that has (to me) 
> become almost 
> > humerous by its cyclical nature. (Ever see the movie 
> "Groundhog Day"?)
> > 
> > Perhaps this was inappropriate, and hopefully has come at no
> > expense to Keith (apologies if it has). I certainly didn't 
> > intend to single Keith out as being solely responsible for 
> > perpetuating the thread.
> > 
> > Thanks,
> > 
> > Fred
> > [email-masked]
> > 
> > 
> 
>

---

From: "Michael R. Cole" <[email-masked]>
Date: Wed, 8 Jan 2003 02:20:59 -0500

----- Original Message -----
From: "Bound, Jim" <[email-masked]>
To: "Marcelo Barbosa Lima" <[email-masked]>; "Fred L. Templin"
<[email-masked]>
Cc: "Keith Moore" <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Tuesday, January 07, 2003 10:14 AM
Subject: RE: RES: ReN: (ngtrans) IPv6 tranisition issues

> No comment from me at this point.   I would not advocate the development
of state machines in code to support NAT at this point with IPv6 so close
though.
> /jim bound

IPv6 is still a long ways from production deployment. Some protocols are
still in the experimental stage or pre-experimental stage. Likewise, I have
not found a supported IPv6 dual stack implementation for Windows 2000 not
that I have no idea if I can run it through Earthlink.

There is also the problem that companies want extensive experience and they
want people to get experience from an invisible gremlin named Not Me. There
was even a company here in Cleveland who this past June advertised that they
wanted somebody with 2 years of experience with Windows 2000 - they were too
stupid to realize that Windows 2000 was not really released until October of
2000. Corporate stupidgroupthink will probably stretch out implementation of
IPv6 for possibly as long as 30 years!!!!