Subject: [Nmlrg] Machine Learning in network - solicitation for use cases

From: Sheng Jiang <[email-masked]>
Date: Mon, 31 Aug 2015 03:15:46 +0000

Hi, all,

Thanks for subscribe to NMLRG (Network Machine Learning) mail list. As we know, there are already many ongoing researches for Machine Learning in network, in many areas. But up to now, there are few matured applications yet. So it is the time for a Research Group to work on this future-oriented technology.

The first step would be to collect possible use cases: where the machine learning mechanism could be used in networks. The use cases does not need to be mature, but should have potential.

Note that this topic is rapidly moving from academic research into practical application. Therefore, use cases from university environments, industrial research and development organizations are all welcome.

Best regards,

Sheng

---

From: "Liubing (Leo)" <[email-masked]>
Date: Mon, 31 Aug 2015 07:06:15 +0000

Hi all,

We're working on a use case of applying Machine Learning technologies to network device initial configuration.
The basic scenario is to learn knowledge/patterns of how to configure a device from historical data (device configuration data of a number of networks ) and then apply them to the new networks.

This is to leverage the automation on network initial configuration and only require a minimal set of input such as high-level network planning, which includes architecture design, address pool/block assignment, protocol selection etc.

The advantages of using Machine Learning on network initial configuration could possibly be:
- Saving human cost
- Flexibility
  - dynamically generating configurations on site
  - adaptive to different types of networks
- The ability to continuously optimize the parameters, if the program also learning the running performance
- etc.

Comments are welcomed.

Best regards,
Bing

> -----Original Message-----
> From: nmlrg [mailto:[email-masked]] On Behalf Of Sheng Jiang
> Sent: Monday, August 31, 2015 11:16 AM
> To: [email-masked]
> Subject: [Nmlrg] Machine Learning in network - solicitation for use cases
> 
> Hi, all,
> 
> Thanks for subscribe to NMLRG (Network Machine Learning) mail list. As we
> know, there are already many ongoing researches for Machine Learning in
> network, in many areas. But up to now, there are few matured applications
> yet. So it is the time for a Research Group to work on this future-oriented
> technology.
> 
> The first step would be to collect possible use cases: where the machine
> learning mechanism could be used in networks. The use cases does not need
> to be mature, but should have potential.
> 
> Note that this topic is rapidly moving from academic research into practical
> application. Therefore, use cases from university environments, industrial
> research and development organizations are all welcome.
> 
> Best regards,
> 
> Sheng
> _______________________________________________
> nmlrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/nmlrg

---

From: Sheng Jiang <[email-masked]>
Date: Tue, 1 Sep 2015 03:27:23 +0000

>The basic scenario is to learn knowledge/patterns of how to configure a
>device from historical data (device configuration data of a number of
>networks ) and then apply them to the new networks.

Hi, Bing,

Thanks for sharing. It would be helpful if you could introduce a little bit more on how to leverage the machine learning in your use case, such as the learning objectives, what a result of the learning, how it apply to a network, etc. It would also useful to discuss the precondition of your use case and the constrain of the machine learning mechanism, either in general way or specific in your use case.

Best regards,

Sheng

>This is to leverage the automation on network initial configuration and only
>require a minimal set of input such as high-level network planning, which
>includes architecture design, address pool/block assignment, protocol
>selection etc.
>