Subject: [Nmlrg] Generic knowledge definition and format?

From: Sheng Jiang <[email-masked]>
Date: Tue, 17 Nov 2015 08:04:01 +0000

Hi, Albert,

Thanks for your interesting presentation in the proposed NMLRG meeting in Yokohama. It is a pity we do not have enough time discuss. However, mail list discussion may give us more flexibility to reach deep details. Since you have multiple use cases, let's discuss one by one for better communication.

In your use case 4: knowledge extraction, have you already done some prototype? Would you share some concrete example of knowledge? Actually, I am thinking whether it is feasible to give a generic definition of knowledge and whether it is possible to design a generic format/language to describe knowledge. If so, these knowledge may be much easier to be understood and trigger follow up actions.

Regards,

Sheng

---

From: Albert Cabellos <[email-masked]>
Date: Fri, 20 Nov 2015 10:51:05 +0100

Hi all

We have two experiments demonstrating use-case1 (Overlay Routing) and
use-case 2 (VNF):

Overlay Routing: We can learn how to route in an overlay network when
the underlay is hidden, this means that we learn the function that
relates the traffic matrix on the overlay, routing policy on the
overlay (traffic to paths defined as egress and ingress interfaces of
the overlay nodes) with the underlay performance.

VNF: We can learn the cost (CPU cycles) of a hidden VNF (black box) as
a function of the traffic that it is processing, in this case the
traffic is defined as 70 traffic features.

Unfortunately we don´t have yet an experiment for knowledge
extraction, mainly due to the lack of real-world data. Knowledge
extraction should (in my view) use statistical techniques such as
K-means, K-nearest neighbors and Correlation Analysis. Such techniques
operate over the data-set and hence, the result have the same
semantics than the data-set.

Albert

---

From: Sheng Jiang <[email-masked]>
Date: Fri, 20 Nov 2015 10:02:05 +0000

Hi, Albert,

Thank for your reply. Yes, we do know you have another two use cases. In order to be more concentrate, I planned to discuss them one by one. I will raise some questions for them later in different threads.

>semantics than the data-set.

I do understand and agree your above statement. Allow me to ask my questions in another way, if you can obtain data as you want, what data items will you choose to perform you machine learning process? What analysis tasks will you assign to the machine learning process? What feather or patent may you use? What kind of knowledge are you expecting from it?

I know you may not really have the answer. But let's discuss the potential. Then maybe later, we could be able to talk about where we may obtain the data to do some experimental.

Regards,

Sheng

>> Thanks for your interesting presentation in the proposed NMLRG meeting in
>Yokohama. It is a pity we do not have enough time discuss. However, mail list
>discussion may give us more flexibility to reach deep details. Since you have
>multiple use cases, let's discuss one by one for better communication.
>>
>> In your use case 4: knowledge extraction, have you already done some
>prototype? Would you share some concrete example of knowledge? Actually,
>I am thinking whether it is feasible to give a generic definition of knowledge
>and whether it is possible to design a generic format/language to describe
>knowledge. If so, these knowledge may be much easier to be understood and
>trigger follow up actions.
>>
>> Regards,
>>
>> Sheng

---

From: Albert Cabellos <[email-masked]>
Date: Tue, 24 Nov 2015 21:40:32 +0100

Hi all

Specifically for the knowledge extraction use-case I would take the
data-set and ask an expert to point to relevant events, events that
show a failure/misbehaviour, for instance a storm of BGP signaling
messages, or as simple as an interface flapping, going down, etc.

Then and by means of correlation analysis techniques, we will find
correlations between such relevant events and other prior and past
events. With this we can try to anticipate a failure/misbehaviour
and/or understand why it is happening.

I hope that this helps!

Albert