Subject: Re: [Nmlrg] recent paper on cognition-based networks

From: Andy Donati <[email-masked]>
Date: Thu, 2 Jun 2016 01:47:01 +0000

Michele,

Concepts on page 1516 under the heading of D. Unsupervised learning are akin to the operant conditioning concept within the behavioral learning theory of psychology and there may be a practical use of this concept described below.

Network operators are typically informed of alarmed raised and alarm cleared conditions by their management applications typically by an unsolicited message sent  from the networking machine in the form of an SNMP Notification (.a.k.a. Trap).

Today when a network device reports an undesirable condition in the form of a trap, the monitor application translates this notification as an alarm raised and the network operator has to manually address this issue in order to clear the alarm.  Upon resolution, a clear trap is sent by the network device to the management station which in turn removes the condition.   The network device knows that there is an undesirable condition in the network because it sends the trap to the central office.  But today the device does not know how to get out of this undesirable state and it is up to the network operator to fix the issue.

How can the operant conditioning model be employed by the network entity aid network operations when undesirable conditions occur?  A list of different configuration options can be defined where each implements a different way of dealing with the issue on how to clear the undesirable condition.  This list can be identified and enumerated in a switch case statement of let's say option 1, 2, or 3.  The discriminating stimulus is the alarm raised condition and when this occurs, the routine will be pointed to these 3 defined options.  The very first time this is implemented the machine has no knowledge of what works best and in this case it will randomly select one of the presented options.    Once the machine makes a choice and the condition clears in a short predefined time interval, the option selected will gain a point, however if the condition is not cleared, a point is taken away (if there are any to be taken away) and it will select a different option.  The extra points accumulated of a particular option increase the odds of that option being selected the next time the condition occurs.

In order to be fair to all 3 options, each need to be tried once before the machine begins to make decisions on it's own.  Also, since any particular choice will likely involve a configuration change, there must be a long predefined time interval when the configuration reverts back to its original state before the next choice can be made.   Also it is important to note that like today, alarm raised and alarm clear traps are still sent from the device, but an additional event based trap is sent informing the operator that a particular option was chosen automatically by the machine.

Regards,
Andy Donati
________________________________________
From: nmlrg <[email-masked]> on behalf of Michele Zorzi <[email-masked]>
Sent: Tuesday, May 24, 2016 7:52 AM
To: [email-masked]
Subject: [Nmlrg] recent paper on cognition-based networks

Hi all,

I would like to point you to a recent paper we published, which tries to
scope out some vision for cognitive networking beyond the more traditional
view of cognitive radio. Please find it on IEEExplore (it is open access)
at http://ieeexplore.ieee.org/xpl/abstractCitations.jsp?arnumber=7217798

I will very much welcome your comments and feeback, especially about the
practical feasibility of this approach. I will also welcome expressions of
interest to collaborate on furthering this into something more concrete.

Thanks a lot,

Michele

_______________________________________________
nmlrg mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/nmlrg

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 14 Jun 2016 14:01:16 +1200

Michele,

I read the paper with interest; it even cites an article by one of
my colleagues in Auckland (Aniket Mahani).

I have a practical question. You correctly observe that computing
power is now cheap enough to consider such techniques, but I'm
wondering what that really means. Can we imagine ML inside
high-end routers? Line speed firewalls? Or will it be confined
to specialised nodes that serve up ML results to network devices?

Another question is more abstract. You focus on unsupervised
learning where (if I understand correctly) the features that are
learned have no direct relationship to features that humans
consider important. In that situation, how can we translate what
we are calling "Intent" in the IETF work on autonomics into
goals for the ML-based system? Or to give a concrete example,
suppose there is an Intent statement that jitter (more precisely,
Packet Delay Variation, RFC3393) for voice streams must be less
than N milliseconds. How do we relate that to ML-derived features
in a packet stream?

Regards
   Brian Carpenter

On 24/05/2016 23:52, Michele Zorzi wrote:
> 
> Hi all,
> 
> I would like to point you to a recent paper we published, which tries to scope out some vision for cognitive networking beyond
> the more traditional view of cognitive radio. Please find it on IEEExplore (it is open access) at
> http://ieeexplore.ieee.org/xpl/abstractCitations.jsp?arnumber=7217798
> 
> I will very much welcome your comments and feeback, especially about the practical feasibility of this approach. I will also
> welcome expressions of interest to collaborate on furthering this into something more concrete.
> 
> Thanks a lot,
> 
> Michele
>

---

From: Panagiotis Demestichas <[email-masked]>
Date: Sun, 19 Jun 2016 18:47:07 +0300

Dear all

with respect to the article of Michele and to the comments of Brian, I have
a remark, primarily, on the relation of intent and ML techniques (hope I
got the question correctly).

I will start from the second, that of the relation of intent and
unsupervized machine learning techniques.

In general, my view regarding the relation of intent and ML is that it
depends on the scenarios, on what we are trying to solve. I will take the
example as a basis.

-- The declaration of intent may designate "clusters", and, therefore,
imply that supervized learning techniques are enough. E.g., situations
addressed and network configurations used can be split into clusters that
yield jitter above or below the indicated threshold.

-- The declaration of intent may also leave degrees of freedom. In this
case unsupervized learning may be most appropriate. E.g., we may be
interested in aspects further to the jitter entailed by a situation
addressed and the configuration used. Such aspects may be the energy
consumption, the spectrum needed, etc.

Further views are welcome, and of course further elaboration is possible.

Best regards
Panagiotis

On Tue, Jun 14, 2016 at 5:01 AM, Brian E Carpenter <
[email-masked]> wrote:

> scope out some vision for cognitive networking beyond
> practical feasibility of this approach. I will also

-- 
Panagiotis Demestichas
Professor
University of Piraeus
School of Information and Communication Technology
Department of Digital Systems
Telecommunication Networks and integrated Services (TNS) Laboratory
Office:         +302104142758
Laboratory: +302104142749
Cellular:      +306944243856
Skype:        pdemest
Office: 150 Androutsou, 18532, Piraeus, GREECE
Mail :  80 Karaoli and Dimitriou, 18534, Piraeus, GREECE