Subject: [NNTP] Diffs

From: "Clive D.W. Feather" <[email-masked]>
Date: Mon, 30 May 2005 23:17:58 +0100

Just for the record, here's a set of diffs between the draft 26 text and my
current working text.

--- draft26.unpg	Sat May 21 23:20:00 2005
+++ draft27.unpg	Fri May 27 15:00:27 2005
@@ -3,11 +3,13 @@
 
 NNTP                                                          C. Feather
 Internet-Draft                                                  Thus plc
-Expires: November 21, 2005                                  May 20, 2005
+Updates: 2980 (if approved)                                 May 26, 2005
+Obsoletes: 977 (if approved)
+Expires: November 27, 2005

                      Network News Transfer Protocol
-                       draft-ietf-nntpext-base-26
+                       draft-ietf-nntpext-base-27
 
 Status of this Memo
 
@@ -32,7 +34,7 @@
    The list of Internet-Draft Shadow Directories can be accessed at
    http://www.ietf.org/shadow.html.
 
-   This Internet-Draft will expire on November 21, 2005.
+   This Internet-Draft will expire on November 27, 2005.
 
 Copyright Notice
 
@@ -52,6 +54,8 @@
    This document is a product of the NNTP Working Group, chaired by Russ
    Allbery and Ned Freed.
 
+   This is draft 27 pre-publication version 1.
+
 Author's Note
 
    This document is written in XML using an NNTP-specific DTD.  Custom
@@ -65,6 +69,19 @@
 
    UNIX is a registered trademark of The Open Group.
 
+Note to the RFC Editor
+
+   The normative reference to RFC 2234 [RFC2234] and the informative
+   reference to RFC 2629 [RFC2629] may be replaced by
+   draft-crocker-abnf-rfc2234bis and draft-mrose-writing-rfcs
+   respectively should either or both of those documents reach RFC
+   status before this one.
+
+   The informative references to [NNTP-AUTH], [NNTP-STREAM], and [NNTP-
+   TLS] are documents which are expected to be published simultaneously
+   with this one and so can be replaced by references to the resulting
+   RFCs.
+
 
 Table of Contents
 
@@ -2159,7 +2176,7 @@
       [S] Subject: I am just a test article
       [S] Date: 6 Oct 1998 04:38:40 -0500
       [S] Organization: An Example Net, Uncertain, Texas
-      [S] Message-ID: <[email-masked]>
+      [S] Message-ID: <[email-masked]>
       [S]
       [S] This is just a test article.
       [S] .
@@ -2174,7 +2191,7 @@
       [S] Subject: I am just a test article
       [S] Date: 6 Oct 1998 04:38:40 -0500
       [S] Organization: An Example Net, Uncertain, Texas
-      [S] Message-ID: <[email-masked]>
+      [S] Message-ID: <[email-masked]>
       [S]
       [S] This is just a test article.
       [S] .
@@ -2265,7 +2282,7 @@
       [S] Subject: I am just a test article
       [S] Date: 6 Oct 1998 04:38:40 -0500
       [S] Organization: An Example Net, Uncertain, Texas
-      [S] Message-ID: <[email-masked]>
+      [S] Message-ID: <[email-masked]>
       [S] .
 
    Example of a successful retrieval of the headers of an article by
@@ -2279,7 +2296,7 @@
       [S] Subject: I am just a test article
       [S] Date: 6 Oct 1998 04:38:40 -0500
       [S] Organization: An Example Net, Uncertain, Texas
-      [S] Message-ID: <[email-masked]>
+      [S] Message-ID: <[email-masked]>
       [S] .
 
    Example of an unsuccessful retrieval of the headers of an article by
@@ -3748,6 +3765,10 @@
    This command MAY generate different results if used more than once in
    a session.
 
+   If the OVER command is not implemented, the meaning of the output
+   from this command is not specified but it must still meet the above
+   syntactic requirements.
+
 8.4.3.  Examples
 
    Example of LIST OVERVIEW.FMT output corresponding to the example OVER
@@ -4037,6 +4058,10 @@
    If the server does not treat the various forms differently, then it
    MUST always produce the same results and ignore any argument.
 
+   If the HDR command is not implemented, the meaning of the output from
+   this command is not specified but it must still meet the above
+   syntactic requirements.
+
 8.6.3.  Examples
 
    Example of an implementation providing access to only a few headers:
@@ -5012,6 +5037,7 @@
       Andrew Gierth
       Juergen Helbing
       Scott Hollenbeck
+      Urs Janssen
       Charles Lindsey
       Ade Lovett
       David Magda
@@ -5022,6 +5048,7 @@
       Howard Swinehart
       Ruud van Tol
       Jeffrey Vinocur
+      Eric Warmelink
 
    The author thanks them all and apologises to anyone omitted.
 
@@ -5211,6 +5238,21 @@
    simple sequence number or based on the date and time that the article
    arrived.  When handling email or Netnews articles, a Message-ID
    header SHOULD be added to ensure global consistency and uniqueness.
+
+   Note that, because the message-id might not have been derived from
+   the Message-ID header in the article, the following example is
+   legitimate:
+
+      [C] HEAD <[email-masked]>
+      [S] 221 0 <[email-masked]>
+      [S] Path: pathost!demo!whitehouse!not-for-mail
+      [S] Message-ID: <[email-masked]>
+      [S] From: "Demo User" <[email-masked]>
+      [S] Newsgroups: misc.test
+      [S] Subject: I am just a test article
+      [S] Date: 6 Oct 1998 04:38:40 -0500
+      [S] Organization: An Example Net, Uncertain, Texas
+      [S] .
 
 A.3.  Article posting

-- 
Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:    +44 20 8495 6138
Internet Expert     | Home:  <[email-masked]>  | Fax:    +44 870 051 9937
Demon Internet      | WWW: http://www.davros.org | Mobile: +44 7973 377646
Thus plc            |                            |

---

From: "Charles Lindsey" <[email-masked]>
Date: Tue, 31 May 2005 11:24:37 GMT

>+   the Message-ID header in the article, the following example is
               ^
             (though unusual)

[We don't want to give any impression that such oddities are in any way
normal, otherwise everybody will be doing it :-(. ]

-- 
Charles H. Lindsey ---------At Home, doing my own thing------------------------
Tel: +44 161 436 6131 Fax: +44 161 436 6133   Web: http://www.cs.man.ac.uk/~chl
Email: [email-masked]      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9      Fingerprint: 73 6D C2 51 93 A0 01 E7 65 E8 64 7E 14 A4 AB A5