Subject: [NNTP] Re: Fwd: Last Call: 'Network News Transfer Protocol' to Proposed Standard

From: Russ Allbery <[email-masked]>
Date: Wed, 25 May 2005 09:34:01 -0700

Erik Warmelink <[email-masked]> writes:
> Russ Allbery <[email-masked]> writes:

>> The IESG has received a request from the NNTP Extensions WG to consider the 
>> following document:
>> 
>> - 'Network News Transfer Protocol '
>>    <draft-ietf-nntpext-base-26.txt> as a Proposed Standard

> If I understand the semantics of "ARTICLE" correctly, on page 50,
> under "Example of a successful retrieval of an article by message-id:"
> one would expect:

>        [C] ARTICLE <[email-masked]>
>        [S] 220 0 <[email-masked]>
>        [S] Path: pathost!demo!whitehouse!not-for-mail
>        [S] From: "Demo User" <[email-masked]>
>        [S] Newsgroups: misc.test
>        [S] Subject: I am just a test article
>        [S] Date: 6 Oct 1998 04:38:40 -0500
>        [S] Organization: An Example Net, Uncertain, Texas
> -      [S] Message-ID: <[email-masked]>
> +      [S] Message-ID: <[email-masked]>
>        [S]
>        [S] This is just a test article.
>        [S] .

Yes, that's confusing even if it's intended to be an intentional example
of how NNTP doesn't necessarily care about the body of the article.  I'll
forward this along to the working group.

Thanks!

-- 
Russ Allbery ([email-masked])             <http://www.eyrie.org/~eagle/>

          Please post questions rather than mailing me directly.
     <http://www.eyrie.org/~eagle/faqs/questions.html> explains why.

---

From: "Clive D.W. Feather" <[email-masked]>
Date: Thu, 26 May 2005 10:38:39 +0100

> forward this along to the working group.

Blast. It's legal (see 6.3.2.3 and A.2) but this is not the place to
expound it.

I'll fix this example and the related ones, and add an example to A.2.

-- 
Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:    +44 20 8495 6138
Internet Expert     | Home:  <[email-masked]>  | Fax:    +44 870 051 9937
Demon Internet      | WWW: http://www.davros.org | Mobile: +44 7973 377646
Thus plc            |                            |

---

From: "Ruud H.G. van Tol" <[email-masked]>
Date: Thu, 26 May 2005 12:41:27 +0200

> I'll fix this example and the related ones, and add an example to A.2.

Would it be enlightening to vary the casing of the commands in the
examples?
UPPERCASE, lowercase, CamelCase, etc.

-- 
Grtz, Ruud

---

From: "Clive D.W. Feather" <[email-masked]>
Date: Thu, 26 May 2005 12:02:22 +0100

> UPPERCASE, lowercase, CamelCase, etc.

I don't think so.

If we want to demonstrate this at all, it should be in a separate examples
section within 3.1. About the only other thing I can think of to demonstrate
in that is multi-line data blocks, so I'm not sure how worth it it is.