Subject: [NNTP] FW: Last Call Expired: <draft-ietf-nntpext-base>

From: "Scott Hollenbeck" <[email-masked]>
Date: Tue, 7 Jun 2005 08:53:00 -0400

The IETF last call for draft-ietf-nntpext-base has completed.  I'm not sure
that all of the last call questions were resolved (I'd point to the
messages, but the WG list archives appear to be both mis-identified on the
IETF WG charter page and incomplete here:

https://mailman.academ.com/pipermail/ietf-nntp/

the archive situation REALLY needs to be fixed):

1. Is the new base spec supposed to obsolete or update 2980?

2. Example on page 50.

I didn't see any other comments other than the General Area one from Spencer
Dawkins and I don't think there's anything there to address.  If we can get
through these quickly and have the document updated before 16 June I can
have it scheduled for IESG review during the 23 June telechat.

-Scott-

-----Original Message-----
From: DraftTracker Mail System [mailto:[email-masked]] 
Sent: Monday, June 06, 2005 11:30 PM
To: [email-masked]
Cc: [email-masked]
Subject: Last Call Expired: <draft-ietf-nntpext-base> 

Please DO NOT reply on this email.

ID: draft-ietf-nntpext-base

IETF Last Call has ended, and the state has been changed to Waiting for AD
Go-Ahead

---

From: Russ Allbery <[email-masked]>
Date: Tue, 07 Jun 2005 10:26:37 -0700

Scott Hollenbeck <[email-masked]> writes:

> The IETF last call for draft-ietf-nntpext-base has completed.  I'm not
> sure that all of the last call questions were resolved (I'd point to the
> messages, but the WG list archives appear to be both mis-identified on
> the IETF WG charter page and incomplete here:

> the archive situation REALLY needs to be fixed):

I've tried to get the IETF WG charter page fixed a couple times.  I
thought it took the last time, but apparently it didn't.  The list
archives are at:

    <http://lists.eyrie.org/pipermail/ietf-nntp/>

for everything after August of 2004, which is when we moved the mailing
list because the previous server was having too many difficulties.

Of course, the lack of update to the IETF WG charter page is probably also
why the list doesn't get any spam.  *wry grin*

> 1. Is the new base spec supposed to obsolete or update 2980?

I believe it's supposed to update 2980.

> I didn't see any other comments other than the General Area one from
> Spencer Dawkins and I don't think there's anything there to address.  If
> we can get through these quickly and have the document updated before 16
> June I can have it scheduled for IESG review during the 23 June
> telechat.

That sounds great!

-- 
Russ Allbery ([email-masked])             <http://www.eyrie.org/~eagle/>

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Tue, 7 Jun 2005 13:37:36 -0400

Russ,

Check out the archives linked-to from this web page:

http://www.academ.com/academ/nntp/ietf.html

(this page is listed on the IETF charter page)

This page seems to have archives for as recently as February 2005.

The web page should be fixable by sending the needed corrections to the
Secretariat.  I'll approve them, and the request will be tracked.  Could you
try to have the page updated again, please?

Please keep me posted on the document update and we'll get this through as
quickly as possible.

The other last calls end today.  More info coming on those no later than
tomorrow.

-Scott-

> From: Russ Allbery [mailto:[email-masked]] 
> Sent: Tuesday, June 07, 2005 1:27 PM
> To: [email-masked]
> Cc: Scott Hollenbeck
> Subject: Re: [NNTP] FW: Last Call Expired: <draft-ietf-nntpext-base>
>

---

From: Russ Allbery <[email-masked]>
Date: Tue, 07 Jun 2005 11:05:44 -0700

> Secretariat.  I'll approve them, and the request will be tracked.  Could
> you try to have the page updated again, please?

Done.

> Please keep me posted on the document update and we'll get this through
> as quickly as possible.

> The other last calls end today.  More info coming on those no later than

Thank you very much for your work on this!  I'm getting rather excited; it
feels like we're almost there.  :)

---

From: "Clive D.W. Feather" <[email-masked]>
Date: Wed, 8 Jun 2005 06:38:26 +0100

> 1. Is the new base spec supposed to obsolete or update 2980?

Both addressed in my current version (see the diffs I sent round a week or
so ago).

What happens now? Do I send draft 27 to the I-D editor?

-- 
Clive D.W. Feather  | Work:  <[email-masked]>   | Tel:    +44 20 8495 6138
Internet Expert     | Home:  <[email-masked]>  | Fax:    +44 870 051 9937
Demon Internet      | WWW: http://www.davros.org | Mobile: +44 7973 377646
Thus plc            |                            |

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Wed, 8 Jun 2005 07:13:07 -0400

> From: Clive D.W. Feather [mailto:[email-masked]] 
> Sent: Wednesday, June 08, 2005 1:38 AM
> To: Scott Hollenbeck
> Cc: [email-masked]

Yes, you update the document and send it to the I-D administrator.  I'll
pick it up once it hits the archives.

-Scott-

---

From: "Clive D.W. Feather" <[email-masked]>
Date: Wed, 8 Jun 2005 18:20:02 +0100

> pick it up once it hits the archives.

Okay: Unidiff of drafts 26 and 27 (the unpaginated versions). Russ, please
confirm this is final before I send the latter to the I-D admins.

--- draft26.unpg.txt	Sat May 21 23:20:00 2005
+++ draft27.unpg.txt	Wed Jun  8 18:15:44 2005
@@ -3,11 +3,13 @@
 
 NNTP                                                          C. Feather
 Internet-Draft                                                  Thus plc
-Expires: November 21, 2005                                  May 20, 2005
+Updates: 2980 (if approved)                                 June 8, 2005
+Obsoletes: 977 (if approved)
+Expires: December 10, 2005

                      Network News Transfer Protocol
-                       draft-ietf-nntpext-base-26
+                       draft-ietf-nntpext-base-27
 
 Status of this Memo
 
@@ -32,7 +34,7 @@
    The list of Internet-Draft Shadow Directories can be accessed at
    http://www.ietf.org/shadow.html.
 
-   This Internet-Draft will expire on November 21, 2005.
+   This Internet-Draft will expire on December 10, 2005.
 
 Copyright Notice
 
@@ -65,6 +67,19 @@
 
    UNIX is a registered trademark of The Open Group.
 
+Note to the RFC Editor
+
+   The normative reference to RFC 2234 [RFC2234] and the informative
+   reference to RFC 2629 [RFC2629] may be replaced by
+   draft-crocker-abnf-rfc2234bis and draft-mrose-writing-rfcs
+   respectively should either or both of those documents reach RFC
+   status before this one.
+
+   The informative references to [NNTP-AUTH], [NNTP-STREAM], and [NNTP-
+   TLS] are documents which are expected to be published simultaneously
+   with this one and so can be replaced by references to the resulting
+   RFCs.
+
 
 Table of Contents
 
@@ -2159,7 +2174,7 @@
       [S] Subject: I am just a test article
       [S] Date: 6 Oct 1998 04:38:40 -0500
       [S] Organization: An Example Net, Uncertain, Texas
-      [S] Message-ID: <[email-masked]>
+      [S] Message-ID: <[email-masked]>
       [S]
       [S] This is just a test article.
       [S] .
@@ -2174,7 +2189,7 @@
       [S] Subject: I am just a test article
       [S] Date: 6 Oct 1998 04:38:40 -0500
       [S] Organization: An Example Net, Uncertain, Texas
-      [S] Message-ID: <[email-masked]>
+      [S] Message-ID: <[email-masked]>
       [S]
       [S] This is just a test article.
       [S] .
@@ -2265,7 +2280,7 @@
       [S] Subject: I am just a test article
       [S] Date: 6 Oct 1998 04:38:40 -0500
       [S] Organization: An Example Net, Uncertain, Texas
-      [S] Message-ID: <[email-masked]>
+      [S] Message-ID: <[email-masked]>
       [S] .
 
    Example of a successful retrieval of the headers of an article by
@@ -2279,7 +2294,7 @@
       [S] Subject: I am just a test article
       [S] Date: 6 Oct 1998 04:38:40 -0500
       [S] Organization: An Example Net, Uncertain, Texas
-      [S] Message-ID: <[email-masked]>
+      [S] Message-ID: <[email-masked]>
       [S] .
 
    Example of an unsuccessful retrieval of the headers of an article by
@@ -3748,6 +3763,10 @@
    This command MAY generate different results if used more than once in
    a session.
 
+   If the OVER command is not implemented, the meaning of the output
+   from this command is not specified but it must still meet the above
+   syntactic requirements.
+
 8.4.3.  Examples
 
    Example of LIST OVERVIEW.FMT output corresponding to the example OVER
@@ -4037,6 +4056,10 @@
    If the server does not treat the various forms differently, then it
    MUST always produce the same results and ignore any argument.
 
+   If the HDR command is not implemented, the meaning of the output from
+   this command is not specified but it must still meet the above
+   syntactic requirements.
+
 8.6.3.  Examples
 
    Example of an implementation providing access to only a few headers:
@@ -5012,6 +5035,7 @@
       Andrew Gierth
       Juergen Helbing
       Scott Hollenbeck
+      Urs Janssen
       Charles Lindsey
       Ade Lovett
       David Magda
@@ -5022,6 +5046,7 @@
       Howard Swinehart
       Ruud van Tol
       Jeffrey Vinocur
+      Eric Warmelink
 
    The author thanks them all and apologises to anyone omitted.
 
@@ -5211,6 +5236,21 @@
    simple sequence number or based on the date and time that the article
    arrived.  When handling email or Netnews articles, a Message-ID
    header SHOULD be added to ensure global consistency and uniqueness.
+
+   Note that, because the message-id might not have been derived from
+   the Message-ID header in the article, the following example is
+   legitimate (though unusual):
+
+      [C] HEAD <[email-masked]>
+      [S] 221 0 <[email-masked]>
+      [S] Path: pathost!demo!whitehouse!not-for-mail
+      [S] Message-ID: <[email-masked]>
+      [S] From: "Demo User" <[email-masked]>
+      [S] Newsgroups: misc.test
+      [S] Subject: I am just a test article
+      [S] Date: 6 Oct 1998 04:38:40 -0500
+      [S] Organization: An Example Net, Uncertain, Texas
+      [S] .
 
 A.3.  Article posting

---

From: Russ Allbery <[email-masked]>
Date: Wed, 08 Jun 2005 12:24:06 -0700

> confirm this is final before I send the latter to the I-D admins.

Looks right to me.

---

From: "Clive D.W. Feather" <[email-masked]>
Date: Thu, 9 Jun 2005 08:37:11 +0100

>> confirm this is final before I send the latter to the I-D admins.

Right, draft 27 now dispatched.

Versions available in the usual place:

<http://www.davros.org/nntp-texts/draft27.txt>
<http://www.davros.org/nntp-texts/draft27.unpg.txt>
<http://www.davros.org/nntp-texts/draft27.html>