Subject: Re: [NNTP] Compressed LIST (and other commands) answers

From: Urs Janßen <[email-masked]>
Date: Wed, 2 Dec 2009 11:31:32 +0100

On Wed, Dec 02, 2009 at 02:16:35AM -0800, Ade Lovett wrote:
> Ask yourselves these two questions:
> 
> 1.  If I'm attempting to download binaries faster, what does <compression-technique> give me?
> 2.  If I'm spending a lot of time in high-traffic text newsgroups, what does <compression-technique> give me?
>
> Pay particular attention to the fact that consumers of (1) and (2) above are most likely already on high speed internet connections (heck, I pay $19.95/mo for 10/3) and so are _not_ the target audience.

I only do text newsgroups and compression would speed up inital connection
times and group entering (at least with tin).

> Again, I ask folks.  Is this really a "problem" that needs to be "solved" ?

compression does happen in the real world (giganews, astraweb, diablo), we
can ignore that or try to come up with something usefull in a standard so we
do not see tons of different implementations and at least reader authors end
up in a nightmare.

urs
-- 
"Only whimps use tape backup: _real_ men just upload their important stuff
 on ftp, and let the rest of the world mirror it ;)" - Linus

---

From: Ade Lovett <[email-masked]>
Date: Wed, 2 Dec 2009 02:36:52 -0800

> do not see tons of different implementations and at least reader authors end

You miss the point.

Various server providers have come up with a number of non-standard methods in which to perform compression.

From a client perspective, it is not unreasonable to expect those server authors to document, via IETF et al., the ways in which they are doing things.

The fact that they haven't merely indicates further that they are not interested in the Usenet community at large, and are implementing said details purely to knock up a few notches on the "hey, we're cool" belt.

Astraweb.  Giganews, Highwinds.  Sure, you and I have .. history.  But we're talking about a community here.  A community on which you're making millions of dollars per year.

How about y'all show some interest in standardization?

-aDe