Subject: [NNTP] Tr: Last Call: draft-elie-nntp-list-additions (Network News Transfer Protocol (NNTP) Additions to LIST Command) to Proposed Standard

From: Julien ÉLIE <[email-masked]>
Date: Thu, 24 Jun 2010 15:44:07 +0200

Hi all,

The draft specifying the COUNTS, DISTRIBUTIONS, MODERATORS, MOTD,
and SUBSCRIPTIONS variants to the LIST command, as well as additional
'j', 'x' and '=' status for a newsgroup, is currently in Last Call.

If you have any comments, do not hesitate to tell before July, 16th 2010.

Thanks,

-- 
Julien

----- Message d'origine ----- 
De : "The IESG" <[email-masked]>
Groupes de discussion : gmane.ietf.announce
À : "IETF-Announce" <[email-masked]>
Envoyé : samedi 19 juin 2010 02:08
Objet : Last Call: draft-elie-nntp-list-additions (Network News Transfer Protocol (NNTP) Additions to LIST Command) to Proposed 
Standard

> The IESG has received a request from an individual submitter to consider
> the following document:
>
> - 'Network News Transfer Protocol (NNTP) Additions to LIST Command '
>   <draft-elie-nntp-list-additions-03.txt> as a Proposed Standard
>
> The IESG plans to make a decision in the next few weeks, and solicits
> final comments on this action.  Please send substantive comments to the
> [email-masked] mailing lists by 2010-07-16. Exceptionally,
> comments may be sent to [email-masked] instead. In either case, please
> retain the beginning of the Subject line to allow automated sorting.
>
> The file can be obtained via
> http://www.ietf.org/internet-drafts/draft-elie-nntp-list-additions-03.txt
>
>
> IESG discussion can be tracked via
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=19404&rfc_flag=0
>

---

From: Julien ÉLIE <[email-masked]>
Date: Thu, 24 Jun 2010 15:57:51 +0200

Hi,

* Regarding LIST COUNTS, the separator is one or more spaces.
It is like LIST ACTIVE.  That is to say no tabulation is allowed.

  list-counts-content =
        *(newsgroup-name 3(SPA article-number)
        SPA newsgroup-status CRLF)

I think that is the best thing to do (SPA instead of WS) but
do not hesitate to tell if you think WS is better.
As LIST COUNTS is very similar to LIST ACTIVE and as LIST ACTIVE
uses SPA for historical reasons (client parsers expect spaces),
I think we should go on with SPA for LIST COUNTS.
(Highwind servers and INN 2.5.2 use a single space.)

* A question by Alexey, the Area Director sponsor for the draft:

LIST MODERATORS
2.4.3.  Example

       Similarly, a "%s" pattern rule cannot be used for the moderation
       submission template for two moderated newsgroups whose names
       differ only by the case of their characters.

Left hand sides of email addresses are actually case sensitive (although
most end systems treat them as case-insensitive).
Therefore, is this remark for LIST MODERATORS accurate?  Maybe we should
say "It is recommended not to use [...]" because, clearly, "cannot"
is wrong.

What do you think about that?  Is it the right fix to do?

-- 
Julien ÉLIE

« -- C'est un drôle de nom, HCL.
  -- C'est son immatriculation d'espion. Son vrai nom,
  c'est Acidcloridrix... » (Astérix)

---

From: Russ Allbery <[email-masked]>
Date: Thu, 24 Jun 2010 10:40:54 -0700

> What do you think about that?  Is it the right fix to do?

While the LHS of an email address is case-sensitive in the standard, most
mail systems do not treat it as case-sensitive without going to special
work to configure them to do so, which means that in practice relying on
that case-sensitivity is unlikely to work.  We should probably say that
explicitly, but I think the provision of the text here is correct.

-- 
Russ Allbery ([email-masked])             <http://www.eyrie.org/~eagle/>