Subject: [nsc] Question regarding topology for bidirectional service chains

From: Ron Parker <[email-masked]>
Date: Thu, 27 Jun 2013 18:58:45 +0000

I have a question for the group regarding bidirectional service chains.

For sake of discussion, I will call the directions of packet flow East and West.    Let's also assume that classification-only nodes exist at each end of the chain and that service-only nodes exist in the middle.   And for simplicity of discussion, let's say that service invocation order is an exact mirror in each direction.

     <---->classifier-West <---->service-node-1 <---->service-node-2 <---->service-node-3 <---->classifier-East <---->

In the eastbound direction, classifier-West first receives the traffic from some upstream node and determines the service-chain.   Likewise, in the westbound direction, classifier-East first receives the traffic from some upstream node and determines the service-chain.   But, what about at the final end of each chain?    Must eastbound traffic traverse classifier-East and must westbound traffic traverse classifier-West?

I'm suspecting that the answer is no, but it does create the asymmetrical requirement that a non-classifier node can never be NLF-ingress, but can be NLF-egress.

     -->classifier-West -->service-node-1 -->service-node-2 -->service-node-3 -->
     <--service-node-1 <--service-node-2 <--service-node-3 <--classifier-East <--

Thanks.

   Ron

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Thu, 27 Jun 2013 22:48:55 +0000

Hi Ron,

I believe that both scenario's are valid; in some cases traffic will be required to flow through both ingress and egress classifiers in both directions and in others it will not. In either case however a binding between east and west chain must be established (so that the chain is in fact bidirectional).

From: Ron Parker <[email-masked]<mailto:[email-masked]>>
Date: Thursday, June 27, 2013 2:58 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [nsc] Question regarding topology for bidirectional service chains

For sake of discussion, I will call the directions of packet flow East and West.    Let’s also assume that classification-only nodes exist at each end of the chain and that service-only nodes exist in the middle.   And for simplicity of discussion, let’s say that service invocation order is an exact mirror in each direction.

I’m suspecting that the answer is no, but it does create the asymmetrical requirement that a non-classifier node can never be NLF-ingress, but can be NLF-egress.

Thanks.

   Ron

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 28 Jun 2013 01:34:01 +0200

Hi Jim,

I would agree with your conclusion.

However bidirectional flows can be accomplished at the network level
or at the network orchestration level.

I think proceeding in both planes may unnecessarily complicate things.
Do you really think bidirectional flows must be happening at the
network level ? I think much easier could be to provide them at the
higher levels.

Regards,
R.

> On Fri, Jun 28, 2013 at 12:48 AM, Jim Guichard (jguichar) <[email-masked]> wrote:
>
> Hi Ron,
>
> I believe that both scenario's are valid; in some cases traffic will be
> required to flow through both ingress and egress classifiers in both
> directions and in others it will not. In either case however a binding
> between east and west chain must be established (so that the chain is in
> fact bidirectional).
>
> From: Ron Parker <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> For sake of discussion, I will call the directions of packet flow East and
> West.    Let’s also assume that classification-only nodes exist at each end
> of the chain and that service-only nodes exist in the middle.   And for
> simplicity of discussion, let’s say that service invocation order is an
> exact mirror in each direction.
>
>
>
>      ßàclassifier-West ßàservice-node-1 ßàservice-node-2 ßàservice-node-3
> ßàclassifier-East ßà
>
>
>
> In the eastbound direction, classifier-West first receives the traffic from
> some upstream node and determines the service-chain.   Likewise, in the
> westbound direction, classifier-East first receives the traffic from some
> upstream node and determines the service-chain.   But, what about at the
> final end of each chain?    Must eastbound traffic traverse classifier-East
> and must westbound traffic traverse classifier-West?
>
>
>
> I’m suspecting that the answer is no, but it does create the asymmetrical
> requirement that a non-classifier node can never be NLF-ingress, but can be
> NLF-egress.
>
>
>
>      àclassifier-West àservice-node-1 àservice-node-2 àservice-node-3 à
>
>      ßservice-node-1 ßservice-node-2 ßservice-node-3 ßclassifier-East ß
>
>
>
>
>
> Thanks.
>
>
>
>    Ron
>
>
> _______________________________________________
> nsc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nsc
>

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Thu, 27 Jun 2013 23:39:52 +0000

Hi Robert,

I agree. Personally I think they should happen at the network orchestration level and be pushed to the relevant network nodes.

Sent from my iPhone

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 28 Jun 2013 01:41:32 +0200

Same here !

Great,
R.