Subject: [nsc] FW: FW: Comments on draft-quinn-nsh-00

From: "NAPIERALA, MARIA H" <[email-masked]>
Date: Fri, 19 Jul 2013 04:58:26 +0000

Surendra,

Thanks for clarifying few aspects of the proposal. Please see in-line.

Maria

From: Surendra Kumar (smkumar) [mailto:[email-masked]]
Sent: Tuesday, July 16, 2013 3:38 PM
To: NAPIERALA, MARIA H; Jim Guichard (jguichar)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [nsc] FW: Comments on draft-quinn-nsh-00

<MN> Cut off text.
[...]

<SK> In general I would tend to agree with notion that services should be focused on the service functions. A service has the service function and it may have a forwarding component or interact with one.
The forwarding component may be tasked to manipulate the service header. The network or the infrastructure may provide that for the service to integrate with (see below comment as well) strongly or as a proxy. The header does not dictate any of this. For those services that do own both the components, the draft does not prevent the use of the header.

<MN> Actually, the draft says that "Participating nodes *MUST* use the base header for selecting the next service in the service path".

Commingling signaling of network connectivity with signaling of metadata is unnecessary and counterproductive, IMO.

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Fri, 19 Jul 2013 19:23:49 +0000

Maria,
The draft specifies that the participating node must use the base header for selecting the next service in the service path but its does not specify that the location of said next service must be carried in the header. There is therefore no co-mingling of network connectivity and signaling of metadata implied in the wording of the draft.

From: <NAPIERALA>, MARIA H <[email-masked]<mailto:[email-masked]>>
Date: Friday, July 19, 2013 12:58 AM
To: "Surendra Kumar (smkumar)" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [nsc] FW: FW: Comments on draft-quinn-nsh-00

Surendra,

Maria

<MN> Cut off text.
[…]

<MN> Actually, the draft says that “Participating nodes *MUST* use the base header for selecting the next service in the service path”.