Subject: [nsc] IETF 87 NSC BoF

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Fri, 19 Jul 2013 17:29:41 +0000

Greetings,

As you are hopefully aware by now a Network Service Chaining (NSC) BoF has been scheduled for IETF 87 in Berlin (Monday, July 29th, 1510-1610 CEST).  A preliminary (subject to change) agenda has been posted and may be found here -> http://tools.ietf.org/agenda/87/agenda-87-nsc.html. Presentations for the BoF will be posted the end of next week (week of July 21st) so that you have time to review them prior to the meeting in Berlin.

The primary goal of this BoF is to let network operators explain their NSC use cases and requirements so that the IETF is exposed to the problem space. Our agenda is therefore tailored toward that end. We hope that through this use case discussion, the scope and broad industry interest for service chaining becomes apparent, as well as the need to start formally working on the problem space. Ideally, from this BoF, there will be enough consensus to start planning for an NSC working group.

With the limited amount of time we have available we respectfully ask that you limit questions and comments during the BoF to the set of use cases presented. We have allocated 15 minutes at the end of the presentations for Q&A and with > 230 subscribers to our mailing list we expect a lively discussion!

Although this BoF is focused on the presentation of use cases and general service chaining requirements, there are several NSC-related drafts posted (http://trac.tools.ietf.org/bof/trac/). Given the time constraints these documents will not be discussed during the BoF but we encourage you to review them as they provide informative context about the subject of service chaining.

---

From: Linda Dunbar <[email-masked]>
Date: Sun, 21 Jul 2013 23:20:28 +0000

Jim, et al,

After reading all of the drafts posted in the NSC BoF website, I see three distinct problem spaces that are addressed by those drafts:

1.      Locating available Network service functions
"draft-boucadair-network-function-chaining" has very good description of this problem space.

It reminds me of Rserpool WG. "Rserpool" focused on supporting high availability and scalability of applications through the use of pools of servers, whereas "Locating Network Service Functions" will be on monitoring and building topology of available service functions (either on physical devices or virtual devices).

2.      Creating chronology of service functions based on user demand and network resource availability.

For any given network service function, there might be multiple service modules capable of doing the task. It can be challenging to build a service chain that maximizes the performance and minimizes the network resource used.

This categories reminds me of PCE. PCE is for computing optimal path, whereas this space is for selecting set of service modules for traffic to traverse through and identifying  specific points (or nodes) in the network for the selected traffic to be steered to the corresponding service modules.

3.      Methods along data path to enforce specific traffic going through their designated service functions.

There are several drafts proposing various methods to achieve this goal, such as l3vpn-service-chaining, metadata-header carried by IP or MPLS, etc.

I hope the BOF can be organized to associate use cases with their distinct problem space.

Linda Dunbar

From: [email-masked] [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Friday, July 19, 2013 12:30 PM
To: [email-masked]
Subject: [nsc] IETF 87 NSC BoF

Greetings,