Subject: [nsc] comments on draft-yong-gre-in-udp-encap-4-service-chaining-00.txt

From: Ron Parker <[email-masked]>
Date: Wed, 17 Jul 2013 15:37:04 +0000

Hi, Lucy.

I think the addition of the UDP entropy is a very valuable concept to better support ECMP, LAG, and RSS (within a multi-core network entity).

My question is what value is added by the GRE header?   As an alternative, have you considered a well-known NSH-in-UDP port instead of a well-known GRE-in-UDP port?

Thanks.

    Ron Parker
    Affirmed Networks

---

From: John E Drake <[email-masked]>
Date: Wed, 17 Jul 2013 15:41:19 +0000

Ron,

That was our original proposal.  It was shot down by the UDP police because it used too many of their precious ports.

Yours Irrespectively,

John

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ron Parker
Sent: Wednesday, July 17, 2013 8:37 AM
To: [email-masked]
Subject: [nsc] comments on draft-yong-gre-in-udp-encap-4-service-chaining-00.txt

Hi, Lucy.

Thanks.

    Ron Parker
    Affirmed Networks

---

From: Lucy yong <[email-masked]>
Date: Wed, 17 Jul 2013 15:43:08 +0000

Hi Ron,

As you see, gre header is used for encoding payload protocol type identification/demultiplexing. Without it, we have to burn UDP ports, i.e. destination ports, for each payload protocol that IP network may tunnel.

Thanks,
Lucy

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ron Parker
Sent: Wednesday, July 17, 2013 10:37 AM
To: [email-masked]
Subject: [nsc] comments on draft-yong-gre-in-udp-encap-4-service-chaining-00.txt

Hi, Lucy.

Thanks.

    Ron Parker
    Affirmed Networks