Subject: Re: [nsc] FW: New Version Notification for draft-liu-service-chaining-use-cases-01.txt

From: "Will Liu (Shucheng)" <[email-masked]>
Date: Fri, 16 Aug 2013 08:18:47 +0000

Hi Hu Jie,

Thanks for your comments. The points you’ve listed are non-trivial. Let me try to answer them:

1)      IMHO, the service nodes include those functions that operators are able and willing to connected to form services by service chains, such as NAT, DPI, Fire Wall, etc. We’ve mentioned some in our use case draft. If it’s necessary, I will invite our co-authors to add one use case to elaborate the use cases for service nodes together. We will be very glad if you can help us in providing detailed service node use cases.

2)      The deployment is also a very important thing for service chain. Now given that the final charter has not been decided yet, and as Adrian said, it was less clear to me that there is agreement about the layer in which service chaining has to be solved, so for this point, there might be several possibilities. One naïve use I can easily case is the service chain can be deployed at the where the BNG is deployed, between the metro and CR. I will try to add a figure to illustrate this later. If you have some other idea, please let me know.

Regards,
Shucheng LIU (Will)

From: 胡捷 [mailto:[email-masked]]
Sent: Friday, August 16, 2013 10:33 AM
To: [email-masked]; Will Liu (Shucheng)
Subject: RE: [nsc] FW: New Version Notification for draft-liu-service-chaining-use-cases-01.txt

Hi Will,

I read through your draft and believe that, overall, this is a very useful document, and I support most of use cases in it.

However, I think it would be great if you can add the following two in next version:

1) The detailed use cases for service node, e.g., what function are you going to be virtualized.
2) How is the service chain deployed in an operator's network?

Best regards,

Hu Jie

---

From: "Cao,Zhen" <[email-masked]>
Date: Mon, 19 Aug 2013 12:16:47 +0800

Hello Hujie and Will ,

two more cents regarding the discussion.

For 1), there are many good examples of service nodes (In additional
to Will's list, there are LB/VPN/ALG), but where they are virtualized
or overlay-ed are orthogonal to the use cases the draft would like to
describe.

For 2), using vswitch to deploy service chain is one vivid example

Best regards,
-czh/cmcc

On Fri, Aug 16, 2013 at 4:18 PM, Will Liu (Shucheng)
<[email-masked]> wrote:
> 1)      IMHO, the service nodes include those functions that operators are
> able and willing to connected to form services by service chains, such as
> NAT, DPI, Fire Wall, etc. We’ve mentioned some in our use case draft. If
> it’s necessary, I will invite our co-authors to add one use case to
> elaborate the use cases for service nodes together. We will be very glad if
> you can help us in providing detailed service node use cases.
>
> 2)      The deployment is also a very important thing for service chain. Now
> given that the final charter has not been decided yet, and as Adrian said,
> it was less clear to me that there is agreement about the layer in which
> service chaining has to be solved, so for this point, there might be several
> possibilities. One naïve use I can easily case is the service chain can be
> deployed at the where the BNG is deployed, between the metro and CR. I will
> try to add a figure to illustrate this later. If you have some other idea,
> please let me know.
>
>
>
> Regards,
>
> Shucheng LIU (Will)
>
>
>
> Subject: RE: [nsc] FW: New Version Notification for
> draft-liu-service-chaining-use-cases-01.txt
>
>
>
> Hi Will,
>
> I read through your draft and believe that, overall, this is a very useful
> document, and I support most of use cases in it.
>
>
>
> _______________________________________________
> nsc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nsc
>

---

From: "Will Liu (Shucheng)" <[email-masked]>
Date: Mon, 19 Aug 2013 07:02:09 +0000

Hi Jie, Zhen, and all,

Following(and the txt enclosed) is the figure I mentioned in my previous mail. Please let me know your opinion on it. Thanks.

               ------                                       ------
            //        \\  ********************           //        \\
 +----+    |            | * +---+            * +---+    |            |
 |CPE |--->+  Metro     +-->+BNG+>+-------+--->|CR +--->+ Internet   |
 +----+    |            | * +---+ |       ^  * +---+    |            |
            \\        //  *       v       |  *           \\        //
               ------     *      ++-------++ *              ------
                          *      | Service | *
                          *      | Chain   | *
                          *      +---------+ *
                          ********************

                    service chain deployment position
Regards,
Shucheng LIU (Will)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Cao,Zhen
> Sent: Monday, August 19, 2013 12:17 PM
> To: Will Liu (Shucheng)
> Cc: [email-masked]; 胡捷; [email-masked]
> Subject: Re: [nsc] FW: New Version Notification for