Subject: [nsc] More well defined Use Cases for NSC

From: Sean Yiu <[email-masked]>
Date: Thu, 22 Aug 2013 14:20:50 -0700

Hi  Jim and Thomas et al

Thanks much for moving NSC along. I do have some suggestions on the next steps - i.e.  is that towards the WG sessions (in Vancouver ?) , one main  focus could be documenting some well defined use cases - especially from the network operators'  point of view. Closest I found so far seems to be http://datatracker.ietf.org/doc/draft-liu-service-chaining-use-cases/?include_text=1 but it has a few examples only (at least at this point in time).  It would be helpful to have  more use cases from a larger set of network operators. I also suggest that in collecting and documenting these use cases, we be "strict" to ourselves to state the use cases in some level of detail and not jump into Architecture and even implementation details.

Thanks

Sean

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Mon, 26 Aug 2013 13:28:45 +0000

Hi Sean,

I think the problem with use cases is that there are so many of them and in a lot of cases will be specific to a given operators deployment choices. Trying to document them all serves little purpose other than informational imho.  Having said that we will have high level use cases in the problem statement draft. For more detailed use cases I think we will probably see a set of drafts that are relevant to specific deployment environments such as mobility, DC, etc, and I think that is the right approach.

From: Sean Yiu <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 22, 2013 5:20 PM
To: Microsoft Office User <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: More well defined Use Cases for NSC

Hi  Jim and Thomas et al

Thanks much for moving NSC along. I do have some suggestions on the next steps – i.e.  is that towards the WG sessions (in Vancouver ?) , one main  focus could be documenting some well defined use cases – especially from the network operators’  point of view. Closest I found so far seems to be http://datatracker.ietf.org/doc/draft-liu-service-chaining-use-cases/?include_text=1 but it has a few examples only (at least at this point in time).  It would be helpful to have  more use cases from a larger set of network operators. I also suggest that in collecting and documenting these use cases, we be “strict” to ourselves to state the use cases in some level of detail and not jump into Architecture and even implementation details.

Thanks

Sean