Subject: [nsc] NSC Working Group Charter Proposal

From: Andre Beliveau <[email-masked]>
Date: Thu, 5 Sep 2013 15:08:28 +0000

Hi Jim,

Some comments on Take Two of the charter:

In the paragraph:
The Network Service Chaining (NSC) working group focuses on new approaches to network service structuring, insertion, and deployment, providing a framework for the construction of services built using service function chains. The WG focuses on the necessary protocols for the creation of service chains, and the transmission of network and service-specific information from the network to service functions, and between service functions.

Could we be more generic and not limit to "creation" of service chains.  We could write the last sentence as "The WG focuses on the necessary protocols for management (e.g. create, delete, monitor) of service chains, and the transmission of network and service-specific information from the network to service functions, and between service functions."

I would also propose to be more specific when we write "focuses on new approaches", so it gives guidance for the solution.  Following the key points highlighted by operators in their presentations at IETF 87, I would be more specific and write "working group focuses on new and simpler approaches to...".  It's important that the outcome of the WG will result in implementations which will reduce the complexity to manage Service Chains.

Regarding the manageability, I'm quite happy to see specific deliverables as item 4).  I'd like it to be more specific, but we have not seen any solution proposals for managing Service Chains which would guide us in a more specific deliverable.

Regards,

André Béliveau, Ing.
Expert, Software and System Architecture
Ericsson Research, Packet Technologies
Tel.: +1 (514) 345 2708
Mobile: +1 (514) 502 9592  mailto:[email-masked]

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Thu, 5 Sep 2013 15:51:16 +0000

Thank you Andre for this input. I agree that the second sentence and the simplicity angle are appropriate changes and I have updated the charter accordingly.

From: Andre Beliveau <[email-masked]<mailto:[email-masked]>>
Date: Thursday, September 5, 2013 11:08 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [nsc] NSC Working Group Charter Proposal

Hi Jim,

In the paragraph:

Could we be more generic and not limit to “creation” of service chains.  We could write the last sentence as “The WG focuses on the necessary protocols for management (e.g. create, delete, monitor) of service chains, and the transmission of network and service-specific information from the network to service functions, and between service functions.”

I would also propose to be more specific when we write “focuses on new approaches”, so it gives guidance for the solution.  Following the key points highlighted by operators in their presentations at IETF 87, I would be more specific and write “working group focuses on new and simpler approaches to…”.  It’s important that the outcome of the WG will result in implementations which will reduce the complexity to manage Service Chains.

Regarding the manageability, I’m quite happy to see specific deliverables as item 4).  I’d like it to be more specific, but we have not seen any solution proposals for managing Service Chains which would guide us in a more specific deliverable.

Regards,

André Béliveau, Ing.