Subject: [nsc] Questions to "draft-boucadair-service-chaining-framework-00"

From: Linda Dunbar <[email-masked]>
Date: Mon, 16 Sep 2013 21:24:55 +0000

Mohamed, et al,

What does the first bullet in the Objective section mean?
Is it about the "forwarding planes" among "Service Functions"? or is it about creating a forwarding plane in the "underlying network?

Is the "differentiated packet forwarding" referring to the "underlying network"?

In Section 1.5, you stated that "SFs are handled as black boxes",
Is it intended for chaining together  existing Service Functions?
Does it mean that the Service Functions don't see the "Chain Marking information" (the Section 6 in draft-boucadair-chaining-design-analysis-00)?
Then, is it the underlying nodes that need to interpret the "Chain Marking Information"?

Thanks,
Linda Dunbar

---

From: <[email-masked]>
Date: Thu, 26 Sep 2013 09:46:34 +0200

Dear Linda,

Apologies for the delay to answer this message.

Please see inline.

Cheers,
Med

De : Linda Dunbar [mailto:[email-masked]]
Envoyé : lundi 16 septembre 2013 23:25
À : BOUCADAIR Mohamed IMT/OLN; Ron Parker; JACQUENET Christian IMT/OLN
Cc : [email-masked]
Objet : Questions to "draft-boucadair-service-chaining-framework-00"

Mohamed, et al,

What does the first bullet in the Objective section mean?
Is it about the "forwarding planes" among "Service Functions"? or is it about creating a forwarding plane in the "underlying network?
[Med] This means creating a forwarding path that will be service-inferred, i.e. a forwarding path that involves a set of SFs in a given order.

Is the "differentiated packet forwarding" referring to the "underlying network"?
[Med] it means differentiated packet forwarding within an SFC-enabled domain.

In Section 1.5, you stated that "SFs are handled as black boxes",
Is it intended for chaining together  existing Service Functions?
[Med] chaining-related features are not part of the technical characterization of each SF.
Does it mean that the Service Functions don't see the "Chain Marking information" (the Section 6 in draft-boucadair-chaining-design-analysis-00)?
[Med] This is something that need to be further clarified in the document: the marking information will need to be parsed and understood by the SF. We do not consider that part an inherent component of the technical characterization of an SF. This is an extension to "legacy" behavior.
Then, is it the underlying nodes that need to interpret the "Chain Marking Information"?
[Med] Only SF nodes interpret such information; other (legacy) nodes are not required to do so.

Thanks,
Linda Dunbar