Subject: Re: [nsc] New NSC WG Charter

From: Andre Beliveau <[email-masked]>
Date: Fri, 13 Sep 2013 15:18:18 +0000

Hi,

Here are the sentences where I would replace Service by Composite Service (or another agreed name) in the proposed charter:
---
Composite Services are typically implemented by the ordered combination of a number of service functions that may be implemented at different points within the network. Composite Services delivery is currently both a technical and organisational challenge that involves significant modification to the network configuration.
For a given Composite Service, the abstracted view of the required service functions and the order in which they are to be invoked is called a Service Function Chain (SFC). The Service Function Chaining (SFC) working group will develop new approaches to Composite Service delivery and deployment, by providing a framework for service function chaining and the necessary protocols or protocol extensions to convey the service path and for communication between nodes that implement service functions.
---

Regards,
André Béliveau, Ing.
Tel.: +1 (514) 345 2708
Mobile: +1 (514) 502 9592  mailto:[email-masked]

---

From: Ron Parker <[email-masked]>
Date: Fri, 13 Sep 2013 15:26:03 +0000

Andre,

That sounds good.

However, can we make it clearer that the complete chain may be the concatenation of multiple composite services?   It may be useful to add this additional layer to the hierarchy such that highest level service offerings (i.e., chains) could be described as {composite service A, composite service B} or {composite service A, composite service C, ...}.

Thanks.

   Ron

From: [email-masked] [mailto:[email-masked]] On Behalf Of Andre Beliveau
Sent: Friday, September 13, 2013 11:18 AM
To: [email-masked]
Subject: Re: [nsc] New NSC WG Charter

Hi,

Regards,
André Béliveau, Ing.
Tel.: +1 (514) 345 2708

---

From: Andre Beliveau <[email-masked]>
Date: Fri, 13 Sep 2013 15:37:27 +0000

Ron,
I would rather embed SF chains within themselves and talk about the "externally visible" service with a unique name.  But it is true that if we allow recursion, we should rather define Service Function Chains as an ordered list of Service Functions or existing Service Function Chains.

IMHO, I would think that using recursion is more an implementation issue.  If it becomes important for simplification to detail this recursion, we can do that later when we have sufficient design justification to include it in the standard.

/AB

From: Ron Parker [mailto:[email-masked]]
Sent: September-13-13 11:26 AM
To: Andre Beliveau; [email-masked]
Subject: RE: Re: [nsc] New NSC WG Charter

Andre,

That sounds good.

Thanks.

   Ron

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Andre Beliveau
Sent: Friday, September 13, 2013 11:18 AM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [nsc] New NSC WG Charter

Hi,

Regards,
André Béliveau, Ing.
Tel.: +1 (514) 345 2708

---

From: Ron Parker <[email-masked]>
Date: Fri, 13 Sep 2013 15:39:33 +0000

We could always say that service chains may be concatenated together.

   Ron

From: Andre Beliveau [mailto:[email-masked]]
Sent: Friday, September 13, 2013 11:37 AM
To: Ron Parker; [email-masked]
Subject: RE: Re: [nsc] New NSC WG Charter

Ron,

/AB

From: Ron Parker [mailto:[email-masked]]
Sent: September-13-13 11:26 AM
To: Andre Beliveau; [email-masked]<mailto:[email-masked]>
Subject: RE: Re: [nsc] New NSC WG Charter

Andre,

That sounds good.

Thanks.

   Ron

Hi,

Regards,
André Béliveau, Ing.
Tel.: +1 (514) 345 2708

---

From: Andre Beliveau <[email-masked]>
Date: Fri, 13 Sep 2013 15:47:37 +0000

Agree.  There are different ways to represent a hierarchy or composition.

From: Ron Parker [mailto:[email-masked]]
Sent: September-13-13 11:40 AM
To: Andre Beliveau; [email-masked]
Subject: RE: Re: [nsc] New NSC WG Charter

   Ron

From: Andre Beliveau [mailto:[email-masked]]
Sent: Friday, September 13, 2013 11:37 AM
To: Ron Parker; [email-masked]<mailto:[email-masked]>
Subject: RE: Re: [nsc] New NSC WG Charter

Ron,

/AB

Andre,

That sounds good.

Thanks.

   Ron

Hi,

Regards,
André Béliveau, Ing.
Tel.: +1 (514) 345 2708