Subject: [Nsis-imp] The length field in Common Header of ping message.

From: Bo Gao <[email-masked]>
Date: Mon, 03 Jul 2006 14:43:35 -0400

Hello,
I am doing my ping tool for my GIST now and just checked 
draft-juchem-nsis-ping-tool-02.txt and found that the length field in 
the common header is only 8 bits long. But at every hop we should add 24 
bytes (16bytes IP address and 8 bytes timestamp) to the ping message. Is 
n't it too short as it can allow maximum about 10 hops in the real world?

Have A Nice Day!

Best Regards,

Bo Gao,

_______________________________________________
NSIS-imp mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis-imp

---

From: "Xiaoming Fu" <[email-masked]>
Date: Mon, 03 Jul 2006 21:11:16 +0200

Hi 

Assume IP layer MTU = 1540 bytes, then a ping exchange can at least traverse 
1540/24/2 = 32 hops in one direction. 

I think this is usually enough?
Xiaoming
Bo Gao writes:
> draft-juchem-nsis-ping-tool-02.txt and found that the length field in the 
> common header is only 8 bits long. But at every hop we should add 24 bytes 
> (16bytes IP address and 8 bytes timestamp) to the ping message. Is n't it 
> too short as it can allow maximum about 10 hops in the real world? 
> 
> Have A Nice Day! 
> 
> Best Regards, 
> 
> Bo Gao, 
>