Subject: Re: [NSIS] Initial ID on Signalling Requirements

From: Scott Bradner <[email-masked]>
Date: Thu, 1 Nov 2001 09:32:39 -0500 (EST)

agree & thanks

----

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Thu, 1 Nov 2001 16:11:27 +0100

Hi Jukka

Comparing the problem statements presented in the NSIS BOF
during the 50th IETF meeting with the problem statement 
given in this preliminary charter, I have the impression 
that there is a mismatch.

I hope that this mismatch will be solved in the next version of the charter.

Best regards,
Georgios

-----Original Message-----
From: Jukka Manner [mailto:[email-masked]]
Sent: donderdag 1 november 2001 15:38
To: Scott Bradner
Cc: [email-masked]; [email-masked]
Subject: Re: [NSIS] Initial ID on Signalling Requirements

	Hi,

	I tried to say, that I could write specifically about the
"requirements", not about solutions, yet. I discussed with John about NSIS
and an actual problem statement, as we did in Seamoby, but he said the
problem was actually presented in the charter, and thus the requirements
were the next/first thing. So, that is what I am proposing to do before
the SLC meeting.

	Regards,

	Jukka

On Thu, 1 Nov 2001, Scott  Bradner wrote:

> please do get IDs in with ideas that you have but please do not be
> constrained by existing IDs - NSIS should be looking at
> signaling and not be limited to a particular type of signaling
> in a particular media
>
> note also that we are in the 'what is the problem' phase not 'here
> is a solution' phase - it is too eraly to be proposing specific technology
>
> Scott
>
> ------
>
> >From [email-masked]  Thu Nov  1 09:12:15 2001
> Date: Thu, 1 Nov 2001 16:14:11 +0200 (EET)
> From: Jukka Manner <[email-masked]>
> To: [email-masked]
> Subject: [NSIS] Initial ID on Signalling Requirements
> In-Reply-To: <[email-masked]>
> MIME-Version: 1.0
> Content-Type: TEXT/PLAIN; charset=US-ASCII
> Sender: [email-masked]
> Errors-To: [email-masked]
> X-Mailman-Version: 1.0
> Precedence: bulk
> List-Id: Next Steps in Signaling <nsis.ietf.org>
> X-BeenThere: [email-masked]
>
>
> 	Hi,
>
> 	I just remembered that the deadline for initial versions of IDs is
> in two weeks. The WG charter suggests an initial version of the signalling
> requirements to be ready in December, but would that before of after Salt
> Lake City? It might be a good idea to have it as a basis for the NSIS
> meeting in SLC, so it must be submitted in two weeks.
>
> 	As NSIS is not yet a WG, I suggest to create the first version of
> the requirements as an individual ID. I could take as basis
>
> 	- the NSIS BOF report (draft-bradner-nsis-bof-00.txt),
> 	- the MIP QoS document (draft-chaskar-mobileip-qos-01.txt), and
> 	- issues raised on the mailing list.
>
> 	Would that sound ok? John, Scott, any comments?
>
>
> 	Regards,
>
> 	Jukka
>
> --
>
> Jukka MJ Manner                  Voice:  +358+(0)9+191 44210
> Research Scientist               Fax:    +358+(0)9+191 44441
> Department of Computer Science   Mobile: +359+(0)50+320 3018
> University of Helsinki           E-mail: [email-masked]
> P.O. Box 26, FIN-00014           WWW:    www.cs.Helsinki.Fi/u/jmanner/
> UNIVERSITY OF HELSINKI, Finland  Office: B433
>                        "Believe in Angels"
>
>
>
> _______________________________________________
> nsis mailing list
> [email-masked]
> http://www1.ietf.org/mailman/listinfo/nsis
>

_______________________________________________
nsis mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/nsis

_______________________________________________
nsis mailing list
[email-masked]
http://www1.ietf.org/mailman/listinfo/nsis

---

From: Scott Bradner <[email-masked]>
Date: Fri, 2 Nov 2001 07:08:39 -0500 (EST)

> I look forward to the next round of the charter.  Any chance
> it'll be out today or will it be early next week?

yes

Scott

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Fri, 2 Nov 2001 17:16:57 +0100

Hi Jukka and John

I would very much like to contribute in writing the Initial ID 
on Signalling Requirements. 
Can we combine our efforts?

Best regards,
Georgios

---

From: [email-masked]
Date: Sat, 3 Nov 2001 13:41:02 +0200

Hi Georgios,

> on Signalling Requirements. Can we combine our efforts?

Right now, there is no official working group document,
because there is no working group yet.  I do encourage
you to write up your concerns in an Internet Draft.
Co-operating with others on the list is a great way
to gain concensus, however all IDs must be individual
submissions at this point.

John

---

From: [email-masked]
Date: Sat, 3 Nov 2001 13:41:15 +0200

Hi Georgios,

> that there is a mismatch.

It is important to note that the NSIS BOF at IETF 50, was
more-or-less open mic night.  The presenters were free
to discuss what they thought was of interest and importance.

John

---

From: [email-masked]
Date: Sat, 3 Nov 2001 13:41:03 +0200

Hi Jukka,

> 	Would that sound ok? John, Scott, any comments?

That sounds like a good way forward. I'm sure that there are
others on the list who would be happy to add their two cents
as well.

John

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Mon, 5 Nov 2001 11:43:37 +0100

Hi John

Thank you for your question!
Brian, thank you for giving some explanation on the QoS issues related
to wireless links. 

In this e-mail I will try to give a summary of the draft
               
http://search.ietf.org/internet-drafts/draft-westberg-rmd-cellular-issues-00.txt

First of all before giving this summary please let me mention 
that such requirements can be valid for any network that has to 
support a huge real-time  traffic (mixed with best effort traffic )
volume that is generated by a huge number of users. Such networks
can also be future IP core 
networks. Probably, the Diffserv QoS architecture 
will be used in such future IP core networks. However, I think 
that there are some open issues related to the use of the Diffserv QoS 
architecture in such networks. 

At the moment a wide spread belief is that when Diffserv is used, 
a pre-defined level of QoS can be guaranteed. This is done by 
static provisioning of resources at the interior Diffserv nodes, 
and also by setting traffic conditioning elements at the Difsserv 
edges.  This level of QoS can be guaranteed  in many situations, but 
there are no mechanisms defined in Diffserv to solve  severe congestion 
situations in interior nodes. Severe 
congestion can be considered as an undesirable state which 
may occur as a result of a route change or a link failure. 
Typically, routing algorithms are able to adapt and change 
their routing decisions to reflect changes in the topology 
and traffic volume.  In such situations the re-routed traffic 
will have to follow a new path.  Interior nodes located on 
this new path may become overloaded, since they suddenly 
might need to support more traffic than their capacity.  
Severe congestion situations will severely affect the 
overall performance of the traffic passing through such 
nodes.

As the provisioning and conditioning are static and very 
slow operations, severe congestion can not be solved while 
keeping the same level of QoS. Therefore, a dynamic QoS solution 
will be needed to solve these severe congestion situations.
We believe, similar to our problem statement (see below), 
that a dynamic, scalable, simple and fast QoS solution is 
needed in such IP core networks. This solution should be able
to solve severe congestion situations.

Now I would like to focus and give a summary of the 
"Resource Reservation Issues in Cellular Radio Access Networks".

What is a radio access network?

Usually, the boundaries of the radio access network are 
a collection of radio base stations and the gateways to 
the backbone of the cellular network, e.g., 
base station controller (BSC) or radio network 
controller (RNC). The radio access network has different 
characteristics when compared to traditional IP-networks.  
Typically, the wired transmission in such a network 
contains a relatively high volume of leased lines. 
The fact that radio base stations are spread over a 
wide geographical area and are in general situated 
at large distance from the backbone typically 
results in high cost for the transmission links. 
Therefore dimensioning of network resources using 
over-provisioning might be expensive. 
Also, the majority of the traffic transported on 
the wired transmission links used by the radio 
access network is radio frames. A radio frame is 
a short data segment coded/decoded and 
transmitted/received by the base station. 
These radio frames must be delivered on a unicast 
basis from RNC to base station and vice versa in a 
timely fashion with limited delay. Otherwise, 
the base station or RNC will discard them. Due to 
the time constraints on the delivery of radio frames 
the majority of the traffic can be considered to be 
real-time traffic. This means that the traffic is 
very sensitive to delays and delay variation (jitter). 
Also, for maximal utilization of radio spectrum, fast 
and frequent handover operations between radio channels 
and radio base stations are required. 
Furthermore, in current radio access networks, the RNC 
is capable of supporting the initiation and management 
of the resource reservations for both directions, 
i.e., bi-directional, both to and from the base station, 
simultaneously.
Therefore, a QoS solution deployed in the radio access network 
will have to be simple and fast in order to handle frequent 
mobility operations, i.e. due to soft and hard 
handovers, while avoiding degradation of the 
performance of the radio network. Moreover, 
since the total amount of flows for radio 
frame transport in the radio access network is very large, 
the resource management scheme has to be scalable and be able to solve 
severe congestion situations.

Best Regards,
Georgios

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: zaterdag 3 november 2001 12:41
To: [email-masked]; [email-masked]
Subject: RE: [NSIS] Initial ID on Signalling Requirements

Hi Georgios,

> I think that at least two more requirements drafts should be included 
> in this discussion, i.e.,:
> "Resource Reservation Issues in Cellular Radio Access Networks"
> located at:

Could you provide a quick summary on why these are appropriate
for NSIS?  I read them some time ago, and I have to refresh
my memory.  A short summary would be helpful for all.

Thanks,
John

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Mon, 5 Nov 2001 11:59:44 +0100

Hi John

[JL]  The presenters were free
to discuss what they thought was of interest and importance.

Yes, but I hope that the presenters views will be somehow included 
in the process of defining a new charter for this WG.

Best Regards,
Georgios

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Mon, 5 Nov 2001 12:01:33 +0100

Hi John

Yes, I definitely agree, I am also interested in this
procedure.

Best Regards,
Georgios

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: zaterdag 3 november 2001 12:41
To: [email-masked]; [email-masked]
Subject: RE: [NSIS] Initial ID on Signalling Requirements

Hi Jukka,

John

---

From: [email-masked]
Date: Mon, 5 Nov 2001 13:01:31 +0200

Hi Georgios,

> in the process of defining a new charter for this WG.

They have been.  Of course, if we tried to address all of the
concerns presented at the meeting, we'd be 'boiling the ocean.'

br,
John

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Mon, 5 Nov 2001 12:13:53 +0100

[GK] Yes, but I hope that the presenters views will be somehow included 
[GK] in the process of defining a new charter for this WG.

[JL] They have been.  Of course, if we tried to address all of the
[JL] concerns presented at the meeting, we'd be 'boiling the ocean.'

Does this mean that the remaining views will be handled by a future 
QOS Working Group (not NSIS)?

Best Regards,
Georgios

---

From: [email-masked]
Date: Mon, 5 Nov 2001 13:15:08 +0200

Hi Georgios,

> Yes, I definitely agree, I am also interested in this

As we don't have an approved charter, I cannot authorize
any workgroup drafts.  In the best IETF spirit, I suggest
you 'flock together' with some other folks on the list
and publish an individual draft.

br,
John

---

From: [email-masked]
Date: Mon, 5 Nov 2001 13:16:16 +0200

Hi Georgios,

> QOS Working Group (not NSIS)?

This I cannot say.  What I intend for NSIS is what is outlined
in the charter (see the deliverables).  There is always
the prospect of re-chartering the WG later.  

John

---

From: [email-masked]
Date: Mon, 5 Nov 2001 13:25:07 +0200

Hi Geogios,

A quick re-read of this document:

http://search.ietf.org/internet-drafts/draft-westberg-rmd-cellular-issues-00
.txt

Brings the first comments:

Sections 3 and 4 are probably not so important for NSIS, meaning that NSIS
is not specifically defining a protocol for cellular networks, therefore the
3GPP architecture isn't completely relevant.

Section 5 would be applicable (in an abbreviated format) for consideration
in the Requirements draft.

Parts Section 6 would be applicable (in an abbreviated format) for
consideration in the Analysis draft. 

I'll re-read it and give more direct comments.

best regards,
John

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Mon, 5 Nov 2001 12:32:59 +0100

Hi John

[JL] Sections 3 and 4 are probably not so important for NSIS, meaning that NSIS
[JL] is not specifically defining a protocol for cellular networks, therefore the
[JL] 3GPP architecture isn't completely relevant.

Agree!

[JL] Section 5 would be applicable (in an abbreviated format) 
[JL] for consideration in the Requirements draft.

Agree!

[JL] Parts Section 6 would be applicable (in an abbreviated format) for
[JL] consideration in the Analysis draft. 

Agree!

Best Regards,
Georgios