Subject: RE: [NSIS] Two kinds of requirements

From: "Loughney John (NRC/Helsinki)" <[email-masked]>
Date: Thu, 17 Jan 2002 14:54:05 +0200

Hi Cornelia,

> to my understanding the very idea of the modular / toolkit 
> approach is providing basic "MUST" functionality, but at the 
> same time _leaving open_ the possiblity of later adding "MAY" 
> functionality. 
> 
> This means we should try designing the protocol such that 
> later "MAY" functionality can be added in a modular fashion. 

Yes, I agree with you & Georgios, however, with respect to
the Requirements Document - I think we should only place
MUSTs in such a document.

John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Michael Thomas <[email-masked]>
Date: Thu, 17 Jan 2002 14:11:27 -0800 (PST)

> MUSTs in such a document.

   I think that Scott might have addressed this,
   but SHOULD's aren't necessarily an oxymoron in
   a requirements draft. The way I interpret that
   is that the design really, really ought to 
   implement the SHOULD requirement or have a very 
   good reason why it doesn't. MAY's are pretty
   much a waste, IMO.

	  Mike