Subject: RE: [NSIS] Two kinds of requirements

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Fri, 18 Jan 2002 10:14:56 +0100

Hi,

Actually I agree with the comment of Scott regarding the MUST feature.

Furthermore, I would like to emphasize that what I meant 
by modularity is exactly what David Partain mentioned in 
his last NSIS e-mail:
"There are environments where a
certain kind of feature make sense and is considered mandatory.
There are others where that same feature would be considered
a waste of memory and cpu cycles.  I think we need to get
away from the discussion about words being used to describe
this issue.  I believe the issue certainly exists, and it
would be best if what we are working on allows us to have
"domain-specific features" and the "everyone-has it features".
If we don't do this, then vendors are certain to invent
non-standard ways to have their "domain-specific features".
That wouldn't be good."

Best Regards,
Georgios

-----Original Message-----
From: Scott Bradner [mailto:[email-masked]]
Sent: donderdag 17 januari 2002 19:42
To: [email-masked];
[email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]
Subject: RE: [NSIS] Two kinds of requirements

> I don't see how you can make all the requirements MUST. 

I agree, but it is good to think hard about a feature that is not needed
in most cases - maybe it can be left out (and maybe it can not)

Scott

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Xiaoming Fu <[email-masked]>
Date: Fri, 18 Jan 2002 11:20:50 +0100

Hi,

I fully agree Georgios and David's comments on this issue. Since we have 
a consensus that the modularity is a necesity then a few SHOULDs(even MAYs)
will be brought up. In rfc1812 "Requirements for IP Version 4 Routers", 
for example,

(4.2.3.1 IP Broadcast Addresses)
   For historical reasons, there are a number of IP addresses (some
   standard and some not) which are used to indicate that an IP packet
   is an IP broadcast.  A router

   (1) MUST treat as IP broadcasts packets addressed to 255.255.255.255
        or { <Network-prefix>, -1 }.

   (2) SHOULD silently discard on receipt (i.e., do not even deliver to
        applications in the router) any packet addressed to 0.0.0.0 or {
        <Network-prefix>, 0 }.  If these packets are not silently
        discarded, they MUST be treated as IP broadcasts (see Section
        [5.3.5]).  There MAY be a configuration option to allow receipt
        of these packets.  This option SHOULD default to discarding
        them.
    ...

Also I would favor some "DISCUSSION" under some requirements like rfc1812
to record the reasoning of the final text.

Regards,
Xiaoming