Subject: RE: [NSIS] Two kinds of requirements

From: "Roy, Radhika R, ALASO" <[email-masked]>
Date: Wed, 16 Jan 2002 15:18:23 -0500

-----Original Message-----
From: Steven Berson [mailto:[email-masked]]
Sent: Wednesday, January 16, 2002 2:08 PM
To: Roy, Radhika R, ALASO
Cc: Michael Thomas; [email-masked];
[email-masked]; [email-masked]; [email-masked]
Subject: RE: [NSIS] Two kinds of requirements

On Wed, 16 Jan 2002, Roy, Radhika R, ALASO wrote:

> Hi, Mike:
> 
> Let me try.
> 
> For (a), RSVP has definitely some characteristics that can be used
> at the application layer on end-to-end basis. In fact, we have to
> look into RSVP, like SDPng, to examine all its features how we can
> exploit it for using in the application layer. We can then
> determine what we do when think that we need to develop a new QOS
> protocol.
> 
> However, it requires that RSVP needs to be used on end-to-end
> basis. If RSVP is used on end-to-end basis and if we all agree we
> do not need additional features (e.g., SDPng and/or others
> provide), it is definitely a good candidate to examine whether it
> meets all requirements.
> 
> What do we do when RSVP is not end-to-end? For example domain 1 =
> RSVP, domain 2 = DiffServ, and domain 3= RSVP. I guess that here
> it breaks down. One solution may be translation between RSVP and
> DiffServ. Then we loose the end-to-end picture.

I think this was adequately addressed in RFC 2998, ``A Framework for 
Integrated Services Operation over Diffserv Networks'' by Bernet, et 
al.

[RRR] It is a good point. If we look into RFC 2998, we will see that it will provide a good insight to develop our end-to-end application layer QOS (generic) signaling protocol. What we need to do to make it evolve in such a way that the end-to-end QOS signaling will be able satisfy any combinations of network layer QOS that has been implemented using RSVP, DiffServ, MPLS, and/or other means while testing RFC 2998's end-to-end scheme as one of the implementation schemes.

Regards,
Steve

> Hope this may help to answer your questions.
> 
> Radhika
> 
> -----Original Message-----
> From: Michael Thomas [mailto:[email-masked]]
> Sent: Wednesday, January 16, 2002 11:31 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: [NSIS] Two kinds of requirements
> 
> 
> 
> So, I'm really dumb here. Can somebody enumerate
> the *specific* things that are broken with RSVP?
> Before we run off designing new protocols, it
> would be nice to know a) what things the current
> protocols have problems with and b) whether the
> current protocols are fatally flawed in the face
> of those problems.
> 
> I know some in (a). I don't think they meet (b).
> 
> 	Mike
> 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Steven Berson <[email-masked]>
Date: Wed, 16 Jan 2002 12:58:52 -0800 (PST)

On Wed, 16 Jan 2002, Roy, Radhika R, ALASO wrote:

> [Steve] I think this was adequately addressed in RFC 2998, ``A
> Framework for Integrated Services Operation over Diffserv
> Networks'' by Bernet, et al.
> 
> [RRR] It is a good point. If we look into RFC 2998, we will see
> that it will provide a good insight to develop our end-to-end
> application layer QOS (generic) signaling protocol. What we need
> to do to make it evolve in such a way that the end-to-end QOS
> signaling will be able satisfy any combinations of network layer
> QOS that has been implemented using RSVP, DiffServ, MPLS, and/or
> other means while testing RFC 2998's end-to-end scheme as one of
> the implementation schemes.

[Steve] I think RFC 2998 (Intserv over diffserv) over provides a
specific solution to the problem of end-to-end qos in the presence of
diffserv networks.  I further propose that RFC 2998 is a good start
for dealing with (for example) MPLS or other sub-ip technologies.  I
would be interested in hearing opposing opinions and rationale.

Regards,
Steve