Subject: RE: [Seamoby] RE: [NSIS] Establishing QoS after handoff.

From: "Gary Kenward"<[email-masked]>
Date: Mon, 8 Apr 2002 17:34:26 -0400

Can anyone offer an explaining of how or why CT would add significantly 
to the already unreliable physics of handover? 

What failure modes for CT would be noticeable above the unavoidable 
rate of handover failures due the vagaries of wireless coverage and 
wireless link layer performance???? 

If CT fails, then the handover fails. It is that simple. If CT were 
to fail with every 2nd handover attempt, then there would be a problem. 
But, I cannot seriously see CT failing more then every one in a million 
handover attempts, or less. 

CT should not be attempted if there is an incompatibility between source 
and destination ARs. And, I HAD thought that it was the purpose of CAR 
to identify those incompatibilities and thus avoid doing CT when it is 
clear it would fail. How to mitigate those incompatibles is not a 
CT issue, it is a service adaptation issue, which can be resolved in 
a number of ways, some of which would imply signalled negotiation either 
between the ARs or between the ARs and the MN. 

Regards,
Gary 

> -----Original Message----- 
> From: Nakhjiri Madjid-MNAKHJI1 [mailto:[email-masked]] 
> Sent: April 5, 2002 16:58 
> To: 'Rajeev Koodli'; James Kempf 
> Cc: Kenward, Gary [WDLN2:AN10:EXCH]; [email-masked]; 
> [email-masked]; [email-masked] 
> Subject: RE: [Seamoby] RE: [NSIS] Establishing QoS after handoff. 
> 
> 
> Agreed. I don't think reliability in signaling, which by the way 
> neither CT requirements, nor nsis requirements are covering, has to 
> do with failure in QoS negotiation. I don't think you can count 
> the case, where the QoS information that CT has given the AR is not 
> applicable, as a CT failure. 
> 
> Madjid 
> 
> -----Original Message----- 
> From: Rajeev Koodli [mailto:[email-masked]] 
> Sent: Friday, April 05, 2002 12:03 PM 
> To: James Kempf 
> Cc: Gary Kenward; [email-masked]; [email-masked]; 
> [email-masked] 
> Subject: Re: [Seamoby] RE: [NSIS] Establishing QoS after handoff. 
> 
> 
> James Kempf wrote: 
> 
> > Rajeev, 
> > 
> > I agree, but there is still an issue of how the AR would 
> notify the MN 
> > if CT fails. Is this covered by CT or not? 
> > 
> 
*snip*
> _______________________________________________ 
> Seamoby mailing list 
> [email-masked] 
> https://www1.ietf.org/mailman/listinfo/seamoby 
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 08 Apr 2002 14:58:23 -0700

Hello Gary,

> to the already unreliable physics of handover?

Since I took physics in college, I can answer this.  It would not
add significantly to handover unreliability.

> wireless link layer performance????

Congestion at intermediate routing points comes to mind.
Just because two access points are both within range of a mobile node
does not mean that they are neighbors to each other.  They may even
be attached to completely different physical media.

> to fail with every 2nd handover attempt, then there would be a problem.

I quite disagree with this statement.  It depends on very many things.
For instance, we have to be able to run CT without CARD.  So, the
destination access router might not offer header compression at all,
for instance.  Thus, the handover would succeed, but the context transfer
(or, part of it) would fail. 

> handover attempts, or less.

Cool!  This could be good news.

> and destination ARs.

As noted above, I quite disagree with this statement.

>                       And, I HAD thought that it was the purpose of CAR
> clear it would fail.

But, we have to be allowed to do CT without ever running CARD.
For instance, we have reactive mode.

>                        How to mitigate those incompatibles is not a

Sometimes, the service cannot be adapted, and the feature context is
just plain lost, because the feature is unavailable.  Suppose, for example,
that the contexts transferred include header compression, QoS, security,
and other features.  Now suppose that _only_ the security context can be
transferred.  That's still better than nothing!  Maybe the QoS application
will have to terminate, or go into degraded mode, but the other applications
that need security will still be able to go on undisturbed.  Why not?

Regards,
Charlie P.

PS. I relucantly left NSIS on the CC: list, but shouldn't it be pruned?

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Phil Neumiller" <[email-masked]>
Date: Mon, 8 Apr 2002 21:09:17 -0400

----- Original Message -----
> Congestion at intermediate routing points comes to mind.

Yes, and SOME MANET protocols are sensitive to this.

> does not mean that they are neighbors to each other.

Aah, but maybe they want to be eh?  Then what?

> They may even

Yes, but lets say I walk into a room with a Microsoft X100B-35S 100 Mbps
wireless
interface and you have your Binford 8000 and we want to chat.  Should we not
be able
to take advantage of the local infrastructure?  Securely???