Subject: [NSIS] comments Issue (12) included in draft-ietf-nsis-req-01

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Mon, 22 Apr 2002 10:33:03 +0200

Hi Marcus

Please receive my comments on Issue (12) included in the 
NSIS WG draft: draft-ietf-nsis-req-01.txt

Comment on Issue (12):

>   12) (CLOSED) text replacing scalability reqs
>   "The nsis architecture should give the ability to constrain the load
>   (CPU load, memory space, signaling bandwidth consumption and
>   signaling intensity) on devices where it is needed. This can be
>   achieved by many different methods, for example message aggregation,
>   by ignoring signaling message, header compression or minimizing
>   functionality. The architecture may choose any of these methods as
>   long as the requirement is met."
>   Editor: added the above text, but did not remove scalability reqs

[GK] If the text will have to replace the scalability requirements,
[GK] then in my opinion it should be slightly modified by adding the words 
[GK] "and the number of reservation states". The text becomes then:

     "The nsis architecture should give the ability to constrain the load
     (CPU load, memory space, signaling bandwidth consumption and
      signaling intensity) and the number of reservation states on devices 
      where it is needed. This can be
      achieved by many different methods, for example message aggregation,
      by ignoring signaling message, header compression or minimizing
      functionality. The architecture may choose any of these methods as
      long as the requirement is met."
--------------

Best regards,
Georgios

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: [email-masked]
Date: Mon, 22 Apr 2002 16:37:09 +0300

Hi Georgios,

>       long as the requirement is met."

I think that your text goes beyond what we can document.  The NSIS 
'architecture' (I prefer) framework, cannot talk about header compression,
etc. - that is definately out of scope for NSIS.  

John

---

From: [email-masked]
Date: Mon, 22 Apr 2002 16:05:39 +0200

John, 

As the original author of the text I would like to comment: 

>> functionality. The architecture may choose any of these 
>> methods as long as the requirement is met."
(this was the original text)

> 'architecture' (I prefer) framework, cannot talk about header 
> compression, etc. - that is definately out of scope for NSIS.  

The text mearly tries to state that the "framework" should give the ability to constrain "load". Then it _examplifies_ this with three different methods. This is doen to give some clarity to the requirement. Whether or not the examples stay or not is not my major concern, you can choose. However sometimes examples are good. 

Anders

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Mon, 22 Apr 2002 16:42:26 +0200

Hi John 

My main comment was related to the addition of 
the words "number of reservation states" and that is 
within the scope of NSIS.

Regarding the header compression text; it was an example used by Anders.

Best Regards,
Georgios

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: maandag 22 april 2002 15:37
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [NSIS] comments Issue (12) included in
draft-ietf-nsis-req-01

Hi Georgios,

John

---

From: [email-masked]
Date: Tue, 23 Apr 2002 06:48:00 +0300

Hi,

> Regarding the header compression text; it was an example used 

OK, the complaint I had was this:

	The architecture may choose any of these methods as
	long as the requirement is met.

I'd change it to be:

	Systems may use some of the above methods to meet
	the requirement, but how this is done is outside the
	scope of this document.

John

---

From: "Georgios Karagiannis (ELN)" <[email-masked]>
Date: Tue, 23 Apr 2002 09:29:36 +0200

Hi John

I agree with your proposal!

Best regards,
Georgios

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: dinsdag 23 april 2002 5:48
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [NSIS] comments Issue (12) included in
draft-ietf-nsis-req-01

Hi,

I'd change it to be:

John