Subject: RE: [NSIS] On the definition of QoS flow and aggregate flow.

From: "Gary Kenward"<[email-masked]>
Date: Fri, 5 Apr 2002 10:39:08 -0500

Ok, first observation: clearly I am not alone in my mis-interpretation of 
what this priority means.

Second, I am confused as to why NSIS would be concerned with defining what
amounts to a class of service identifier. 

I concur with Djamel on the need for an identifier, but only with respect
to the type of identifies that have been discussed in so many other wgs:
as one of the defined value fields in a VTD data chunk carried by the
protocol.
Some values of this identifier may require standardization through IANA -
as well known services, but do these values have to be determined by NSIS?

Perhaps I am missing an important issue here with the semantics of a QoS 
control protocol, but given the scope of the requirements, I see NSIS as
being more of a container protocol then an SS7 or UNI protocol. This allows
NSIS to be used in a variety of network implementations.

Does anyone know of semantic/performance issues with this approach?

Gary

> -----Original Message-----
> From: DJamel H. Sadok [mailto:[email-masked]]
> Sent: April 4, 2002 06:46
> To: Shahrier, Sharif M.
> Cc: [email-masked]; Carlos Alberto Kamienski
> Subject: Re: [NSIS] On the definition of QoS flow and aggregate flow.
> 
> 
> 
> 
> > Having a single priority value would make it much easier to 
> quantify QoS to
> > define a flow, as opposed to a whole set of parameters like delay,
> > throughput, jitter ............
> >
> 
> I did not follow this thread and consequently I am not sure of what a
> priority in this context is, but it seems to me
> that it would mean some information that refers to a set of 
> QoS parameters
> for a given flow. So, why not consider  the use of well known
> services (WKS) and defining well known service ids (WKS-IDs) 
> as some class
> of a service specification with delay, bandwidth, etc.. 
> information and
> use a flow-id or a WKS-ID to refer to it. Of course there is 
> the problem
> of having these predefined for scalability. I am using the 
> term service
> here to refer to a class of flows with some common QoS 
> characteristics.
> The goal here is NOT to define services but to identify using these
> WKS-IDs some classes and build some templates for them that 
> some domains
> may aggree to use for end-to-end QoS.
> 
> So for example in the DSCP field one may have this WKS-ID 
> that represents an
> aggreagate flow class and which may locally be mapped
> to any QoS domain specific technology (IntServ, DiffServ, 
> over provisionning, ...)
> Their mapping depends on the local domain policies and its 
> QoS technology.
> 
> Flows may be aggregated at the domain for example if we have two flows
> that require delay values of 10ms and 5 ms, a domain may 
> aggregate both
> specifications and offer resources for the aggregate as long 
> as the delay
> is maintained bellow 5 ms. Of course considering this field, only a
> limited number of classes may be defined, so if we need to maintain
> information on individual flows and not simply on their 
> aggregates, for
> example to deal with those that may breach access policies or apply
> admission or other  control, then another field may be used to contain
> flow ids.
> 
> Djamel
> 
> > A flow aggregate can be defined as a set of flows, where 
> each flow has the
> > same QoS priority.
> >
> > Thus, a coarse grain, single QoS priority for "flow" 
> characterization can
> > help to readily gather flows with the same priority value 
> into a set to form
> > an aggregate flow set.
> >
> > Comments and feedback please.........
> >
> > Sharif.
> >
> >
> > _______________________________________________
> > nsis mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/nsis
> >
> 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
>

---

From: [email-masked]
Date: Mon, 8 Apr 2002 11:19:31 +0300

Hi Gary,

> NSIS to be used in a variety of network implementations. 

I am on the same page as you are with this.  We are not designing a solution
for a particular network or sevice.  To be successful, we need to work on
a general solution.

John

---

From: "Shahrier, Sharif M." <[email-masked]>
Date: Mon, 8 Apr 2002 15:06:19 -0400

I don't see how finding a "general solution" would not permit classifying
different QoS types. There had been some discussions that flow-ids and other
types of indentifiers were available for these purposes. However, I am not
able to find any RFCs that describes this. 

Sharif.

 -----Original Message-----
From: 	[email-masked] [mailto:[email-masked]] 
Sent:	Monday, April 08, 2002 4:20 AM
To:	[email-masked]
Cc:	[email-masked]
Subject:	RE: [NSIS] On the definition of QoS flow and aggregate flow.

Hi Gary,

John