Subject: RE: [NSIS] Establishing QoS after handoff.

From: [email-masked]
Date: Fri, 5 Apr 2002 01:54:23 -0500

Hi John:

Some comments below:

-----Original Message-----
From: Loughney John (NRC/Helsinki) 
Sent: Thursday, April 04, 2002 11:28 PM
To: Chaskar Hemant (NRC/Boston); [email-masked]
Subject: RE: [NSIS] Establishing QoS after handoff.

Hi all,

Just to follow on to Hemant's comment:

> There is currently a debate going on in Seamoby as to whether 
> this QoS negotiation be covered by NSIS or Seamoby (CAR 
> discovery protocol). 
> 
> IMHO it should be covered by CAR discovery and not NSIS. CAR 
> discovery is supposed to identify candidate access routers 
> for handoff and QoS is an important property for candidacy. 

CAR discovery may be used to select handoff targets with
correct QoS support / capabilities.  Context Transfer (CT)
can be used with the handoff procedure to ensure proper
QoS state gets transfered to the new access router.

[HC] I agree with this.

If there is anyone interested in this work, please let me
know.  The SeaMoby chairs asked me to see if NSIS can provide
them any information about QoS needs.

[HC] Yes, NSIS protocol must have provisions to *accept* session's QoS data (transferred by CT) from new AR during QoS  signalling. Still, IMHO target selection and CT aspects as such should be out of scope of NSIS.

thanks,
John

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Xiaoming Fu <[email-masked]>
Date: Fri, 05 Apr 2002 10:22:11 +0200

Hi Hemant, John,

Yes, I agree that target selection and CT aspects as such should be out of
scope of NSIS,
instead, task of SEAMOBY. 

However, following req-draft "exclusions" section 4.3.2:
   4.3.2. Specific mechanisms (APIs and so on) for interaction between
   transport/applications and the network layer are not considered,
   except to clarify the requirements on the negotiation capabilities
   and information semantics that would be needed of the signaling
   protocol. The same applies to application adaptation mechanisms.

and section 5.10.3 - Combination with Mobility management:
   Combining mobility and QoS signaling should be supported for
   economic signaling behavior (e.g., negotiation with the new access
   network: Mobile IP message to acquire new care-of address and query
   for QoS information could be combined, in order to preserve
   bandwidth and reduce latency).

I think NSIS should clarify the interaction of negotiation (via SEAMOBY or
other mechanisms) and QoS signaling though. If we simply exclude other
possibilities and only allow "QoS signaling after handoff", we may get a QoS
losing much beauty in mobility scenarios.

Cheers,
Xiaoming