Subject: RE: [NSIS] Any Router Alert Option influence on router performanc e?

From: Tschofenig Hannes <[email-masked]>
Date: Wed, 19 Nov 2003 21:14:55 +0100

hi ruediger, 

you might also want to take a look at:

 [IP-OPT] P. Pan, H. Schulzrinne, "PF_IPOPTION: A kernel extension for
   IP option packet processing", Technical Memorandum 10009669-02TM,
   Bell Labs, Lucent Technologies, Murray Hill, NJ, June 2000.

ping says in draft [draft-pan-nsis-rsvp-transport] :
"
This design (referring to [RFC2113]) is
   simple to implement and efficient to run. As shown from the
   experiments in [IP-OPT], IP option processing introduces very little
   overhead on a FreeBSD box with minor kernel changes.
"

[draft-pan-nsis-rsvp-transport] is also a nice-to-read document. ping also
provides details about the router alert option in his thesis.  

a separate issue which cedric raised at the last ietf was directed towards
the problem of filtering packets by routers/firewalls which do not
understand the router alert option. 
maybe someone can point us to literature. 

ciao
hannes

[draft-pan-nsis-rsvp-transport] P. Pan and H. Schulzrinne: "An Evaluation on
RSVP Transport Mechanism", <draft-pan-nsis-rsvp-transport-01.txt>,
(expired), Jan. 2003.

> -----Original Message-----
> From: Geib, Ruediger [mailto:[email-masked]]
> Sent: Wednesday, November 19, 2003 1:01 PM
> To: [email-masked]
> Subject: [NSIS] Any Router Alert Option influence on router 
> performance?
> 
> 
> Dear all,
> 
> should anybody of you be aware of measurements 
> comparing the influence of processing "router 
> alert option" packets on router processing as 
> compared to complete absence of these packets, 
> I'd appreciate information or a URL. The 
> background isn't to prevent such messages. I'm 
> interested in learning more about the level 
> (if any) where they start to hurt.
> 
> Regards, Rüdiger 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Geib, Ruediger" <[email-masked]>
Date: Thu, 20 Nov 2003 11:43:19 +0100

David, Michael, Hannes,

thanks for distributing information on the issue!

Regards, Rüdiger