Subject: RE: [NSIS] Feedback from the "mobility in NSIS" meeting

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 11 Nov 2003 16:24:49 -0000

Marcus,

All your questions are reasonable, and I would say come
into the category of "that's exactly what I would like
a consensus draft to answer".

Regardless of whether people want to use nsis protocols in
a "mobile environment" (whatever that means) or not, we
I think should have a broader expectation that the nsis
protocols will get used in ways we haven't thought of yet.
(That is, if they get used at all. If they don't, it doesn't
really matter what we do right now.)

Thinking about how we would attempt to use the protocols
in stressful environments is one way to avoid building 
restrictive assumptions into the protocol design, and
mobility etc. is a very good hothouse for doing this. I
don't actually expect significant extra functionality is
needed to handle any of these issues, certainly not in the
NTLP anyway; indeed, the analysis might be a method for
trimming down the set of possible designs (which we should
all be grateful for).

Exactly how this work should get managed, officially or
otherwise, is another question. But the situation we have
at the moment - where we have several drafts, which all have
to be read very closely to determine whether they are 
asking for roughly the same thing or completely different
things from the protocols - is not optimised for making 
best use of WG energy (or causing least confusion to the
protocol design work).

r.

> -----Original Message-----
> From: Marcus Brunner [mailto:[email-masked]]
> Sent: Monday, November 10, 2003 21:49
> To: [email-masked]
> Subject: Re: [NSIS] Feedback from the "mobility in NSIS" meeting
> 
> 
> 
> > Basic Issues
> > ------------
> >
> > - Differences between the general route change (not related 
> to mobility)
> >   and mobility-caused route change, when
> >   a) when IP addresses change (end host or next peer)
> >   b) when IP addresses do not change
> >
> 
> So what is the difference?
> 
> > - How to discover crossover router, when
> 
> First question: what do you need the crossover router for? What 
> functionality is special on the crossover router?
> 
> >   a) the cross-over router exists by the definition in 
> RSVP, that is, the
> > same       session is identified on a new interface
> >   b) the cross-over router does not exist in the previous 
> way, that is,
> > new       messages for an existing session arrive from a 
> new peer through
> > the old       interface
> >   c) other nodes than the cross-over router affect the signaling
> > (The cross-over router discovery is most important when the 
> mobile node
> > is receiver)
> >
> > - State update on the common path after handover
> >
> 
> I would assume this is NSLP dependent
> 
> > - Interactions with mobility protocols such as MIP and LMM protocols
> >
> 
> IMHO there is no interworking needed with MIP except that MIP 
> might want to 
> use NSIS.
> 
> [...]
> 
> > - Dependencies between the NTLP and NSLP and split of functionality
> > between    layers
> >
> 
> Can you an example where the split might be different when 
> looking into 
> mobile versus static networks.
> 
> > - Security issues: implications of the authorization model
> >
> 
> What is different in the mobility case.
> 
> > - Dead peer and dead cross-over router discovery
> >
> 
> again why do you need to discover these? I assume peer 
> maintance is part of 
> the NTLP anyway.
> 
> Marcus
> 
> --------------------------------------
> Dr. Marcus Brunner
> Network Laboratories
> NEC Europe Ltd.
> 
> E-Mail: [email-masked]
> WWW:    http://www.ccrle.nec.de/
> Phone: +49 (0) 6221 905 11 29
> Mobile: +49 (0) 163 275 17 43
> personal home page: http://www.brubers.org/marcus
> 
> 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Marcus Brunner <[email-masked]>
Date: Tue, 11 Nov 2003 13:27:36 -0600

> trimming down the set of possible designs (which we should

yes, sure, but I have too often heard the word "optimize" in the context of 
the mobility discussion.  The best optimization is IMO the make it simple 
and lean

> best use of WG energy (or causing least confusion to the

agreed, if it helps the WG to finalize the work I am in favour of a 
combined draft.