Subject: RE: [NSIS] Draft on NSIS Operation Over IP Tunnels

From: [email-masked]
Date: Sat, 30 Jul 2005 12:08:55 +0300

Hi Charles,

Thanks for the draft, I think this is quite a useful analysis.  As tunneling,
like multihoming, can be related to mobility, I wonder if the analysis could
go into the Mobility Applicability Statement document.  

After that, for the BOUND_FLOW_SESSION object, do you think that this would
be a general object for all NSLPs that might run over a tunnel?  One option
would be to add this to the existing NSLPs, or to write a very short document
registering this as a NSLP object in the NSIS IANA registry (when there is one).

What does the rest of the wg think?

thanks,
John

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> ext Charles Shen
> Sent: 14 July, 2005 07:45
> To: [email-masked]
> Subject: [NSIS] Draft on NSIS Operation Over IP Tunnels
> 
> 
> Dear all,
> 
> We've submitted a draft on "NSIS Operation Over IP Tunnels". 
> The abstract is
> as follows:
> 
>    In this draft we briefly review various IP Tunnelling 
> mechanisms and
>    discuss the main problems with signaling operation over IP tunnels.
>    We also summarize the existing RSVP operation over IP tunnels
>    mechanism.  Then we present the design details and case examples of
>    an NSIS operation over IP tunnels scheme.  QoS NSLP is 
> assumed as the
>    NSIS signaling application in our discussion.
> 
> The document is available at
> 
> http://www.ietf.org/internet-drafts/draft-shen-nsis-tunnel-00.txt
> 
> Any comments are greatly appreciated!
> 
> Best regards,
> 
> Charles 
> 
> 
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Charles Shen" <[email-masked]>
Date: Sun, 31 Jul 2005 12:31:46 -0400

Hi John,

> From: [email-masked] [mailto:[email-masked]] 
> Sent: Saturday, July 30, 2005 5:09 AM
> To: [email-masked]; [email-masked]
> Subject: RE: [NSIS] Draft on NSIS Operation Over IP Tunnels
> 
> 
> Hi Charles,
> 
> Thanks for the draft, I think this is quite a useful 
> analysis. 

Thank you very much.

> As tunneling, like multihoming, can be related to 
> mobility, I wonder if the analysis could go into the Mobility 
> Applicability Statement document.  
> 

Yes some analysis could go to the Mobility Applicability document since
mobility (e.g. Mobile IP) makes use of tunneling. It also seems to be true
that tunneling itself does not need to be tied with mobility. So I am not
sure whether the topic itself deserves a separate document. (Indeed RFC2746
RSVP over IP tunnel is a separate one). 

On the other hand, I am not sure whether the scope of the Mobility
Applicability Statement document would cover specific solutions. If the NSIS
operation over tunnel draft describes a specific solution (like RFC2746)
would it still be appropriate to be included in the Mobility Applicability
Statement document?   

The current version of the draft is intended to focus on more generic
aspects of NSIS tunneling, without explicit description of mobility. We are
also working on applying this general scheme in the NSIS mobility
environment, which I think is probably a good part of the Mobility
Applicability Statement document.     

> After that, for the BOUND_FLOW_SESSION object, do you think 
> that this would be a general object for all NSLPs that might 
> run over a tunnel?  One option would be to add this to the 
> existing NSLPs, or to write a very short document registering 
> this as a NSLP object in the NSIS IANA registry (when there is one).
> 

I tend to favor having a general intra-session binding object for all NSLPs.
In fact we might also have the same question for inter-session binding. 

Thanks.

Charles

> > From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of 
> > ext Charles Shen