Subject: [NSIS] GIMPS/GIST: Ordering of objects

From: "Christian Dickmann" <[email-masked]>
Date: Fri, 26 Aug 2005 14:13:57 +0200

Hi Robert, hi WG,

at the Interop we talked about the ordering of objects. The current draft
specifies, that the ordering
is fixed. The common feeling was, that there is no need for it to be fixed.
I just want to comment on this topic again. When I wanted to implement the
LooseEnd-ByPass, I 
came to the conclusion, that it should be mandatory to have the MRI as the
first object. When 
bypass should take place I do not want to parse the complete message to get
the MRM, instead,
I want to simply step into the message and read the MRM field at the fixed
position. 

So NSLP Data (we agreed here) and MRI (I do not remember if we agreed here)
should be at fixed
positions (end/front respectively). If we agree on those two, the
specification should really make the
complete ordering fixed in my opinion. But the statement about the ordering
should be moved IMHO.
Currently it is the last sentence in the initial text on TLVs (chapter 5.2.2
TLV Objects
"The ABNF given above fixes the order of objects within a message."). The
ABNF itself is given in 
chapter 5.1. I think the note should be moved to the beginning of chapter
5.1, as it is the possition
where the note applies. It in not so much about the TLV objects, but about
the messages and so 
to my mind, chapter 5.1 (named GIMPS Messages) is the right place to put the
note.

Christian Dickmann

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 30 Aug 2005 17:34:38 +0100

Hi Christian,

I'm personally happy with the idea of fixed ordering
(maybe more precisely, allowing receivers to assume
that the order is fixed). And the ABNF already matches
your recommendation to have the MRI first (although I
don't recall us analysing the question very much when
we decided that). 

I agree that a better place to say this would be at the
start of 5.1 and I've added this as an editorial issue,
http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-ntlp-issues/issue67

Maybe when it is a bit more prominent there will also
be some more technical argument on the subject as well...

Cheers,

Robert H.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Christian Dickmann
> Sent: 26 August 2005 13:14
> To: [email-masked]
> Subject: [NSIS] GIMPS/GIST: Ordering of objects
> 
> 
> Hi Robert, hi WG,
> 
> at the Interop we talked about the ordering of objects. The 
> current draft specifies, that the ordering is fixed. The 
> common feeling was, that there is no need for it to be fixed. 
> I just want to comment on this topic again. When I wanted to 
> implement the LooseEnd-ByPass, I 
> came to the conclusion, that it should be mandatory to have 
> the MRI as the first object. When 
> bypass should take place I do not want to parse the complete 
> message to get the MRM, instead, I want to simply step into 
> the message and read the MRM field at the fixed position. 
> 
> So NSLP Data (we agreed here) and MRI (I do not remember if 
> we agreed here) should be at fixed positions (end/front 
> respectively). If we agree on those two, the specification 
> should really make the complete ordering fixed in my opinion. 
> But the statement about the ordering should be moved IMHO. 
> Currently it is the last sentence in the initial text on TLVs 
> (chapter 5.2.2 TLV Objects "The ABNF given above fixes the 
> order of objects within a message."). The ABNF itself is given in 
> chapter 5.1. I think the note should be moved to the 
> beginning of chapter 5.1, as it is the possition where the 
> note applies. It in not so much about the TLV objects, but 
> about the messages and so 
> to my mind, chapter 5.1 (named GIMPS Messages) is the right 
> place to put the note.
> 
> Christian Dickmann
> 
> 
>