Subject: RE: [NSIS] GIST NAT traversal object

From: "Hancock, Robert" <[email-masked]>
Date: Fri, 19 Aug 2005 11:32:48 +0100

Roland,

well caught. #complete words after the length field
seems reasonable (so byte length will be 4*length + 2).

http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-ntlp-issues/issue65

r.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Roland Bless
> Sent: 19 August 2005 01:21
> To: [email-masked]
> Subject: [NSIS] GIST NAT traversal object
> 
> 
> Hi,
> 
> just a quick question related to sec. C.4.8:
>  Length of opaque NLI info.
> Is this specified in bytes or words?
> (I assume the latter, but a clear statement
> in the doc would be nice).
> 
> Regards,
>  Roland
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis
> 

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Christian Dickmann" <[email-masked]>
Date: Fri, 19 Aug 2005 12:39:13 +0200

Hi Robert,

as you told me, an implementation could write anything into that field. So
to my mind, the length should be specified in bytes and the block (length +
value) should be padded to words. (Which is similar to PeerIdentity in NLI)
One question remains: Where should padding be applied? after the length
field or after the NLI info?

Christian

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Hancock, Robert
> Sent: Friday, August 19, 2005 12:33 PM
> To: Roland Bless; [email-masked]
> Subject: RE: [NSIS] GIST NAT traversal object
> 
> Roland,
>