Subject: [NSIS] QoS NSLP 5.4.3 Response w/o RSN and RII

From: Roland Bless <[email-masked]>
Date: Fri, 12 Aug 2005 15:26:27 +0200

Hi,

Markus Ott, who currently implements the QoS NSLP,
asked himself what to do when he receives a RESPONSE
without RSN and RII. Section 5.4.3 (draft-qos-nslp-07)
describes only what
to do when either RSN or RII is present. But how should
a RESPONSE be processed if both are missing (which is
ok due to the current RESPONSE ABNF Spec)?

Another case when this may occur: when a RESERVE comes in but
has no RSN. In this case the node should/could respond
with a RESPONSE (Error Mandatory object missing). Technically
one can use the Source SII-Handle to send it back. But how long
is it forwarded along the path since no QNE can match this RESPONSE
to a REQUEST etc.? I guess it should not be forwarded, but there should
be a sentence stating that:
"On receipt of a RESPONSE message containing neither an RII nor AN RSN
object, the RESPONSE MUST NOT be forwarded further along the path."
Are there any cases that have different requirements?

Best regards,
 Roland & Markus

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Tseno Tsenov <[email-masked]>
Date: Fri, 12 Aug 2005 16:06:09 +0200

Hi,

A related issues that I faced in the work on the QoS-NSLP FSM:

Section 5.4.3./the last paragraph/ of QoS NSLP draft states:
"
On receipt of a RESPONSE message containing an RSN object, the QNE
MUST compare the RSN to that of the appropriate signaling session.
If the match succeeds then the ERROR_SPEC MUST be processed.  The
RESPONSE message MUST NOT be forwarded further along the path whether
or not the match succeeds.
"

In case a QNE receives RESERVE message without RII and it does not have enough resources to meet the QoS requested with the RESERVE message, it should send back a RESPONSE with the RSN(from the RESERVE) and an appropriate ERROR_SPEC. Following the above rules, this RESPONSE message must be stopped in the upstream neighbor QNE. Then, how is the unsuccessful reservation reported to the upstream QNEs and QNI?

greetings,
Tseno

Original Message:

Hi,

Best regards,
Roland & Markus