Subject: [NSIS] FW: nsis meeting minutes

From: [email-masked]
Date: Fri, 9 Dec 2005 20:49:46 +0200

Hi all,

Minutes are attached, send comments & corrections.

John
WEDNESDAY, November 9, 2005
0900-1130 Morning Session I
TSV     nsis      Next Steps in Signaling WG

Meeting Minute Taker:
 - Andrew McDonald
 - Andreas Pashalidis
 Compiled by Hannes Tschofenig

Agenda bashing - chair - 10 min
--------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-0.ppt

NATFW NSLP - Martin Stiemerling - 20 min
http://www.ietf.org/internet-drafts/draft-ietf-nsis-nslp-natfw-08.txt
---------------------------------------------------------------------

Slides are available at: 
http://www3.ietf.org/proceedings/05nov/slides/nsis-1.ppt

- Q: what if two ports need to open, eg. RTP? a problem with doing two
  is that you might not get subsequent numbers. If there is a more
  generic need, then this might me considered to be added.

“Notification storm” issue: 

John is in favour of “aggregated” notifies. 

Robert: how do you route this message? 

Martin: good question; next node may need to forward the notify depending on where things may be affected. 

Hannes: we need more time to study this issue.

Hannes & John: a lightweight version of the NATFW NSLP seems to be better, now that we don’t know yet what we are going to need with experience.

Martin: By February 06, we are likely to be ready for LC.

NATFW NSLP Implementation Status - Hannes Tschofenig - 5 min
------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-2.ppt

John: Will the source code be made available? 

Hannes hopes Xiaoming Fu will release the
code. (no date given)

Mobility Applicability Statement for NSIS - Sung-Hyuck Lee - 10 min
http://www.ietf.org/internet-drafts/draft-ietf-nsis-applicability-mobility-signaling-03.txt
--------------------------------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-3.ppt

- Hannes: with regard to MIP API, whether we could leverage some work
  from other WGs? Has someone looked at those? Eg. the PFKEY interface that was used in the context of MOBIKE? 

- No other comments

John: it is good if people can go and read the open issues and make comments.

GIST - Robert Hancock - 20 mins 
http://www.ietf.org/internet-drafts/draft-ietf-nsis-ntlp-08.txt
---------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-4.ppt

Robert presents what is going on in creating version 09 based on WGLC

Martin: “it is important to finish GIST; thus have it with basic TLS now, and add advanced TLS later”.

John: “the security area will look closely on how we use TLS; so enough information should be in GIST so that the security area is satisfied”.

Hannes: It is good to think now about extensibility and how to extend usage scenarios. I think we need more thinking about how to proceed best.

John: RFC 2026. maybe we should add some “MUST” with a “MAY” that would allow other usages of TLS

Hannes: “basic stuff works, but other mechanisms that are more suitable for certain deployments may need to exchange additional information”

Robert: “it is important to get the other uses of TLS. In reality it is important to get these in. 
Question is: do we want this as an extension or no?

Xiaoming: “the MAY approach seems useful to me; it does not hurt; then extensions can be done when they’re needed”

Henning: need to have a single place where the text talks about
timers, how to set them up, what are the issues, how to avoid network
synchronization, etc.

John: “about downgrading attacks: the security AD will spot this and point out problems, if there are any”. About internal timer operation and setting

Henning: “this is a problem that arises in other protocols. It seems reasonable, to have a paragraph somewhere because this stuff is really useful for implementers. There is a first order concern, e.g. you don’t want to wait until the last millisecond before you refresh.”

Robert: “will add text”.

John: “there are a number of GIST implementation under GPL etc. there is therefore running code available for people who would like to experiment with it…”

Analysis of Options for Securing GIST - Hannes Tschofenig
http://www.ietf.org/internet-drafts/draft-tschofenig-nsis-gist-security-00.txt
------------------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-5.ppt

John: “this is future oriented scenarios; good to get feedback from deployers; do any of these that Hannes listen are relevant to people who want to deploy this stuff?”

Hannes: “it might be good to have a “story” about how to integrate other security mechanisms within GIST”

Path type support for NSIS signaling - Takako Sanda - 15 min
http://www.ietf.org/internet-drafts/draft-sanda-nsis-path-type-03.txt
---------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-6.ppt

No comments from the audience

John: “we need feedback to see if this is needed in NSIS”

NSIS Flow ID and packet classification Issues - Cheng Hong - 15 min
http://www.ietf.org/internet-drafts/draft-cheng-nsis-flowid-issues-02.txt
-------------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-7.ppt

“all information is still derived from the MRI”.

John: “some of this is going to be discussed tomorrow. Hot topic with respect to QoS NSLP”.

Xiaoming?: “q1: idea is to classify anything that is not in the MRI. Where you specify the needed object? Q2: “is this really needed right now? We can always add new objects in the future, when there is real need”.

Cheng: we are not going to define anything. We think that it is needed now because in QoS you want to signal port ranges.

Robert: “if you have a classifier with multiple addresses, how would you route this to? (if you have multiple destination addresses). Another q about port ranges: how common is it to carry identical signaling data over multiple ports?”

Martin: “I have problems with saying to put something in the NSLP layer that replaces something important. Is this the same signaling flow you are signaling for? You can extend the MRI, but not completely replace it…” 

Cheng: “signaling is still based on MRI. There are some cases that may result in a different MRI; example: tunneling case. There are some real use cases for multiple ports”

GIST over SCTP - Xiaoming Fu - 5 min
http://www.ietf.org/internet-drafts/draft-fu-nsis-ntlp-sctp-00.txt
--------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-8.ppt

Xiaoming mentions that performance tests regarding the Linux SCTP version do not offer
the best performance. Xiaoming thinks that the SCTP implemention could be improved. 

John: “the linux SCTP has no optimization in it.”

John: “how much does this affect the current GIST?”

Robert: “when this came out, I said “this draft is really short”—which is a good thing. I think this should be done separately.”

John: “may it is better to move with this forward separately. This is likely to become WG item, but first let’s have AD review for the base GIST…”

NSIS Operation Over IP Tunnels - Henning Schulzrinne - 10 min	
http://www.ietf.org/internet-drafts/draft-shen-nsis-tunnel-01.txt 
----------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-9.ppt

Robert: tunnel needs to do NSLP-related processing, right? It seems this
is above GIST

Martin: might not be needed with the NAT/FW

Elwyn Davis: probably we don't care of it.

Robert: Metering should think about this?

The room showed support for this.

John will make this a provisional WG item, later
(yet, the proposed extension to the BOUND_SESSION_ID object in QoS
NSLP will be accepted)

AAA support for QoS signaling - Hannes Tschofenig - 10 min
http://www.ietf.org/internet-drafts/draft-alfano-aaa-qosprot-05.txt
http://www.ietf.org/internet-drafts/draft-tschofenig-radext-qos-02.txt  
----------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-10.ppt

Hannes mentioned the previous dependency on the usage of accounting messages. 
Based on comments this dependency was relaxed. 
       
John mentions that the draft needs to be very flexible to support the full range 
of usage scenarios. 

Martin: would NAT/FW need this, too? 

Metering NSLP - Jurgen Quittek- 10 min
http://www.ietf.org/internet-drafts/draft-fessi-nsis-m-nslp-framework-02.txt
http://www.ietf.org/internet-drafts/draft-dressler-nsis-metering-nslp-03.txt
----------------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-11.ppt

John: IPFIX and PSAMP: how much are they looking forward to this?

Juergen: don't know, yet

Design Options of NSIS Diagnostics NSLP - Xiaoming Fu - 10 min
http://user.informatik.uni-goettingen.de/~fu/nsis/diagnostics/draft-fu-nsis-diagnostics-nslp-00.txt
---------------------------------------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-12.ppt

Robert: is this network management (ie. reading MIBs) or diagnostics? how is this different from network management with, e.g. SNMP and network management tools

John: “I am not sure if I want GIST/NSLP to become “yet another network management tool”.

Hannes: this is fine line, need to think how far you would like to go
  in this, some scenarios could feel more like network management. one of the question is about how far you want to go.

Elwyn Davis: motivation to go for complicated functions was the need to
find nodes involved, then you can read MIBs to find out more information...

Xiaoming: “one of the options is to define a MIB for GIST and the NSLPs.”

Robert: “you have to decide on which NSLP ID you sent the list of supported NSLP IDs.”

Xiaoming: “this would run on the GIST layer, however, GIST does not support end-to-end semantics”.

Robert: “… it seems this will be a new NSLP with a new NSLP ID.”

John: “people probably have not read it; once they do, comment on the mailing list.”

THURSDAY, November 10, 2005
1510-1610 Afternoon Session II
TSV     nsis      Next Steps in Signaling WG

QoS-NSLP - Jukka Manner - 15 min
http://www.ietf.org/internet-drafts/draft-ietf-nsis-qos-nslp-08.txt
-------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-13.ppt

Regarding the policy data object Hannes mentions the difficulty describing the interaction 
between the involved protocols in all scenarios. He worked on a document that will be published
soon. 

John: does it makes sense to hold up this document?

Jukka: I propose what the RSVP spec says. Policy object can be defined in new draft.

John: is this good or bad?

Hannes: usage of the token is fine. On the lower layer we have the information about authenticated identities… there is something missing, I think however it should not stop the progress of this document. It has to do with the authentication of the qos request to a third party.

John: I suggest then we do what rsvp does and close this issue.

Robert about packet classifiers: I would like one classifier across NSLPs. I don’t think that you need anything more.

Jukka’s proposal: do nothing for the time being.

QSPEC I-D - Jerry Ash - 10 min
http://www.ietf.org/internet-drafts/draft-ietf-nsis-qspec-07.txt
----------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-14.ppt

no comments

Y.1541-QOSM I-D - Jerry Ash - 5 min
http://ietf.org/internet-drafts/draft-ietf-nsis-y1541-qosm-00.txt
-----------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-15.ppt

no comments

User Application-to-User Plane Vertical Interface - Jerry Ash - 5 min
http://ietf.org/internet-drafts/draft-ash-nsis-vertical-interface-01.txt
------------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-16.ppt

Also presents user applcaition to user plane vertical interface

Proposal to become WG document.

Taylor: is this what other people would classify as the Gq interface?

Hannes: that’s an interesting question.

Hannes: it should not become a WG item; if it does, I totally misunderstood the document. 

John encourages people to read the draft again to make sure everyone agrees about what the purpose of the document is.

RMD-QOSM - Attila Bader - 10 min
http://www.ietf.org/internet-drafts/draft-ietf-nsis-rmd-04.txt
--------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-17.ppt

no comments

Attila mentions that the document can go into last call early next year. 

3GPP-QOSM - 10 min
http://www.ietf.org/internet-drafts/draft-jeong-nsis-3gpp-qosm-02.txt
---------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-18.ppt

no comments

John: what about the “other wireless networks”? maybe we can have stuff (parameters) that relates to those in a separate document.

John: comment from paris: gsma has taken over some responsibility for mapping qos parameters to diffserv stuff. 

John: is 3gpp is doing anything with this at the moment.

Speaker: interworking is an issue. It is interesting to nsis people. 3gpp are waiting for nsis progress.

A QoS Model for Signaling IntServ Controlled-Load Service - X. Fu - 5 min
http://www.ietf.org/internet-drafts/draft-kappler-nsis-qosmodel-controlledload-03 
---------------------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-19.ppt

no comments

NAT traversal for GIST
http://tools.ietf.org/wg/nsis/draft-pashalidis-nsis-gimps-nattraversal-01.txt
-----------------------------------------------------------------------------

Slides are available at:
http://www3.ietf.org/proceedings/05nov/slides/nsis-20.ppt

Robert: It would be good to evaluate how MIDCOM protocols (STUN, etc) relate to the approach, and also what sort of policy decisions are involved when NATs allocate NAT bindings for data traffic.

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Ash, Gerald R \(Jerry\), ALABS" <[email-masked]>
Date: Mon, 12 Dec 2005 07:22:16 -0600

John,

> > Minutes show no comments on the following draft: Y.1541-QOSM I-D -
> > Jerry Ash
> > - 5 min
> > "no comments"

> At least I don't remember making any comments to this draft at the
> meeting.

You're right, there were no comments.  There was a brief discussion that
the I-D should go to WGLC after the QoS/NSLP & QSPEC WGLC.

Jerry

---

From: "Roy, Radhika R." <[email-masked]>
Date: Mon, 12 Dec 2005 09:45:18 -0500

John:

OK, let us now discuss about the following comments. Kindly help us as to
resolve the following:

1.      This draft is INCOMPLETE with respect to extensions of QOSM
parameters for using Y.1541. For example, some extensions of QOSM parameters
for Y.1541 have been done in the QOSM draft and some extensions of QOSM
parameters have been done in this (Y.1541-QOSM I-D) draft. Why is it so?

2.      It is inconsistent that the generalized QOSM draft contains some
INCOMPLETE extensions for Y.1541-specific draft. Why is it so?

3.      Why does this draft (Y.1541-QOSM I-D) not contain all
Y.1541-specific extensions of QOSM parameters and make it complete per item
1? Is there any reason for not doing so?

Best regards,

Radhika

-----Original Message-----
From: [email-masked] [mailto:[email-masked]
<mailto:[email-masked]> ]
Sent: Monday, December 12, 2005 8:16 AM
To: Roy, Radhika R.
Cc: [email-masked]; [email-masked]
Subject: RE: [NSIS] FW: nsis meeting minutes

Radhika,

>Hi, John and all:

Jerry Ash

>http://ietf.org/internet-drafts/draft-ietf-nsis-y1541-qosm-00.txt
<http://ietf.org/internet-drafts/draft-ietf-nsis-y1541-qosm-00.txt> 

meeting.

John