Subject: [NSIS] Problem in QoSNSLP/NSISNTLP draft

From: David Palma <[email-masked]>
Date: Fri, 10 Feb 2006 16:10:23 +0000

Hi all,

I'm from the University of Coimbra and I'm currently implementing the
QoS-NSLP.

I started the tests between the QoS-NSLP and GIST but I found a problem.

When creating the Packet Classifier, as described on section 5.1.3.5 of the
draft (draft-ietf-nsis-qos-nslp-08), it's assumed that we should get from
the MRI the following flags:

      X - Source Address and Prefix
      Y - Destination Address and Prefix
      P - Protocol
      T - Traffic Class
      F - Flow Label
      S - SPI
      A - Source Port
      B - Destination Port

Cross checking the MRI object format of the GIST draft in section A.3.1
(draft-ietf-nsis-ntlp-08) the only existing flags are:

   P - P=1 means that IP Protocol should be interpreted
   T - T=1 means that DS-Field should be interpreted; see [4] and [18]
   F - F=1 means that flow Label is present and should be interpreted
   S - S=1 means that SPI is present and should be interpreted; see [10]
   A/B - Source/Destination Port (see below)
   D - Direction of message relative to flow

The Traffic Class field doesn't even exist! However in further searches I
found that in an earlier version of GIMPS, like version 6, there was a
Traffic Class field.

To resume my question is:

 - Where should I get the X, Y and T flag since they are not part of the MRI
object has it is supposed to be in the GIST MRI?

Regards,

David Palma

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Robert Hancock" <[email-masked]>
Date: Sun, 12 Feb 2006 11:37:05 -0000

hi david,

you are right that there is no traffic class carried in the GIST MRI.
however, the 6-bit DS-Field is there instead. the references are to rfc2474
and rfc3260 which discuss the replacent of the 'traffic class' terminology
with 'ds-field' terminology.

i don't know which document should fix this mainly terminological
inconsistency; however, the fact that the 'traffic class' terminology had
been replaced was pointed out to me by one of the QoS-NSLP authors :-)

cheers,

r.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of David Palma
> Sent: 10 February 2006 16:10
> To: [email-masked]
> Subject: [NSIS] Problem in QoSNSLP/NSISNTLP draft
> 
> 
> Hi all,
> 
> I'm from the University of Coimbra and I'm currently 
> implementing the QoS-NSLP.
> 
> When creating the Packet Classifier, as described on section 
> 5.1.3.5 of the draft (draft-ietf-nsis-qos-nslp-08), it's 
> assumed that we should get from the MRI the following flags:
> 
> The Traffic Class field doesn't even exist! However in 
> further searches I found that in an earlier version of GIMPS, 
> like version 6, there was a Traffic Class field.
> 
>  - Where should I get the X, Y and T flag since they are not 
> part of the MRI object has it is supposed to be in the GIST MRI?
> 
> Regards,
> 
> David Palma
> 
>