Subject: [NSIS] Section 3 of Mobility Applicability Draft

From: "Shivanajay Marwaha" <[email-masked]>
Date: Thu, 16 Feb 2006 19:59:14 +0800

Dear Sung-Hyuck, Seong-Ho, Mobility Applicabilty Draft Authors and other
NSIS WG members, 
 
Some comments/suggestions on section 3 in the NSIS mobility
applicability draft. 
 
Suggestion 1:- 
 
Following three sub-topics are not adequately covered in the main body
and some elaboration regarding the problem should be provided or it
should be in the open-issue list. 
 
(i) Sub-section 3.1 (11):- "Key exchange:- When a handover happens,
nodes
on the new path must be able to verify the signaling messages of the
MN, and vice versa.  " 
(ii) Sub-section 3.2.3 (1):- "Update of firewall rules and NAT bindings"

(iii) Sub-section 3.2.3  (2) "Re-use of NAT/FW-NSLP's old state" 
 
-----------------------------------------------------
 
Suggestion 2:- 
 
Current Text -  In Section 3.1 (3) -> " For example, Mobile IP may use
the routing
headers to define explicit routes, which diverts the traffic from an
expected path."
 
Comment/Suggestion - Kindly elaborate how this is done ->  MIP does not
require special
support at the intermediate routers. Any address change or
tunnelling, is done at the MIP supported nodes for eg. Home Agent or
the MN. So we would like to seek clarfication on how MIP affects
explicit routes?
 
-----------------------------------------------------
 
Suggestion 3:- 
 
Section 3.1  (6) Upstream State Update vs. Downstream State
Update:- 
 
Current Text -  " Since the upstream and downstream paths are likely not
to be the 
same, the upstream and downstream CRNs may not coincide, either.
Therefore, the State Update needs to be handled independently for  
the upstream and the downstream, including the discovery of  upstream
and downstream CRNs."
 
Comment/Suggestion - Does the above "upstream and downstream" flow refer
to data or
signalling? As such in path coupled signalling, there shouldn't be
any difference between upstream and downstream paths. So, if it is
directly addressed there may be an issue, if it is hop-hop address,
there may not be any issue as they should follow the same path.
 
-------------------------------------------------------
 
Suggestion 4:- 
 
Following 3 sub-topics do not seem to be problems, rather they seem
more like requirements:-
 
(i) Sub-section 3.1 (10) "Identification of the crossover node" - seems
to be a requirement derived from the previous point (9).
(ii) Sub-section 3.2.1.  (1) "Interfaces between Mobile IP and NSIS
protocols"
(iii) Sub-section 3.2.1 (2)  "Localized State Update"
 
Regards,
Shivanajay Marwaha
(On Behalf of Takako Sanda, Toyoki Ue and Cheng Hong)

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Sung-Hyuck Lee <[email-masked]>
Date: Tue, 21 Feb 2006 11:49:27 +0900

Dear Shivanajay,

Please refer to my comments in line.

Sung-Hyuck

----- Original Message ----- 
From: "Shivanajay Marwaha" <[email-masked]>
To: "Seong-Ho Jeong" <[email-masked]>; "Sung-Hyuck Lee" <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, February 16, 2006 8:59 PM
Subject: Section 3 of Mobility Applicability Draft

> (iii) Sub-section 3.2.3  (2) "Re-use of NAT/FW-NSLP's old state" 

[SHL] Could you let me know why those three items are not proper in more 
detail? I guess "key exchange"-related issues need to further be described in 
Section 6.

[SHL] As you know, Mobile IPv6 has a few specification different from 
Mobile IPv4. For example, Mobile IPv4 just routes packets to mobile nodes 
from CN via tunneling, but Mobile IPv6 can routes packets to mobile nodes 
from CN via both tunneling and source routing (using IPv6 routing header). 

> Update:- sp

[SHL] This text describes the direction of NSIS signaling. The route of NSIS 
signaling initiated from sender may be different that of NSIS signaling 
initiated from receiver. This is also similar to the case of bidirectional 
reservation.

[SHL] The authors of the mobility draft have tried to address issues that
need to be considered in interaction with NSIS protocols and mobile IP.
The issues listed in Section 3. Is there any detailed comment/suggestion 
to appropriately place three items above?

---

From: Takako Sanda <[email-masked]>
Date: Tue, 21 Feb 2006 12:33:52 +0900

Dear Sung-Hyuck,

> initiated from receiver. This is also similar to the case of bidirectional 

We need to clarify the terms "upstream" and "downstream" for signaling.

In the GIST draft
(http://www.ietf.org/internet-drafts/draft-ietf-nsis-ntlp-09.txt), the
terms are defined as:
  Downstream: In the same direction as the data flow.
  Upstream: In the opposite direction to the data flow.
But in the Applicability draft, these terms seem to be used as:
  Downstream: Signaling (or data) from CN to MN
  Upstream: Signaling (or data) from MN to CN
This difference makes confusion.
I think the terminologies should be unified in NSIS WG drafts.

BR,
Takako

---

From: Sung-Hyuck Lee <[email-masked]>
Date: Tue, 28 Feb 2006 17:25:00 +0900

Hi Takako,

Thank you for your comment.
The authors of the mobility draft will refer to your comment.
I'm reviewing the mobility draft based on your comment again.

Warm regards,

Sung-Hyuck