Subject: RE: IANA Considerations for QoS workAW: [NSIS] RE: QOSM IANA Status /NSIS Extensibility Doc on QOSMs

From: "Hancock, Robert" <[email-masked]>
Date: Tue, 7 Mar 2006 13:50:38 -0000

hi,

> -----Original Message-----
> From: Roland Bless [mailto:[email-masked]] 
> Sent: 07 March 2006 12:29
> To: Hancock, Robert
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]
> Subject: Re: IANA Considerations for QoS workAW: [NSIS] RE: 
> QOSM IANA Status /NSIS Extensibility Doc on QOSMs
> 
> 
> Hi Robert,
> 
> > However, GIST creates 2 registries (NSLPID and MRMID) which are
> > referred to by all NSLPs. In addition, AFAIK the NSLP object type
> > registry is shared between all NSLPs, but GIST doesn't 
> create it (its
> > object types are its own), so some other mechanism is needed for
> > that.
> 
> Does it really make sense to have a shared NSLP object type registry?
> Do we have common objects? Any advantages compared to NSLP specific
> types?

it's an old discussion; see for example the thread starting here
http://www1.ietf.org/mail-archive/web/nsis/current/msg03990.html
(2004, how time flies...)

i don't know whether it's possible or desirable to reopen it.

> 
> > The above implies to me that a single NSIS registry is more 
> sensible.
> 
> Sure, NSLPID and MRMID are related to NSLPs because they are used
> at the interface between GIST and NSLPs. However, one could also
> assign them to a GIST related registry.
> Moreover, if we decide that NSLP object type IDs are not shared
> between all NSLPs, I don't see a compelling reason for a single NSIS
> registry.

the object type is the major issue rather than the other two, i agree.

r.

> Regards,
>  Roland

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: <[email-masked]>
Date: Tue, 7 Mar 2006 16:09:35 +0200

That is my memory as well, so I think we need to assume a single
registry until proven otherwise.

John 

>From: ext Hancock, Robert [mailto:[email-masked]] 
>Sent: 07 March, 2006 15:51
>To: Roland Bless
>Cc: Loughney John (Nokia-NRC/Helsinki); 
>[email-masked]; [email-masked]; 
>[email-masked]; [email-masked]; [email-masked]
>Subject: RE: IANA Considerations for QoS workAW: [NSIS] RE: 
>it's an old discussion; see for example the thread starting 
>here http://www1.ietf.org/mail-archive/web/nsis/current/msg03990.html
>> Sure, NSLPID and MRMID are related to NSLPs because they are used at 
>> the interface between GIST and NSLPs. However, one could also assign 
>> them to a GIST related registry.

---

From: Roland Bless <[email-masked]>
Date: Tue, 07 Mar 2006 17:27:14 +0100

Hi Robert,

> (2004, how time flies...)

Thanks a lot for this pointer...I could remember only very vaguely
a related discussion and wasn't able to locate it
so quickly in my archive, and, yes, time flies :-(

> i don't know whether it's possible or desirable to reopen it.

I guess that I have to re-read the thread carefully,
but I also understand that John doesn't want to make
such late changes. ;-)

Cheers,
 Roland

---

From: Martin Stiemerling <[email-masked]>
Date: Wed, 8 Mar 2006 10:03:59 +0100

Am 07.03.2006 um 14:50 schrieb Hancock, Robert:

[...]

> i don't know whether it's possible or desirable to reopen it.

I wouldn't like to reopen it but at the point when discussing it in
the past, we haven't had the NSLPs we have now. I would
prefer a short status check whether the assumptions of the
2004 discussions still hold.

There is also another issue: The error code registry.
I think this is going to separated between the different NSLPs, since
the severity classes of the QoS and NATFW NSLP differ quite much
as the response codes do as well.

   Martin

---

From: <[email-masked]>
Date: Sat, 18 Mar 2006 20:37:50 +0200

Martin,

>I wouldn't like to reopen it but at the point when discussing 
>it in the past, we haven't had the NSLPs we have now. I would 

I think that a common NSLP registry is a good thing, as the NSLPs
will have more in common than unrelated protocols, IMO.  However,
I think the common registry could be for broad issues.

>I think this is going to separated between the different 
>NSLPs, since the severity classes of the QoS and NATFW NSLP 
>differ quite much as the response codes do as well.

So, would a common registry be acceptable if we allow a
specific registry for some issues like error codes?

John