Subject: Re: [NSIS] PACKET_CLASSIFIER in RESERVE adn QUERY

From: Andrew McDonald <[email-masked]>
Date: Fri, 03 Mar 2006 09:28:31 +0000

Hi Georgios,

A long time ago,
Georgios Karagiannis wrote:
> During some previous discussions have been emphasized that the 
> PACKET_CLASSIFIER is only usefull
> if it is carried by RESERVE messages.
> The other three QOS-NSLP messages, i.e., QUERY, NOTIFY and RESPONSE 
> messages do not need
> to carry the PACKET_CLASSIFIER object.
> I think that I would agree that the messages NOTIFY and RESPONSE do not 
> need to carry
> the PACKET_CLASSIFIER
> object, but I think that we should provide the
> ability to future QoS models to use the PACKET_CLASSIFIER also in the 
> QUERY messages.
>  
> Thus my proposal is:
>  
> * Provide the possibility to use the PACKET_CLASSIFIER in RESERVE and 
> QUERY messages. 

I think this was addressed by adding the PACKET_CLASSIFIER in to the BNF 
for the QUERY.

In draft -09, RESERVE is defined as:
    RESERVE = COMMON_HEADER
              RSN [ RII ] [ REFRESH_PERIOD ] [ n*BOUND_SESSION_ID ]
              [ POLICY_DATA ] [ PACKET_CLASSIFIER ] [ QSPEC ] [ QSPEC ]

QUERY is:
    QUERY = COMMON_HEADER
            [ RII ][ n*BOUND_SESSION_ID ]
            [ POLICY_DATA ] PACKET_CLASSIFIER QSPEC [ QSPEC ]

So, in RESERVE PACKET_CLASSIFIER is optional, whereas in QUERY it is 
compulsory.

The optionality of PACKET_CLASSIFIER in RESERVE is linked in the text to 
reduced refreshes. But, the BNF says that you can have a QSPEC but not 
PACKET_CLASSIFIER. So, should the BNF be something more like:
    RESERVE = COMMON_HEADER
              RSN [ RII ] [ REFRESH_PERIOD ] [ n*BOUND_SESSION_ID ]
              [ POLICY_DATA ] [ PACKET_CLASSIFIER QSPEC [ QSPEC ] ]

As an additional thought, in many cases the packet classifier will be 
the same as the MRI. So, could absence of a PACKET_CLASSIFIER object, 
when a QSPEC is provided, indicate that packet classification should be 
done using the whole MRI?

The resulting BNF would be:
    RESERVE = COMMON_HEADER
              RSN [ RII ] [ REFRESH_PERIOD ] [ n*BOUND_SESSION_ID ]
              [ POLICY_DATA ] [ [ PACKET_CLASSIFIER ] QSPEC [ QSPEC ] ]
    QUERY = COMMON_HEADER
            [ RII ][ n*BOUND_SESSION_ID ]
            [ POLICY_DATA ] [ PACKET_CLASSIFIER ] QSPEC [ QSPEC ]

Any opinions?

regards,

Andrew

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Jukka MJ Manner <[email-masked]>
Date: Fri, 3 Mar 2006 11:31:06 +0200 (EET)

Hi,
fine with me.

Jukka

On Fri, 3 Mar 2006, Andrew McDonald wrote:

> > The other three QOS-NSLP messages, i.e., QUERY, NOTIFY and RESPONSE messages
> > do not need
> > I think that I would agree that the messages NOTIFY and RESPONSE do not need
> > to carry
> > the PACKET_CLASSIFIER
> > ability to future QoS models to use the PACKET_CLASSIFIER also in the QUERY
> > messages.
> >  Thus my proposal is:
> >  * Provide the possibility to use the PACKET_CLASSIFIER in RESERVE and QUERY
> > messages. 
> 
> I think this was addressed by adding the PACKET_CLASSIFIER in to the BNF for
> the QUERY.
> 
> As an additional thought, in many cases the packet classifier will be the same
> as the MRI. So, could absence of a PACKET_CLASSIFIER object, when a QSPEC is
> provided, indicate that packet classification should be done using the whole
> MRI?
>

---

From: Andrew McDonald <[email-masked]>
Date: Fri, 03 Mar 2006 09:33:50 +0000

> fine with me.

Which one? The basic fix to the RESERVE BNF, or the absence of 
PACKET_CLASSIFER means that you use the full MRI?
:-)

Andrew

-- 
Andrew McDonald, Senior Engineer
Roke Manor Research Ltd, Romsey, Hants  SO51 0ZN
Phone +44 (0)1794 833833   Fax +44 (0)1794 833616

---

From: Jukka MJ Manner <[email-masked]>
Date: Fri, 3 Mar 2006 11:47:29 +0200 (EET)

I meant the latter one.

Jukka

On Fri, 3 Mar 2006, Andrew McDonald wrote:

> > > > messages
> > > > need
> > > > QUERY
> > > > QUERY
> > > for