Subject: [NSIS] Re: GIST issue - MA-Hello reply

From: Roland Bless <[email-masked]>
Date: Thu, 19 Oct 2006 01:10:47 +0200

Hi Robert,

I just saw that the state diagram in figure 8
gives a more detailed hint, that one should reply with an
MA-Hello message (cf. Rule 3, IMHO, the text in 5.1 should
state this also clearly then).

But I don't quite understand why
Rule 7 says "stop SendHello timer".
This leads to the situation that we don't send
any MA-Hello messages anymore and the other side
will go to Idle and Death as well leading us to
MA-Death, so the MA is closed down. Isn't it the
intention to keep the MA open by sending MA-Hellos?

Regards,
 Roland

Roland Bless wrote:
> the current Spec says in sec. 5.1:
>  MA-Hello: ....
>                                              The R flag MAY be set
>    (R=1); if so, the peer MUST send another message back along the
>    messaging association.
> 
> I need some guidance here: what message should be sent as response?
> If one is queued for transmission no problem, but if sending
> an MA-Hello back I guess it makes sense to require that the
> R flag MUST not be set if an MA-Hello is sent back as response
> to an incoming MA-Hello with R flag set. Otherwise both sides
> would keep sending MA-Hellos without pause.
> 
> Regards,
>  Roland
> 

-- 
Dr. Roland Bless -- WWW: http://www.tm.uka.de/~bless
Institut für Telematik, Universität Karlsruhe (TH), Germany
Zirkel 2, D-76128 Karlsruhe -- Geb. 20.20, 3.OG, Raum 358
Tel.: +49 721 608-6413 Fax: +49 721 608-6789

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Thu, 19 Oct 2006 00:36:37 +0200

Hi Robert,

Regards,
 Roland