Subject: [NSIS] GIST issue - PATH MTU v4/v6

From: Roland Bless <[email-masked]>
Date: Thu, 19 Oct 2006 13:49:22 +0200

Hi,

short question. The draft says:
   Any message sent in D-mode MUST have a size below a conservative
   estimate of the path MTU, for which this specification takes the
   value 512 bytes as a default.  It is possible that fragmented

Would it be reasonable to have different path MTUs for v4 and v6?
For the latter the path MTU could be larger due to its 1280 bytes
requirement.

Regards,
 Roland

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: "Robert Hancock" <[email-masked]>
Date: Thu, 19 Oct 2006 14:08:17 +0200

hi roland,

if you are interested in MTU issues, you might in any case
like to check the revised text at
http://nsis.srmr.co.uk/cgi-bin/roundup.cgi/nsis-ntlp-issues/issue124
(this is following up Lar's DISCUSS comments).

on the v4/v6 question, i'd rather not distinguish between the two:

- i don't know how it would cope with some transition mechanisms
(you could still get fragmentation)

- we know 512 is fine for v4 or v6 (if it isn't we are in trouble)

- if you know you are in a homogeneous v6 network, you know the
larger PMTU anyway as 1280 so that case is covered in the new text.

cheers,

robert h.

> -----Original Message-----
> From: Roland Bless [mailto:[email-masked]] 
> Sent: 19 October 2006 13:49
> To: [email-masked]
> Subject: [NSIS] GIST issue - PATH MTU v4/v6
> 
> 
> Hi,
> 
> Would it be reasonable to have different path MTUs for v4 and 
> v6? For the latter the path MTU could be larger due to its 
> 1280 bytes requirement.
> 
> Regards,
>  Roland
>

---

From: Roland Bless <[email-masked]>
Date: Thu, 19 Oct 2006 17:42:15 +0200

Hi Robert,

> (you could still get fragmentation)

Hmm, this might be a problem...

> - we know 512 is fine for v4 or v6 (if it isn't we are in trouble)

Yep. However, it would be good to also state this explicitly
so that v6 implementations follow the same max size as with v4,
e.g. "...value 512 bytes as a default (also for IPv6). "

Regards,
 Roland