Subject: [NSIS] GIST over GIST-unaware NATs

From: Xiaoming Fu <[email-masked]>
Date: Wed, 11 Oct 2006 21:49:25 +0200

Hi all,

There were some IESG discussions on GIST over GIST-unaware NATs.  I
read through draft-pashalidis-nsis-gist-legacynats-00 and found it makes
a number of clarifications on this issue:

- The presence of a GIST-unaware NAT can be detected by comparing 
headers of the GIST query-response procedure message in the two adjacent
non-NAT GIST nodes.

- Upon the detection of such a NAT (and affiliated rules), these two 
GIST nodes can then establish a UDP tunnel between them, and encapsulate 
the GIST messages (query-response-...) into the tunnel, and the outgoing 
tunnel endpoints decapsulate the messages into the desired format.

- The draft also gives detailed description on GIST signaling and data 
traffic processing in both the case where a NAT is located close to the 
NI and the case where a NAT is close to the NR. The rationale looks fine 
to me. If there is an implementation demoing this, it would be even nicer.

What do others think?
Xiaoming

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: <[email-masked]>
Date: Thu, 12 Oct 2006 06:14:40 +0300

Actually, I think this should be added as a WG document.  

Comments?
John 

>-----Original Message-----
>From: ext Xiaoming Fu [mailto:[email-masked]] 
>Sent: 11 October, 2006 22:49
>To: [email-masked]
>Subject: [NSIS] GIST over GIST-unaware NATs
>
>Hi all,
>
>There were some IESG discussions on GIST over GIST-unaware 
>NATs.  I read through draft-pashalidis-nsis-gist-legacynats-00 
>and found it makes a number of clarifications on this issue:
>
>- The presence of a GIST-unaware NAT can be detected by 
>comparing headers of the GIST query-response procedure message 
>in the two adjacent non-NAT GIST nodes.
>
>- Upon the detection of such a NAT (and affiliated rules), 
>these two GIST nodes can then establish a UDP tunnel between 
>them, and encapsulate the GIST messages (query-response-...) 
>into the tunnel, and the outgoing tunnel endpoints decapsulate 
>the messages into the desired format.
>
>- The draft also gives detailed description on GIST signaling 
>and data traffic processing in both the case where a NAT is 
>located close to the NI and the case where a NAT is close to 
>the NR. The rationale looks fine to me. If there is an 
>implementation demoing this, it would be even nicer.
>
>What do others think?
>Xiaoming
>

---

From: Martin Stiemerling <[email-masked]>
Date: Thu, 12 Oct 2006 09:02:39 +0200

I'm in favour of having such document dealing with GIST-unaware NAT  
traversal. However, I haven't read the latest version of draft- 
pashalidis-nsis-gist-legacynats-00 by now (on my record for the next  
days).

   Martin

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Thu, 12 Oct 2006 15:29:35 +0200

Hi 

I agree with John on this!
It is important to provide (next steps) solutions on this and therefore 
it is good to have it as a WG document.

Best regards,
Georgios

> From: [email-masked] [mailto:[email-masked]] 
> Sent: donderdag 12 oktober 2006 5:15
> To: [email-masked]; [email-masked]
> Subject: RE: [NSIS] GIST over GIST-unaware NATs
> 
> >read through draft-pashalidis-nsis-gist-legacynats-00
> >headers of the GIST query-response procedure message in the two 
> >adjacent non-NAT GIST nodes.
> >
> >GIST nodes can then establish a UDP tunnel between them, and 
> >encapsulate the GIST messages (query-response-...) into the 
> tunnel, and 
> >the outgoing tunnel endpoints decapsulate the messages into 
> the desired 
> >format.
> >
> >NI and the case where a NAT is close to the NR. The rationale looks 
> >fine to me. If there is an implementation demoing this, it would be 
> >even nicer.
> >
> >What do others think?
> >Xiaoming
> >