Subject: [NSIS] Voting: REA Naming Contest (reanco) - the candidates

From: Martin Stiemerling <[email-masked]>
Date: Fri, 6 Oct 2006 16:21:36 +0200

Dear all,

Even though the REA naming contest (reanco) got stuck for a while,  
it's still running.

The deadline for submitting proposals was Aug 3rd and the final  
decision should be made before the next IETF meeting for two reasons:  
a) getting the name in the draft  and b) some beer for the winner at  
the IETF.

The candidates for the name we have (given order is **NO** ranking!):

a) Open Internal Path (OIP) message <-- my favourite
b) Configure Internal Path (CIP) message
c) Prepare For Ucreate (PFU) message (where UCREATE is actually now REA)
d) Internal Network Configuration (INC) message
e) EXT (for playing with the external address and opening firewall  
holes for external data senders (incoming streams))
f) Open Path Interactive (OPI) message
g) Open Interactive Path (OIP) message
h) Path Opening Interactive (POI) message
i) Interactive Path Opening (IPO) message
j) CREATE -> ICREATE (Initiator CREATE); REA -> RCREATE (Responder  
CREATE)
k) CREATE -> SCREATE (Sender CREATE); REA -> RCREATE (Receiver CREATE)

**Please send me directly an email with your vote, stating whether  
you prefer any out of a) to k)!

**All votes MUST be done, i.e., in my inbox, by October 12th, 11pm  
Pacific Time.

**If there is no voting at all, the authors will rule the new name.

Happy voting!!

   Martin

Am 13.07.2006 um 15:32 schrieb Martin Stiemerling:

> Dear All,
>
> We have discussed about the naming issues for the NATFW NSLP's
> RESERVE-EXTERNAL-ADDRESS (REA) message.
>
> In the past revisions of the NATFW NSLP REA has been used to obtain an
> external IP address/port at the outermost NAT (and at in between NATs
> too).
> But the semantics of REA changed over time from purely NAT usage to a
> combined NAT and firewall usage, i.e., a combination of the old REA  
> and
> the old UCREATE.
>
> REA is used for:
> - Used to get external address/port at NAT
> - Used to install firewall rules for inbound traffic
> - Used in proxy mode usage
>
> So the current name is not really describing the semantics/usage  
> anymore
> and we need to something different. Since the authors haven't had any
> good idea and some off-line discussions didn't bring a good name, we
> are starting the
>
>                                REA naming contest (reanco)
>
> This contest calls the NSIS WG for input on name suggestions for the
> message currently called REA.
>
> The contest starts today (actually already yesterday during the  
> session)
> and will run until  August 3rd 8am EST. Suggestion made after
> August 3rd EST are not accepted anymore. All suggestions must be sent
> to the NSIS working group list ([email-masked]). It is not valid to  
> use a
> naming generator that simply tries combinations of characters.
>
> The one who has suggested the name that will be finally taken as  
> the new
> name for REA will be awarded with a six-pack of local beer at next
> IETF in
> San Diego. If there are multiple people suggesting the same name, they
> must share the six pack (sorry for that, but not enough money for  
> it ;-)
>
> Of course all things apply here: participants must be older than 18
> or 21 years
> (depending on location of IETF and the local laws), no guarantees,
> not entitled
> for anything, must be at the next IETF meeting in San Diego in
> November 2006,
> no monetary refunding, etc...
>
>
> So, looking forward to many suggestion for a "new REA".
>
>    Martin for the NATFW NSLP authors.
>
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/nsis

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Martin Stiemerling <[email-masked]>
Date: Tue, 10 Oct 2006 10:24:30 +0200

Just a reminder.

   Martin

Anfang der weitergeleiteten E-Mail:

> Von: Martin Stiemerling <[email-masked]>
> Datum: 6. Oktober 2006 16:21:36 MESZ
> An: nsis <[email-masked]>
> Betreff: [NSIS] Voting: REA Naming Contest (reanco) - the candidates
>
> Dear all,
>
> decision should be made before the next IETF meeting for two  
> reasons: a) getting the name in the draft  and b) some beer for the  
> winner at the IETF.
>
>> combined NAT and firewall usage, i.e., a combination of the old  
>> REA and
>> the old UCREATE.
>>
>> REA is used for: