Subject: [NSIS] Re: I-D ACTION:draft-mcdonald-nsis-router-alert-iana-00.txt

From: Andrew McDonald <[email-masked]>
Date: Mon, 23 Oct 2006 10:52:23 +0100

Hi all,

Following on from previous discussion we had on the topic (going back to 
the Dallas meeting and before) I wrote a short draft on IANA management 
of Router Alert Option Values.

Currently, the QoS and NAT/FW NSLPs (as suggested by GIST) request 
allocation of RAO values. However, there isn't an IPv4 registry to 
manage them. So, if we want to be able to use values other than the 
default value (i.e. 0 = router shall examine packet), I believe we need 
to sort out the Router Alert IANA issues.

The draft also considers possible ways of aligning the RAO value usage 
for IPv4 and IPv6. The draft doesn't attempt to discuss when you 
should/shouldn't use router alert, or should/shouldn't get a new RAO 
value, though those might be things worth including.

Read, comment, tear to shreds, etc

Andrew

[email-masked] wrote:
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> 
> 
> 	Title		: IANA Considerations for the IPv4 and IPv6 Router Alert Option
> 	Author(s)	: A. McDonald
> 	Filename	: draft-mcdonald-nsis-router-alert-iana-00.txt
> 	Pages		: 9
> 	Date		: 2006-10-18
> 	
>    This document provides new instructions to IANA on the allocation of
>    IPv4 and IPv6 Router Alert Option Values.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-mcdonald-nsis-router-alert-iana-00.txt
> 
> To remove yourself from the I-D Announcement list, send a message to 
> [email-masked] with the word unsubscribe in the body of 
> the message. 
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
> to change your subscription settings.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the 
> username "anonymous" and a password of your e-mail address. After 
> logging in, type "cd internet-drafts" and then 
> "get draft-mcdonald-nsis-router-alert-iana-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-mcdonald-nsis-router-alert-iana-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Fri, 27 Oct 2006 16:14:17 +0200

Hi Andrew,

> Read, comment, tear to shreds, etc

Great that you wrote that down. Now it's clear where
the problems are.
I guess that we probably need more feedback, esp.
from vendors and operators, about the current
deployment of these RAO values. If not they are
currently not really in wide use, then reassignment
may not be a big problem. Otherwise we must try tro
preserve some backwards compatability. So bringing
the draft to the attention of a wider community
should be considered IMHO.

Regards,
 Roland