Subject: [NSIS] messages content

From: Lars Westberg <[email-masked]>
Date: Mon, 16 Oct 2006 15:12:49 +0200

hi,
I am trying to make understand how NTLP-works in more detail.
I am missing a more detailed description about the explicit message 
format of the mandatory part of the messages.

Can somone help me with a pointer to such information ?

regards Lasse

_______________________________________________
nsis mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/nsis

---

From: Roland Bless <[email-masked]>
Date: Tue, 17 Oct 2006 09:24:53 +0200

Hi Lars,

> format of the mandatory part of the messages.

Sorry, I don't get the point. It's all in the draft, see below.

> Can somone help me with a pointer to such information ?

You can find the GIST message format in section 5.1 (p.35)
and the binary formats in Appendix A or draft-ietf-nsis-ntlp-11.txt.

Regards,
 Roland

---

From: Roland Bless <[email-masked]>
Date: Tue, 17 Oct 2006 09:30:25 +0200

> and the binary formats in Appendix A or draft-ietf-nsis-ntlp-11.txt.
Typo: s/or/of (or should be read of)
and its on p. 100.

 Roland

---

From: Lars Westberg <[email-masked]>
Date: Tue, 17 Oct 2006 09:37:54 +0200

I have looked through the documet and it's very difficult to interprete 
the all statements. It is too many options an features in the the 
specification.

I am after examples of message structures and sequence diagram so I can 
verify my assumptions.
I would be very happy if someone can help me with such information.

regards Lasse

---

From: Roland Bless <[email-masked]>
Date: Tue, 17 Oct 2006 09:46:21 +0200

Hi Lars,

> the all statements. It is too many options an features in the the

It's somewhat complex, but implementable. A student of mine
was able to do a full implementation within 6 months.

> I would be very happy if someone can help me with such information.

Protocol state machines are in Chapter 6 (see p. 62 and 65)
and message structures in Chapter 5. If this doesn't help
you may ask your question on the list.

Regards,
 Roland

---

From: "Lars Westberg \(KI/EAB\)" <[email-masked]>
Date: Tue, 17 Oct 2006 09:51:39 +0200

comments inline

-----Original Message-----
From: Roland Bless [mailto:[email-masked]] 
Sent: den 17 oktober 2006 09:46
To: Lars Westberg (KI/EAB)
Cc: [email-masked]; Hancock, Robert
Subject: Re: [NSIS] messages content

Hi Lars,

Lars Westberg wrote:
> I have looked through the documet and it's very difficult to 
> interprete the all statements. It is too many options an features in 
> the the specification.

It's somewhat complex, but implementable. A student of mine was able to
do a full implementation within 6 months.

I do not have six-months to spend of it. I would rather prefer a
fast-track solution.

> I am after examples of message structures and sequence diagram so I 
> can verify my assumptions.

Protocol state machines are in Chapter 6 (see p. 62 and 65) and message
structures in Chapter 5. If this doesn't help you may ask your question
on the list.

I can't all questions on the list.  I would rather appreciate an example
implementation of it with message shown in text-format. Does the
implementation showing the messages in text ??

If so, I am interested in it. Is it possible to get a copy ???

Regards,
 Roland

-Lasse

---

From: "Robert Hancock" <[email-masked]>
Date: Tue, 17 Oct 2006 11:09:50 +0200

lars,

if you want examples, then the handshake is in section 4.4.1
just listing the message objects, and an example with textual
versions of the fields is in appendix C. if you want to 
understand the basic concepts, read section 3. if you want
something else, please say what it is.

cheers,

robert h.

> From: Lars Westberg (KI/EAB) [mailto:[email-masked]] 
> Sent: 17 October 2006 09:52
> To: Roland Bless
> Subject: RE: [NSIS] messages content
> 
> 
>  comments inline
> 
> I do not have six-months to spend of it. I would rather 
> prefer a fast-track solution.
> 
> and message structures in Chapter 5. If this doesn't help you 
> may ask your question on the list.
> 
> I can't all questions on the list.  I would rather appreciate 
> an example implementation of it with message shown in 
> text-format. Does the implementation showing the messages in text ??
>

---

From: Xiaoming Fu <[email-masked]>
Date: Tue, 17 Oct 2006 11:37:17 +0200

hi lars,

according to our experience, a state machine based description helps 
towards an easy implementation and maintenance.
we have implemented the ntlp according to the fsm specified in 
http://tools.ietf.org/wg/nsis/draft-ietf-nsis-ntlp-statemachine/
more implementation-specific guidelines are planned to be provided in a 
few update of the doc. as you might know, the code is available at 
http://user.informatik.uni-goettingen.de/~nsis/

cheers,
xiaoming

-- 
Cheers,

Xiaoming
--
http://user.informatik.uni-goettingen.de/~fu

---

From: Roland Bless <[email-masked]>
Date: Tue, 17 Oct 2006 11:53:59 +0200

Hi Lars,

>  comments inline

dito

> I do not have six-months to spend of it. I would rather prefer a

I guess you don't need 6 months to read and understand the spec,
I meant a full implementation including writing and testing the code.

> implementation showing the messages in text ??

Yep, e.g.: an incoming connection with query/response/confirm
(C-Mode setup) may look like this:
2006-10-13 14:10:43.626-20911- EVENT /4: GIST Processing Received
message #5 (SigInd) from: Signaling, signaling peer: 193.136.212.219, PDU:
<query>:   NSLP ID: 1
Message Routing Information <mri_pathcoupled>: (0)
MRM-ID:
IP-Version:             4
Flags:                  PAB
Source Address:         193.136.212.219
Destination Address:    193.136.212.216
Source Prefixlen:       27
Destination Prefixlen:  27
IP-Protocol:               udp
Destination Port:       8080
Source Port:            8080
Direction: Downstream

   SessionID <sessionid>: 666f6f62-61727769-62626c65-00000000

NLI <nli>: (0)

PI length: 4
IP_TTL: 0
IP_Version: 4
RSV_Time: 150000
PI:
IF_Address: 193.136.212.219

   Query Cookie : <0x517565727920436f6f6b69652066726f6d20616631000000>

   StackProposal
Profiles: 1
1 MA fields: <1>

   StackConfigurationData
Profiles: 1
MA-Hold Time: 10000 ms
Protocol: 1 Profile: 0 Configuration Data:
----------------------------------------------------------------------------
2006-10-13 14:10:43.640-20911- DEBUG /4: GIST Signaling  Sending:
<response>:   NSLP ID: 1
Message Routing Information <mri_pathcoupled>: (0)
MRM-ID:                 IP-Version:             4
Flags:                  PABD
Source Address:         193.136.212.219
Destination Address:    193.136.212.216
Source Prefixlen:       27
Destination Prefixlen:  27
IP-Protocol:               udp
Destination Port:       8080
Source Port:            8080
Direction: Upstream

   SessionID <sessionid>: 666f6f62-61727769-62626c65-00000000

NLI <nli>: (0)

PI length: 16
IP_TTL: 0
IP_Version: 4
RSV_Time: 60000
PI:
IF_Address: 193.136.212.216

   Query Cookie : <0x517565727920436f6f6b69652066726f6d20616631000000>

   Responder Cookie : <0x31850f42b79f123151eac346592934685ab8ef5772b0112f>

   StackProposal
Profiles: 2
1 MA fields: <1>
2 MA fields: <2> <1>

   StackConfigurationData
Profiles: 2
MA-Hold Time: 180000 ms
Protocol: 1 Profile: 1 Configuration Data: <75> <30> (30000)
Protocol: 1 Profile: 2 Configuration Data: <75> <31> (30001)
--------------------------------------------------------------------
2006-10-13 14:10:43.748-20911- EVENT /4: GIST Processing Received
message #12 (SigInd) from: Signaling, signaling peer:
::ffff:193.136.212.219, PDU:
<confirm>:
Message Routing Information <mri_pathcoupled>: (0)
MRM-ID:                 IP-Version:             4
Flags:                  PAB
Source Address:         193.136.212.219
Destination Address:    193.136.212.216
Source Prefixlen:       27
Destination Prefixlen:  27
IP-Protocol:               udp
Destination Port:       8080
Source Port:            8080
Direction: Downstream

   SessionID <sessionid>: 666f6f62-61727769-62626c65-00000000

NLI <nli>: (0)

PI length: 4
IP_TTL: 0
IP_Version: 4
RSV_Time: 150000
PI:
IF_Address: 193.136.212.219

   Responder Cookie : <0x31850f42b79f123151eac346592934685ab8ef5772b0112f>

   StackProposal
Profiles: 2
1 MA fields: <1>
2 MA fields: <2> <1>

   StackConfigurationData
Profiles: 0
MA-Hold Time: 10000 ms
-----------------------------------------------------------------

> If so, I am interested in it. Is it possible to get a copy ???

I can sent you a full copy of our log output from one of our
recent interop-tests if that helps.

Regards,
 Roland

---

From: Lars Westberg <[email-masked]>
Date: Tue, 17 Oct 2006 12:28:22 +0200

yes, thanks, that would be very nice.

regards Lasse

---

From: Christian Dickmann <[email-masked]>
Date: Tue, 17 Oct 2006 10:50:55 -0400

Hi,

I am the main developer of the GIST implementation of the University of 
Goettingen.
To me, the draft explains how messages look like pretty well and I have 
no clue how
the draft could be more precise (from the structure point of view).

> If so, I am interested in it. Is it possible to get a copy ???

We implemented an dissector, which is able to display GIST (and QoS, 
NATFW, etc.)
messages in the popular network protocol analyzer Ethereal (now known as 
Wireshark).
In addition, we got several captures of NSIS sessions (some of them 
captured at the
recent Interop event) that we can provide.
So with this, you can look at every message, look at every detail you 
want and see how
GIST works in real life.

Please have a look at 
http://user.informatik.uni-goettingen.de/~nsis/ethereal.html

Christian Dickmann

---

From: <[email-masked]>
Date: Tue, 17 Oct 2006 19:38:25 +0300

Thanks for the note Christian. Running code is a very important
things to consider here.

I think that this seems like very good information.  As this is more of
a discussion 
(if needed) to carry on the NSIS Implementor's list, if people want to
get discuss support
in Wireshark or packet logs.

thanks,
John

>From: ext Christian Dickmann [mailto:[email-masked]] 
>Sent: 17 October, 2006 07:51
>Cc: [email-masked]
>I am the main developer of the GIST implementation of the 
>University of Goettingen.
>To me, the draft explains how messages look like pretty well 
>and I have no clue how the draft could be more precise (from 
>the structure point of view).
>
>> I can't all questions on the list.  I would rather appreciate an 
>> example implementation of it with message shown in text-format. Does 
>> the implementation showing the messages in text ??
>>
>We implemented an dissector, which is able to display GIST 
>(and QoS, NATFW, etc.) messages in the popular network 
>protocol analyzer Ethereal (now known as Wireshark).
>In addition, we got several captures of NSIS sessions (some of 
>them captured at the recent Interop event) that we can provide.
>So with this, you can look at every message, look at every 
>detail you want and see how GIST works in real life.
>
>Please have a look at

---

From: Martin Stiemerling <[email-masked]>
Date: Thu, 19 Oct 2006 16:11:29 +0200

(NSIS co-chair hat off -- implementors hat on)

I have been also implementing the NTLP and it took me 2 weeks to get  
a basic version up and running. This version has been tested at the  
Paris interop event in Summer 2005.

So my from point of view as an implementor I couldn't say which part  
of the NTLP draft is unclear or not easy to be implemented. It is an  
excellent protocol specification!

   Martin

Am 17.10.2006 um 16:50 schrieb Christian Dickmann:

> To me, the draft explains how messages look like pretty well and I  
> have no clue how
>> example
> We implemented an dissector, which is able to display GIST (and  
> QoS, NATFW, etc.)
> messages in the popular network protocol analyzer Ethereal (now  
> known as Wireshark).
> So with this, you can look at every message, look at every detail  
> you want and see how
> GIST works in real life.
>
> Please have a look at http://user.informatik.uni-goettingen.de/ 
> ~nsis/ethereal.html
>
> Christian Dickmann
>
>