Subject: [NSIS] Small change to QoS NSLP INFO_SPEC

From: Jukka Manner <[email-masked]>
Date: Fri, 22 Jan 2010 13:10:01 +0200

While answering IANA's questions to the QoS NSLP, there is one item that 
would warrant some discussion:

The Error code is a 16-bit field (65536 values), while we only have 
values up to around 10 per Error Class. The NATFW NSLP only uses an 
8-bit code space.

Proposal: change the field to 8-bits and leave 8 bits reserved for 
future use (NATFW NSLP does the same actually, 4+4bits).

Opinions?

Jukka

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 22 Jan 2010 13:33:09 +0100

Hi Jukka

> Proposal: change the field to 8-bits and leave 8 bits 
> reserved for future use (NATFW NSLP does the same actually, 4+4bits).

I agree with your proposal!

Best regards,
Georgios

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Jukka Manner
> Sent: vrijdag 22 januari 2010 12:10
> To: [email-masked]
> Subject: [NSIS] Small change to QoS NSLP INFO_SPEC
> 
> While answering IANA's questions to the QoS NSLP, there is 
> one item that would warrant some discussion:
> 
> The Error code is a 16-bit field (65536 values), while we 
> only have values up to around 10 per Error Class. The NATFW 
> NSLP only uses an 8-bit code space.
> 
> Proposal: change the field to 8-bits and leave 8 bits 
> reserved for future use (NATFW NSLP does the same actually, 4+4bits).
> 
> Opinions?
> 
> Jukka
>

---

From: Gerald Ash <[email-masked]>
Date: Mon, 25 Jan 2010 12:20:16 -0800 (PST)

Hi Jukka,

> reserved for future use (NATFW NSLP does the same actually, 4+4bits).
 
Looks OK to me.
 
This means that the Error Code Registry for Error Class = 0x06 (QoS Model Error), as specified in QSPEC Section 7 (IANA Considerations), needs to be changed to allow 8 bits rather than 16 bits.
 
Is this change now decided?
 
Thanks,
Jerry

---

From: Roland Bless <[email-masked]>
Date: Mon, 25 Jan 2010 23:14:45 +0100

Hi Jukka and all,

> Opinions?

Sounds ok to me, so error class remains 4 bits and error code
is 8 bit. The header will then look like this?

    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |    Reserved   |  Error Code   |E-Class|ESI Typ|   ESI-Length  |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Regards,
 Roland

---

From: Jukka Manner <[email-masked]>
Date: Tue, 26 Jan 2010 14:41:35 +0200

Yes.

Jukka

On 26.1.2010 0:14, Roland Bless wrote:
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nsis

-- 
Jukka MJ Manner, Professor, PhD.  Phone:  +358+(0)9+470 22481
Aalto University                  Mobile: +358+(0)50+5112973
Department of Communications      Fax:    +358+(0)9+470 22474
and Networking (Comnet)           Office: G320a (Otakaari 5A)
P.O. Box 13000, FIN-00076 Aalto   E-mail: [email-masked]
Finland                           www.netlab.hut.fi/~jmanner/