Subject: [NSIS] FW: I-D Action:draft-ietf-nsis-nslp-natfw-23.txt

From: "Martin Stiemerling" <[email-masked]>
Date: Fri, 5 Feb 2010 17:04:14 +0100

Hi,

There is again an updated NATFW NSLP draft:
- removed appendix d: protocols numbers for testing
- new appendix d: example for receiver proxy case

I hope that fixes Magnus' comments.

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Friday, February 05, 2010 5:00 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [NSIS] I-D Action:draft-ietf-nsis-nslp-natfw-23.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Next Steps in Signaling Working Group
> of the IETF.
> 
> 
> 	Title           : NAT/Firewall NSIS Signaling Layer Protocol
> (NSLP)
> 	Author(s)       : M. Stiemerling, et al.
> 	Filename        : draft-ietf-nsis-nslp-natfw-23.txt
> 	Pages           : 97
> 	Date            : 2010-02-05
> 
> This memo defines the NSIS Signaling Layer Protocol (NSLP) for
> Network Address Translators (NATs) and firewalls.  This NSLP allows
> hosts to signal on the data path for NATs and firewalls to be
> configured according to the needs of the application data flows.  For
> instance, it enables hosts behind NATs to obtain a public reachable
> address and hosts behind firewalls to receive data traffic.  The
> overall architecture is given by the framework and requirements
> defined by the Next Steps in Signaling (NSIS) working group.  The
> network scenarios, the protocol itself, and examples for path-coupled
> signaling are given in this memo.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-nsis-nslp-natfw-23.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.

---

From: Magnus Westerlund <[email-masked]>
Date: Fri, 26 Feb 2010 15:25:50 +0100

> I hope that fixes Magnus' comments.

I have now reviewed your update. It looks good and seems to resolve my
issues. However, I do wonder if the External binding address object
should have an address family field. I don't want to be pessimistic but
I think there will exist some deployment of IPv6 NATs.

I will start the IETF last call, and you can take the above as the first
comment in IETF last call. I recommend the WG to review the changes as
they are significant and provide feedback.

Cheers

Magnus Westerlund

IETF Transport Area Director
----------------------------------------------------------------------
Multimedia Technologies, Ericsson Research EAB/TVM
----------------------------------------------------------------------
Ericsson AB                | Phone  +46 10 7148287
Färögatan 6                | Mobile +46 73 0949079
SE-164 80 Stockholm, Sweden| mailto: [email-masked]
----------------------------------------------------------------------