Subject: Re: [NSIS] FW: I-D Action:draft-ietf-nsis-nslp-natfw-23.txt

From: "Martin Stiemerling" <[email-masked]>
Date: Wed, 3 Mar 2010 17:42:15 +0100

> -----Original Message-----
> From: Magnus Westerlund [mailto:[email-masked]]
> Sent: Friday, February 26, 2010 3:26 PM
> To: Martin Stiemerling
> Cc: NSIS
> Subject: Re: [NSIS] FW: I-D Action:draft-ietf-nsis-nslp-natfw-23.txt
> 
> 
> I have now reviewed your update. It looks good and seems to resolve my
> issues. However, I do wonder if the External binding address object

Great - thanks!

> should have an address family field. I don't want to be pessimistic but
> I think there will exist some deployment of IPv6 NATs.

The object had an address family field in the past. However, this was kicked out as of WG consensus. All NAT stuff in the NATFW NSLP was IPv6 NAT capable in the past, but we removed this, as this type of NAT was considered very, very evil.

> 
> I will start the IETF last call, and you can take the above as the
> first
> comment in IETF last call. I recommend the WG to review the changes as

Hope my answer above addresses your concern.

Changing back would require IMHO a) an IETF consensus that we allow IPv6 NAT in general and b) WG consensus to bring the IPv6 NAT functionality back to the NSLP.

Thanks,

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014

---

From: "Martin Stiemerling" <[email-masked]>
Date: Thu, 4 Mar 2010 08:32:25 +0100

After sleeping a bit, I'm in favour of adding an address family field, but only specify IPv4 right now. 

Any objections from the WG?

[email-masked]

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Martin Stiemerling
> Sent: Wednesday, March 03, 2010 5:42 PM
> To: Magnus Westerlund
> Cc: NSIS
> The object had an address family field in the past. However, this was
> kicked out as of WG consensus. All NAT stuff in the NATFW NSLP was IPv6
> NAT capable in the past, but we removed this, as this type of NAT was
> considered very, very evil.
> 
> >
> Changing back would require IMHO a) an IETF consensus that we allow
> IPv6 NAT in general and b) WG consensus to bring the IPv6 NAT
> functionality back to the NSLP.
> 
> Thanks,
> 
>   Martin
> 
> [email-masked]
> 
> NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road,
> London W3 6BL | Registered in England 2832014
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nsis