Subject: [NSIS] NSLP Registry Question

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Fri, 18 Jun 2010 10:00:59 +0300

Hi all, 

We got a question about the NATFW NSLP parameter registry from IANA,
which I would like to bring forward to the group. 

What registries are actually shared between the different NSLPs.

To know what I mean have a look at
http://www.iana.org/assignments/nslp-parameters/nslp-parameters.xhtml

Are the following registries shared between NSLPs or not?
1) NSLPs have messages
2) NSLPs have objects
3) NSLPs have error classes 
4) NSLPs have error codes (which are sub-values of error classes)

In the current version of the IANA registry the answer is
(1) No, they are not shared. Two different registries are used. The
NATFW uses the "NATFW NSLP Message Types" and the QoS NSLP uses "QoS
NSLP Message Types". 
(2) Yes, they are shared, see NSLP Message Objects. 
(3) Yes, they are shared, see NSLP Error Classes. 
(4) That's where IANA came with a question to us because they did not
know what to do. 

Here is my suggestion: 

Ad 1) The messages have a very different semantic but putting them into
the same registry probably does not hurt. 
Ad 2) I am fine with using the same registry. 
Ad 3) Using the same error class sounds also useful. 
Ad 4) I believe that the error codes are so different for each NSLP that
they should go into a separate registry. 

This all assumes that only those values are used that are defined for a
specific NSLP and not randomly others from the same registry. 

Do others agree with me? I would like to close this issue!

Ciao
Hannes

---

From: "Martin Stiemerling" <[email-masked]>
Date: Fri, 18 Jun 2010 09:08:54 +0200

Hi,

We have basically the following situation:

The QoS and NATFW NSLP share the error classes, but have different error codes. The other parameters are fine. 
(http://www.iana.org/assignments/nslp-parameters/nslp-parameters.xhtml#error-classes)

I did do a instruction write-up for this and send it to IANA but IANA requested better text - which I still need to provide.

IANA wants specific and clear instructions what to do with error codes.

Everything else is already fixed with IANA it is just to have a proper write-up of the IANA instructions.

I felt to clarify this.

  Martin

[email-masked]

NEC Laboratories Europe - Network Research Division
NEC Europe Limited | Registered Office: NEC House, 1 Victoria Road, London W3 6BL | Registered in England 2832014 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Tschofenig, Hannes (NSN - FI/Espoo)
> Sent: Friday, June 18, 2010 9:01 AM
> To: NSIS
> Subject: [NSIS] NSLP Registry Question
> 
> Hi all,
> 
> _______________________________________________
> nsis mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/nsis

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Fri, 18 Jun 2010 10:48:19 +0300

Thanks Martin for the super quick response. 

In that case I would suggest to add the NSLP name to the different error
code registries, such as s/"Informational Error Codes"/"QoS NSLP
Informational Error Codes", etc. 

>From: ext Martin Stiemerling [mailto:[email-masked]] 
>Sent: 18 June, 2010 10:09
>To: Tschofenig, Hannes (NSN - FI/Espoo); NSIS
>Subject: RE: [NSIS] NSLP Registry Question
>
>Hi,
>
>The QoS and NATFW NSLP share the error classes, but have 
>different error codes. The other parameters are fine. 
>I did do a instruction write-up for this and send it to IANA 
>but IANA requested better text - which I still need to provide.
>
>Everything else is already fixed with IANA it is just to have 
>a proper write-up of the IANA instructions.
>
>I felt to clarify this.
>
>  Martin
>
>
>NEC Laboratories Europe - Network Research Division NEC Europe 
>Limited | Registered Office: NEC House, 1 Victoria Road, 
>London W3 6BL | Registered in England 2832014 
>
>
>> From: [email-masked] [mailto:[email-masked]] On Behalf 
>> Of Tschofenig, Hannes (NSN - FI/Espoo)
>> Ad 1) The messages have a very different semantic but putting them 
>> into the same registry probably does not hurt.
>> Ad 4) I believe that the error codes are so different for each NSLP 
>> that they should go into a separate registry.
>> 
>> This all assumes that only those values are used that are 
>defined for 
>> a specific NSLP and not randomly others from the same registry.
>>

---

From: "Martin Stiemerling" <[email-masked]>
Date: Fri, 18 Jun 2010 10:19:28 +0200

I did request this for the NATFW NSLP and did also for the QoS NSLP in the past, but just figured out that I forgot to remember IANA to do so. 

Let's wait for the answer from IANA (this is not sent via the NSIS ML) and request this afterwards.

Cheers,

  Martin

> From: Tschofenig, Hannes (NSN - FI/Espoo)
> [mailto:[email-masked]]
> Sent: Friday, June 18, 2010 9:48 AM
> To: Martin Stiemerling; NSIS