Subject: Re: [ntpwg] [ntp:hackers] Avoiding MD5

From: Dave Hart <[email-masked]>
Date: Sat, 14 Nov 2009 04:21:48 +0000

As of 4.2.5p244-RC, the support for alternate digest algorithms has
been extended to ntpdc, ntpq, and the ntp_intres resolver's use of
mode 7:

C:\>ntpq
ntpq> keytype sha1
ntpq> keytype
keytype is SHA1 with 20 octet digests
ntpq> keyid 1
ntpq> :config server rackety.udel.edu.
SHA1 Password:
Config Succeeded
ntpq> pe
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
...
 rackety.udel.ed .PPS.            1 u   20   64    1  227.846    0.723   0.977

Cheers,
Dave Hart
_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: Danny Mayer <[email-masked]>
Date: Thu, 07 Jan 2010 11:16:04 -0500

> been extended to ntpdc, ntpq, and the ntp_intres resolver's use of

Details of a specific change to an implementation of the NTP protocol
are not a subject for the working group.

Danny

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.