Subject: Re: [ntpwg] [Editorial Errata Reported] RFC5905 (4121)

From: Brian Haberman <[email-masked]>
Date: Wed, 24 Sep 2014 09:58:01 -0400

NTP folks,

On 9/23/14 1:28 PM, RFC Errata System wrote:
> The following errata report has been submitted for RFC5905,
> "Network Time Protocol Version 4: Protocol and Algorithms Specification".
> 
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata_search.php?rfc=5905&eid=4121
> 
> --------------------------------------
> Type: Editorial
> Reported by: Marina Gertsvolf <[email-masked]>
> 
> Section: 8
> 
> Original Text
> -------------
> In the exchange above, a packet is duplicate or
>    replay if the transmit timestamp t3 in the packet matches the org
>    state variable T3. 
> 
> Corrected Text
> --------------
> In the exchange above, a packet is duplicate or
>    replay if the transmit timestamp t3 in the packet matches the org
>    state variable. 
> 
> Notes
> -----
> The org state variable for peer A has not yet been assigned the value T3.
> 

Unless I am misreading 5905, I think this erratum is not correct.  The
paragraph above the one mentioned here explicitly says that the
corresponding state variables are set.  To me, this means T3 is set and
can be used in the comparison.

Can someone verify (or correct) my interpretation?

Regards,
Brian

_______________________________________________
ntpwg mailing list
[email-masked]
http://lists.ntp.org/listinfo/ntpwg

---

From: Brian Utterback <[email-masked]>
Date: Wed, 24 Sep 2014 11:13:46 -0400

Hi, Brian. I think that this whole diagram and text description is very 
hard to follow. I think that there is confusion here because there are 
three cases in the diagram which explicitly show this check being done 
(t4, t6 and t8) when in reality the checks are done at every receive of 
a packet, while this text is only referring to the receive done at t4. 
At t4 the org state variable is 0, so the note is correct. At least that 
is my interpretation of the diagram and text.

Brian Utterback